Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / ssh.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2013, 2014 Andreas Enge <andreas@enge.fr>
4 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
5 ;;; Copyright © 2015, 2016, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
6 ;;; Copyright © 2016, 2019 Leo Famulari <leo@famulari.name>
7 ;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
8 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
9 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
10 ;;; Copyright © 2017 Stefan Reichör <stefan@xsteve.at>
11 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
12 ;;; Copyright © 2017 ng0 <ng0@n0.is>
13 ;;; Copyright © 2018 Manuel Graf <graf@init.at>
14 ;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
15 ;;; Copyright © 2019, 2020 Mathieu Othacehe <m.othacehe@gmail.com>
16 ;;;
17 ;;; This file is part of GNU Guix.
18 ;;;
19 ;;; GNU Guix is free software; you can redistribute it and/or modify it
20 ;;; under the terms of the GNU General Public License as published by
21 ;;; the Free Software Foundation; either version 3 of the License, or (at
22 ;;; your option) any later version.
23 ;;;
24 ;;; GNU Guix is distributed in the hope that it will be useful, but
25 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
26 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
27 ;;; GNU General Public License for more details.
28 ;;;
29 ;;; You should have received a copy of the GNU General Public License
30 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
31
32 (define-module (gnu packages ssh)
33 #:use-module (gnu packages)
34 #:use-module (gnu packages autotools)
35 #:use-module (gnu packages base)
36 #:use-module (gnu packages boost)
37 #:use-module (gnu packages compression)
38 #:use-module (gnu packages crypto)
39 #:use-module (gnu packages elf)
40 #:use-module (gnu packages gnupg)
41 #:use-module (gnu packages gperf)
42 #:use-module (gnu packages groff)
43 #:use-module (gnu packages guile)
44 #:use-module (gnu packages libedit)
45 #:use-module (gnu packages linux)
46 #:use-module (gnu packages logging)
47 #:use-module (gnu packages m4)
48 #:use-module (gnu packages multiprecision)
49 #:use-module (gnu packages ncurses)
50 #:use-module (gnu packages nettle)
51 #:use-module (gnu packages kerberos)
52 #:use-module (gnu packages perl)
53 #:use-module (gnu packages pkg-config)
54 #:use-module (gnu packages popt)
55 #:use-module (gnu packages protobuf)
56 #:use-module (gnu packages python)
57 #:use-module (gnu packages python-xyz)
58 #:use-module (gnu packages readline)
59 #:use-module (gnu packages texinfo)
60 #:use-module (gnu packages tls)
61 #:use-module (gnu packages xorg)
62 #:use-module (guix build-system cmake)
63 #:use-module (guix build-system gnu)
64 #:use-module (guix build-system python)
65 #:use-module (guix download)
66 #:use-module (guix git-download)
67 #:use-module ((guix licenses) #:prefix license:)
68 #:use-module (guix packages)
69 #:use-module (guix utils)
70 #:use-module (srfi srfi-1))
71
72 (define-public libssh
73 (package
74 (name "libssh")
75 (version "0.9.4")
76 (source (origin
77 (method git-fetch)
78 (uri (git-reference
79 (url "https://git.libssh.org/projects/libssh.git")
80 (commit (string-append "libssh-" version))))
81 (sha256
82 (base32
83 "0qr4vi3k1wv69c95d9j26fiv78pzyksaq8ccd76b8nxar5z1fbj6"))
84 (file-name (git-file-name name version))))
85 (build-system cmake-build-system)
86 (outputs '("out" "debug"))
87 (arguments
88 '(#:configure-flags '("-DWITH_GCRYPT=ON")
89
90 ;; TODO: Add 'CMockery' and '-DWITH_TESTING=ON' for the test suite.
91 #:tests? #f))
92 (inputs `(("zlib" ,zlib)
93 ("libgcrypt" ,libgcrypt)
94 ("mit-krb5" ,mit-krb5)))
95 (synopsis "SSH client library")
96 (description
97 "libssh is a C library implementing the SSHv2 and SSHv1 protocol for client
98 and server implementations. With libssh, you can remotely execute programs,
99 transfer files, and use a secure and transparent tunnel for your remote
100 applications.")
101 (home-page "https://www.libssh.org")
102 (license license:lgpl2.1+)))
103
104 (define-public libssh2
105 (package
106 (name "libssh2")
107 (version "1.9.0")
108 (source (origin
109 (method url-fetch)
110 (uri (string-append
111 "https://www.libssh2.org/download/libssh2-"
112 version ".tar.gz"))
113 (sha256
114 (base32
115 "1zfsz9nldakfz61d2j70pk29zlmj7w2vv46s9l3x2prhcgaqpyym"))))
116 (build-system gnu-build-system)
117 ;; The installed libssh2.pc file does not include paths to libgcrypt and
118 ;; zlib libraries, so we need to propagate the inputs.
119 (propagated-inputs `(("libgcrypt" ,libgcrypt)
120 ("zlib" ,zlib)))
121 (arguments `(#:configure-flags `("--with-libgcrypt")))
122 (synopsis "Client-side C library implementing the SSH2 protocol")
123 (description
124 "libssh2 is a library intended to allow software developers access to
125 the SSH-2 protocol in an easy-to-use self-contained package. It can be built
126 into an application to perform many different tasks when communicating with
127 a server that supports the SSH-2 protocol.")
128 (license license:bsd-3)
129 (home-page "https://www.libssh2.org/")))
130
131 (define-public openssh
132 (package
133 (name "openssh")
134 (version "8.2p1")
135 (source (origin
136 (method url-fetch)
137 (uri (string-append "mirror://openbsd/OpenSSH/portable/"
138 "openssh-" version ".tar.gz"))
139 (sha256
140 (base32
141 "0wg6ckzvvklbzznijxkk28fb8dnwyjd0w30ra0afwv6gwr8m34j3"))))
142 (build-system gnu-build-system)
143 (native-inputs `(("groff" ,groff)
144 ("pkg-config" ,pkg-config)))
145 (inputs `(("libedit" ,libedit)
146 ("openssl" ,openssl)
147 ("pam" ,linux-pam)
148 ("mit-krb5" ,mit-krb5)
149 ("zlib" ,zlib)
150 ("xauth" ,xauth))) ; for 'ssh -X' and 'ssh -Y'
151 (arguments
152 `(#:test-target "tests"
153 ;; Otherwise, the test scripts try to use a nonexistent directory and
154 ;; fail.
155 #:make-flags '("REGRESSTMP=\"$${BUILDDIR}/regress\"")
156 #:configure-flags `("--sysconfdir=/etc/ssh"
157
158 ;; Default value of 'PATH' used by sshd.
159 "--with-default-path=/run/current-system/profile/bin"
160
161 ;; configure needs to find krb5-config.
162 ,(string-append "--with-kerberos5="
163 (assoc-ref %build-inputs "mit-krb5")
164 "/bin")
165
166 ;; libedit is needed for sftp completion.
167 "--with-libedit"
168
169 ;; Enable PAM support in sshd.
170 "--with-pam"
171
172 ;; "make install" runs "install -s" by default,
173 ;; which doesn't work for cross-compiled binaries
174 ;; because it invokes 'strip' instead of
175 ;; 'TRIPLET-strip'. Work around this.
176 ,,@(if (%current-target-system)
177 '("--disable-strip")
178 '()))
179
180 #:phases
181 (modify-phases %standard-phases
182 (add-after 'configure 'reset-/var/empty
183 (lambda* (#:key outputs #:allow-other-keys)
184 (let ((out (assoc-ref outputs "out")))
185 (substitute* "Makefile"
186 (("PRIVSEP_PATH=/var/empty")
187 (string-append "PRIVSEP_PATH=" out "/var/empty")))
188 #t)))
189 (add-before 'check 'patch-tests
190 (lambda _
191 (substitute* "regress/test-exec.sh"
192 (("/bin/sh") (which "sh")))
193
194 ;; Remove 't-exec' regress target which requires user 'sshd'.
195 (substitute* (list "Makefile"
196 "regress/Makefile")
197 (("^(tests:.*) t-exec(.*)" all pre post)
198 (string-append pre post)))
199 #t))
200 (replace 'install
201 (lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
202 ;; Install without host keys and system configuration files.
203 (apply invoke "make" "install-nosysconf" make-flags)
204 (install-file "contrib/ssh-copy-id"
205 (string-append (assoc-ref outputs "out")
206 "/bin/"))
207 (chmod (string-append (assoc-ref outputs "out")
208 "/bin/ssh-copy-id") #o555)
209 (install-file "contrib/ssh-copy-id.1"
210 (string-append (assoc-ref outputs "out")
211 "/share/man/man1/"))
212 #t)))))
213 (synopsis "Client and server for the secure shell (ssh) protocol")
214 (description
215 "The SSH2 protocol implemented in OpenSSH is standardised by the
216 IETF secsh working group and is specified in several RFCs and drafts.
217 It is composed of three layered components:
218
219 The transport layer provides algorithm negotiation and a key exchange.
220 The key exchange includes server authentication and results in a
221 cryptographically secured connection: it provides integrity, confidentiality
222 and optional compression.
223
224 The user authentication layer uses the established connection and relies on
225 the services provided by the transport layer. It provides several mechanisms
226 for user authentication. These include traditional password authentication
227 as well as public-key or host-based authentication mechanisms.
228
229 The connection layer multiplexes many different concurrent channels over the
230 authenticated connection and allows tunneling of login sessions and
231 TCP-forwarding. It provides a flow control service for these channels.
232 Additionally, various channel-specific options can be negotiated.")
233 (license (license:non-copyleft "file://LICENSE"
234 "See LICENSE in the distribution."))
235 (home-page "https://www.openssh.com/")))
236
237 (define-public guile-ssh
238 (package
239 (name "guile-ssh")
240 (version "0.12.0")
241 (home-page "https://github.com/artyom-poptsov/guile-ssh")
242 (source (origin
243 (method git-fetch)
244 (uri (git-reference
245 (url home-page)
246 (commit (string-append "v" version))))
247 (file-name (string-append name "-" version ".tar.gz"))
248 (sha256
249 (base32
250 "054hd9rzfhb48gc1hw3rphhp0cnnd4bs5qmidy5ygsyvy9ravlad"))
251 (modules '((guix build utils)))))
252 (build-system gnu-build-system)
253 (outputs '("out" "debug"))
254 (arguments
255 `(;; It makes no sense to build libguile-ssh.a.
256 #:configure-flags '("--disable-static")
257
258 #:phases (modify-phases %standard-phases
259 (add-before 'build 'fix-libguile-ssh-file-name
260 (lambda* (#:key outputs #:allow-other-keys)
261 ;; Build and install libguile-ssh.so so that we can use
262 ;; its absolute file name in .scm files, before we build
263 ;; the .go files.
264 (let* ((out (assoc-ref outputs "out"))
265 (lib (string-append out "/lib")))
266 (invoke "make" "install"
267 "-C" "libguile-ssh"
268 "-j" (number->string
269 (parallel-job-count)))
270 (substitute* (find-files "." "\\.scm$")
271 (("\"libguile-ssh\"")
272 (string-append "\"" lib "/libguile-ssh\"")))
273 #t)))
274 ,@(if (%current-target-system)
275 '()
276 '((add-before 'check 'fix-guile-path
277 (lambda* (#:key inputs #:allow-other-keys)
278 (let ((guile (assoc-ref inputs "guile")))
279 (substitute* "tests/common.scm"
280 (("/usr/bin/guile")
281 (string-append guile "/bin/guile")))
282 #t)))))
283 (add-after 'install 'remove-bin-directory
284 (lambda* (#:key outputs #:allow-other-keys)
285 (let* ((out (assoc-ref outputs "out"))
286 (bin (string-append out "/bin"))
287 (examples (string-append
288 out "/share/guile-ssh/examples")))
289 (mkdir-p examples)
290 (rename-file (string-append bin "/ssshd.scm")
291 (string-append examples "/ssshd.scm"))
292 (rename-file (string-append bin "/sssh.scm")
293 (string-append examples "/sssh.scm"))
294 (delete-file-recursively bin)
295 #t))))
296 ;; Tests are not parallel-safe.
297 #:parallel-tests? #f))
298 (native-inputs `(("autoconf" ,autoconf)
299 ("automake" ,automake)
300 ("libtool" ,libtool)
301 ("texinfo" ,texinfo)
302 ("pkg-config" ,pkg-config)
303 ("which" ,which)
304 ("guile" ,guile-3.0))) ;needed when cross-compiling.
305 (inputs `(("guile" ,guile-3.0)
306 ("libssh" ,libssh)
307 ("libgcrypt" ,libgcrypt)))
308 (synopsis "Guile bindings to libssh")
309 (description
310 "Guile-SSH is a library that provides access to the SSH protocol for
311 programs written in GNU Guile interpreter. It is a wrapper to the underlying
312 libssh library.")
313 (license license:gpl3+)))
314
315 (define-public guile2.0-ssh
316 (package
317 (inherit guile-ssh)
318 (name "guile2.0-ssh")
319 (native-inputs
320 `(("guile" ,guile-2.0) ;needed when cross-compiling.
321 ,@(alist-delete "guile" (package-native-inputs guile-ssh))))
322 (inputs `(("guile" ,guile-2.0)
323 ,@(alist-delete "guile" (package-inputs guile-ssh))))))
324
325 (define-public guile2.2-ssh
326 (package
327 (inherit guile-ssh)
328 (name "guile2.2-ssh")
329 (native-inputs
330 `(("guile" ,guile-2.2) ;needed when cross-compiling.
331 ,@(alist-delete "guile" (package-native-inputs guile-ssh))))
332 (inputs `(("guile" ,guile-2.2)
333 ,@(alist-delete "guile" (package-inputs guile-ssh))))))
334
335 (define-public guile3.0-ssh
336 (deprecated-package "guile3.0-ssh" guile-ssh))
337
338 (define-public corkscrew
339 (package
340 (name "corkscrew")
341 (version "2.0")
342 (source
343 (origin
344 (method url-fetch)
345 ;; The agroman.net domain name expired on 2017-03-23, and the original
346 ;; "http://www.agroman.net/corkscrew/corkscrew-2.0.tar.gz" now returns
347 ;; bogus HTML. Perhaps it will yet return. Until then, use a mirror.
348 (uri (string-append "https://downloads.openwrt.org/sources/"
349 "corkscrew-" version ".tar.gz"))
350 (sha256 (base32
351 "1gmhas4va6gd70i2x2mpxpwpgww6413mji29mg282jms3jscn3qd"))))
352 (build-system gnu-build-system)
353 (arguments
354 `(#:phases
355 (modify-phases %standard-phases
356 (replace 'configure
357 ;; Replace configure phase as the ./configure script does not like
358 ;; CONFIG_SHELL and SHELL passed as parameters
359 (lambda* (#:key outputs build target #:allow-other-keys)
360 (let* ((out (assoc-ref outputs "out"))
361 (bash (which "bash"))
362 ;; Set --build and --host flags as the provided config.guess
363 ;; is not able to detect them
364 (flags `(,(string-append "--prefix=" out)
365 ,(string-append "--build=" build)
366 ,(string-append "--host=" (or target build)))))
367 (setenv "CONFIG_SHELL" bash)
368 (apply invoke bash "./configure" flags))))
369 (add-after 'install 'install-documentation
370 (lambda* (#:key outputs #:allow-other-keys)
371 (let* ((out (assoc-ref outputs "out"))
372 (doc (string-append out "/share/doc/" ,name "-" ,version)))
373 (install-file "README" doc)
374 #t))))))
375 (home-page "http://www.agroman.net/corkscrew")
376 (synopsis "SSH tunneling through HTTP(S) proxies")
377 (description
378 "Corkscrew tunnels SSH connections through most HTTP and HTTPS proxies.
379 Proxy authentication is only supported through the plain-text HTTP basic
380 authentication scheme.")
381 (license license:gpl2+)))
382
383 (define-public mosh
384 (package
385 (name "mosh")
386 (version "1.3.2")
387 (source (origin
388 (method url-fetch)
389 (uri (string-append "https://mosh.org/mosh-" version ".tar.gz"))
390 (sha256
391 (base32
392 "05hjhlp6lk8yjcy59zywpf0r6s0h0b9zxq0lw66dh9x8vxrhaq6s"))))
393 (build-system gnu-build-system)
394 (arguments
395 '(#:phases
396 (modify-phases %standard-phases
397 (add-after 'install 'wrap
398 (lambda* (#:key outputs #:allow-other-keys)
399 ;; Make sure 'mosh' can find 'mosh-client' and
400 ;; 'mosh-server'.
401 (let* ((out (assoc-ref outputs "out"))
402 (bin (string-append out "/bin")))
403 (wrap-program (string-append bin "/mosh")
404 `("PATH" ":" prefix (,bin)))))))))
405 (native-inputs
406 `(("pkg-config" ,pkg-config)))
407 (inputs
408 `(("openssl" ,openssl)
409 ("perl" ,perl)
410 ("perl-io-tty" ,perl-io-tty)
411 ("zlib" ,zlib)
412 ("ncurses" ,ncurses)
413 ("protobuf" ,protobuf)
414 ("boost-headers" ,boost)))
415 (home-page "https://mosh.org/")
416 (synopsis "Remote shell tolerant to intermittent connectivity")
417 (description
418 "Mosh is a remote terminal application that allows client roaming, supports
419 intermittent connectivity, and provides intelligent local echo and line editing
420 of user keystrokes. It's a replacement for SSH that's more robust and
421 responsive, especially over Wi-Fi, cellular, and long-distance links.")
422 (license license:gpl3+)))
423
424 (define-public et
425 (package
426 (name "et")
427 (version "3.1.0")
428 (source
429 (origin
430 (method git-fetch)
431 (uri (git-reference
432 (url "https://github.com/MisterTea/EternalTCP.git")
433 (commit (string-append "et-v" version))))
434 (file-name (git-file-name name version))
435 (sha256
436 (base32 "1m5caxckn2ihwp9s2pbyh5amxlpwr7yc54q8s0kb10fr52w2vfnm"))))
437 (build-system cmake-build-system)
438 (arguments `(#:tests? #f))
439 (native-inputs
440 `(("pkg-config" ,pkg-config)))
441 (inputs `(("glog" ,glog)
442 ("gflags" ,gflags)
443 ("libsodium" ,libsodium)
444 ("protobuf" ,protobuf)))
445 (synopsis "Remote shell that automatically reconnects")
446 (description
447 "Eternal Terminal (ET) is a remote shell that automatically reconnects
448 without interrupting the session. Unlike SSH sessions, ET sessions will
449 survive even network outages and IP changes. ET uses a custom protocol over
450 TCP, not the SSH protocol.")
451 (home-page "https://eternalterminal.dev/")
452 (license license:asl2.0)))
453
454 (define-public dropbear
455 (package
456 (name "dropbear")
457 (version "2019.78")
458 (source
459 (origin
460 (method url-fetch)
461 (uri (string-append
462 "https://matt.ucc.asn.au/dropbear/releases/"
463 "dropbear-" version ".tar.bz2"))
464 (sha256
465 (base32 "19242qlr40pbqfqd0gg6h8qpj38q6lgv03ja6sahj9vj2abnanaj"))))
466 (build-system gnu-build-system)
467 (arguments `(#:tests? #f)) ; there is no "make check" or anything similar
468 ;; TODO: Investigate unbundling libtommath and libtomcrypt or at least
469 ;; cherry-picking important bug fixes from them. See <bugs.gnu.org/24674>
470 ;; for more information.
471 (inputs `(("zlib" ,zlib)))
472 (synopsis "Small SSH server and client")
473 (description "Dropbear is a relatively small SSH server and
474 client. It runs on a variety of POSIX-based platforms. Dropbear is
475 particularly useful for embedded systems, such as wireless routers.")
476 (home-page "https://matt.ucc.asn.au/dropbear/dropbear.html")
477 (license (license:x11-style "" "See file LICENSE."))))
478
479 (define-public liboop
480 (package
481 (name "liboop")
482 (version "1.0.1")
483 (source
484 (origin
485 (method url-fetch)
486 (uri (string-append "http://ftp.lysator.liu.se/pub/liboop/"
487 name "-" version ".tar.gz"))
488 (sha256
489 (base32
490 "1q0p1l72pq9k3bi7a366j2rishv7dzzkg3i6r2npsfg7cnnidbsn"))))
491 (build-system gnu-build-system)
492 (home-page "https://www.lysator.liu.se/liboop/")
493 (synopsis "Event loop library")
494 (description "Liboop is a low-level event loop management library for
495 POSIX-based operating systems. It supports the development of modular,
496 multiplexed applications which may respond to events from several sources. It
497 replaces the \"select() loop\" and allows the registration of event handlers
498 for file and network I/O, timers and signals. Since processes use these
499 mechanisms for almost all external communication, liboop can be used as the
500 basis for almost any application.")
501 (license license:lgpl2.1+)))
502
503 (define-public lsh
504 (package
505 (name "lsh")
506 (version "2.1")
507 (source (origin
508 (method url-fetch)
509 (uri (string-append "mirror://gnu/lsh/lsh-"
510 version ".tar.gz"))
511 (sha256
512 (base32
513 "1qqjy9zfzgny0rkb27c8c7dfsylvb6n0ld8h3an2r83pmaqr9gwb"))
514 (modules '((guix build utils)))
515 (snippet
516 '(begin
517 (substitute* "src/testsuite/functions.sh"
518 (("localhost")
519 ;; Avoid host name lookups since they don't work in
520 ;; chroot builds.
521 "127.0.0.1")
522 (("set -e")
523 ;; Make tests more verbose.
524 "set -e\nset -x"))
525
526 (substitute* (find-files "src/testsuite" "-test$")
527 (("localhost") "127.0.0.1"))
528
529 (substitute* "src/testsuite/login-auth-test"
530 (("/bin/cat") "cat"))
531 #t))))
532 (build-system gnu-build-system)
533 (native-inputs
534 `(("m4" ,m4)
535 ("guile" ,guile-2.0)
536 ("gperf" ,gperf)
537 ("psmisc" ,psmisc))) ; for `killall'
538 (inputs
539 `(("nettle" ,nettle-2)
540 ("linux-pam" ,linux-pam)
541
542 ;; 'rl.c' uses the 'CPPFunction' type, which is no longer in
543 ;; Readline 6.3.
544 ("readline" ,readline-6.2)
545
546 ("liboop" ,liboop)
547 ("zlib" ,zlib)
548 ("gmp" ,gmp)
549
550 ;; The server (lshd) invokes xauth when X11 forwarding is requested.
551 ;; This adds 24 MiB (or 27%) to the closure of lsh.
552 ("xauth" ,xauth)))
553 (arguments
554 '(;; Skip the `configure' test that checks whether /dev/ptmx &
555 ;; co. work as expected, because it relies on impurities (for
556 ;; instance, /dev/pts may be unavailable in chroots.)
557 #:configure-flags '("lsh_cv_sys_unix98_ptys=yes"
558
559 ;; Use glibc's argp rather than the bundled one.
560 "--with-system-argp"
561
562 ;; 'lsh_argp.h' checks HAVE_ARGP_PARSE but nothing
563 ;; defines it.
564 "CPPFLAGS=-DHAVE_ARGP_PARSE")
565
566 ;; FIXME: Tests won't run in a chroot, presumably because
567 ;; /etc/profile is missing, and thus clients get an empty $PATH
568 ;; and nothing works.
569 #:tests? #f
570
571 #:phases
572 (modify-phases %standard-phases
573 (add-before 'configure 'pre-configure
574 (lambda* (#:key inputs #:allow-other-keys)
575 (let* ((nettle (assoc-ref inputs "nettle"))
576 (sexp-conv (string-append nettle "/bin/sexp-conv")))
577 ;; Remove argp from the list of sub-directories; we don't want
578 ;; to build it, really.
579 (substitute* "src/Makefile.in"
580 (("^SUBDIRS = argp")
581 "SUBDIRS ="))
582
583 ;; Make sure 'lsh' and 'lshd' pick 'sexp-conv' in the right place
584 ;; by default.
585 (substitute* "src/environ.h.in"
586 (("^#define PATH_SEXP_CONV.*")
587 (string-append "#define PATH_SEXP_CONV \""
588 sexp-conv "\"\n")))
589
590 ;; Same for the 'lsh-authorize' script.
591 (substitute* "src/lsh-authorize"
592 (("=sexp-conv")
593 (string-append "=" sexp-conv)))
594
595 ;; Tell lshd where 'xauth' lives. Another option would be to
596 ;; hardcode "/run/current-system/profile/bin/xauth", thereby
597 ;; reducing the closure size, but that wouldn't work on foreign
598 ;; distros.
599 (with-fluids ((%default-port-encoding "ISO-8859-1"))
600 (substitute* "src/server_x11.c"
601 (("define XAUTH_PROGRAM.*")
602 (string-append "define XAUTH_PROGRAM \""
603 (assoc-ref inputs "xauth")
604 "/bin/xauth\"\n")))))
605
606 ;; Tests rely on $USER being set.
607 (setenv "USER" "guix"))))))
608 (home-page "https://www.lysator.liu.se/~nisse/lsh/")
609 (synopsis "GNU implementation of the Secure Shell (ssh) protocols")
610 (description
611 "GNU lsh is a free implementation of the SSH version 2 protocol. It is
612 used to create a secure line of communication between two computers,
613 providing shell access to the server system from the client. It provides
614 both the server daemon and the client application, as well as tools for
615 manipulating key files.")
616 (license license:gpl2+)))
617
618 (define-public sshpass
619 (package
620 (name "sshpass")
621 (version "1.06")
622 (synopsis "Non-interactive password authentication with SSH")
623 (home-page "https://sourceforge.net/projects/sshpass/")
624 (source
625 (origin
626 (method url-fetch)
627 (uri (string-append "mirror://sourceforge/sshpass/sshpass/"
628 version "/sshpass-" version ".tar.gz"))
629 (sha256
630 (base32
631 "0q7fblaczb7kwbsz0gdy9267z0sllzgmf0c7z5c9mf88wv74ycn6"))))
632 (build-system gnu-build-system)
633 (description "sshpass is a tool for non-interactivly performing password
634 authentication with SSH's so-called @dfn{interactive keyboard password
635 authentication}.")
636 (license license:gpl2+)))
637
638 (define-public autossh
639 (package
640 (name "autossh")
641 (version "1.4g")
642 (source
643 (origin
644 (method url-fetch)
645 (uri (string-append
646 "https://www.harding.motd.ca/autossh/autossh-"
647 version ".tgz"))
648 (sha256
649 (base32 "0xqjw8df68f4kzkns5gcah61s5wk0m44qdk2z1d6388w6viwxhsz"))))
650 (build-system gnu-build-system)
651 (arguments `(#:tests? #f)) ; There is no "make check" or anything similar
652 (inputs `(("openssh" ,openssh)))
653 (synopsis "Automatically restart SSH sessions and tunnels")
654 (description "autossh is a program to start a copy of @command{ssh} and
655 monitor it, restarting it as necessary should it die or stop passing traffic.")
656 (home-page "https://www.harding.motd.ca/autossh/")
657 (license
658 ;; Why point to a source file? Well, all the individual files have a
659 ;; copy of this license in their headers, but there's no separate file
660 ;; with that information.
661 (license:non-copyleft "file://autossh.c"))))
662
663 (define-public pdsh
664 (package
665 (name "pdsh")
666 (version "2.34")
667 (source
668 (origin
669 (method url-fetch)
670 (uri (string-append "https://github.com/chaos/pdsh/"
671 "releases/download/pdsh-" version
672 "/pdsh-" version ".tar.gz"))
673 (sha256
674 (base32 "1s91hmhrz7rfb6h3l5k97s393rcm1ww3svp8dx5z8vkkc933wyxl"))))
675 (build-system gnu-build-system)
676 (arguments
677 `(#:configure-flags
678 (list "--with-ssh")
679 #:phases
680 (modify-phases %standard-phases
681 (add-after 'unpack 'patch-/bin/sh
682 (lambda _
683 (substitute* '("tests/t0006-pdcp.sh"
684 "tests/t0004-module-loading.sh"
685 "tests/t2001-ssh.sh"
686 "tests/t1003-slurm.sh"
687 "tests/t6036-long-output-lines.sh"
688 "tests/aggregate-results.sh"
689 "tests/t2000-exec.sh"
690 "tests/t0002-internal.sh"
691 "tests/t1002-dshgroup.sh"
692 "tests/t5000-dshbak.sh"
693 "tests/t0001-basic.sh"
694 "tests/t0005-rcmd_type-and-user.sh"
695 "tests/test-lib.sh"
696 "tests/t2002-mrsh.sh"
697 "tests/t0003-wcoll.sh"
698 "tests/test-modules/pcptest.c")
699 (("/bin/sh") (which "bash")))
700 #t))
701 (add-after 'unpack 'patch-tests
702 (lambda _
703 (substitute* "tests/t6036-long-output-lines.sh"
704 (("which") (which "which")))
705 #t)))))
706 (inputs
707 `(("openssh" ,openssh)
708 ("mit-krb5" ,mit-krb5)
709 ("perl" ,perl)))
710 (native-inputs
711 `(("which" ,which)))
712 (home-page "https://github.com/chaos/pdsh")
713 (synopsis "Parallel distributed shell")
714 (description "Pdsh is a an efficient, multithreaded remote shell client
715 which executes commands on multiple remote hosts in parallel. Pdsh implements
716 dynamically loadable modules for extended functionality such as new remote
717 shell services and remote host selection.")
718 (license license:gpl2+)))
719
720 (define-public clustershell
721 (package
722 (name "clustershell")
723 (version "1.8.3")
724 (source
725 (origin
726 (method url-fetch)
727 (uri (string-append "https://github.com/cea-hpc/clustershell/releases"
728 "/download/v" version
729 "/ClusterShell-" version ".tar.gz"))
730 (sha256
731 (base32 "1qdcgh733szwj9r1gambrgfkizvbjci0bnnkds9a8mnyb3sasnan"))))
732 (build-system python-build-system)
733 (inputs `(("openssh" ,openssh)))
734 (propagated-inputs `(("python-pyyaml" ,python-pyyaml)))
735 (arguments
736 `(#:phases (modify-phases %standard-phases
737 (add-before 'build 'record-openssh-file-name
738 (lambda* (#:key inputs #:allow-other-keys)
739 (let ((ssh (assoc-ref inputs "openssh")))
740 (substitute* "lib/ClusterShell/Worker/Ssh.py"
741 (("info\\(\"ssh_path\"\\) or \"ssh\"")
742 (string-append "info(\"ssh_path\") or \""
743 ssh "/bin/ssh\"")))
744 #t))))))
745 (home-page "https://cea-hpc.github.io/clustershell/")
746 (synopsis "Scalable event-driven Python framework for cluster administration")
747 (description
748 "ClusterShell is an event-driven Python framework, designed to run local
749 or distant commands in parallel on server farms or on large GNU/Linux
750 clusters. It will take care of common issues encountered on HPC clusters,
751 such as operating on groups of nodes, running distributed commands using
752 optimized execution algorithms, as well as gathering results and merging
753 identical outputs, or retrieving return codes. ClusterShell takes advantage
754 of existing remote shell facilities such as SSH.")
755 (license license:lgpl2.1+)))
756
757 (define-public endlessh
758 (package
759 (name "endlessh")
760 (version "1.1")
761 (source
762 (origin
763 (method git-fetch)
764 (uri (git-reference
765 (url "https://github.com/skeeto/endlessh.git")
766 (commit version)))
767 (file-name (git-file-name name version))
768 (sha256
769 (base32 "0ziwr8j1frsp3dajr8h5glkm1dn5cci404kazz5w1jfrp0736x68"))))
770 (build-system gnu-build-system)
771 (arguments
772 '(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
773 "CC=gcc")
774 #:tests? #f ; no test target
775 #:phases
776 (modify-phases %standard-phases
777 (delete 'configure)))) ; no configure script
778 (home-page "https://github.com/skeeto/endlessh")
779 (synopsis "SSH tarpit that slowly sends an endless banner")
780 (description
781 "Endlessh is an SSH tarpit that very slowly sends an endless, random SSH
782 banner. It keeps SSH clients locked up for hours or even days at a time. The
783 purpose is to put your real SSH server on another port and then let the script
784 kiddies get stuck in this tarpit instead of bothering a real server.
785
786 Since the tarpit is in the banner before any cryptographic exchange occurs, this
787 program doesn't depend on any cryptographic libraries. It's a simple,
788 single-threaded, standalone C program. It uses @code{poll()} to trap multiple
789 clients at a time.")
790 (license license:unlicense)))