gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / wv.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014 Marek Benc <merkur32@gmail.com>
3 ;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
4 ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages wv)
22 #:use-module (gnu packages)
23 #:use-module (gnu packages compression)
24 #:use-module (gnu packages glib)
25 #:use-module (gnu packages gnome)
26 #:use-module (gnu packages image)
27 #:use-module (gnu packages pkg-config)
28 #:use-module (guix packages)
29 #:use-module (guix download)
30 #:use-module (guix build-system gnu)
31 #:use-module ((guix licenses) #:prefix license:))
32
33 (define-public wv
34 (package
35 (name "wv")
36 (version "1.2.9")
37 (source
38 (origin
39 (method url-fetch)
40 (uri (string-append "https://abiword.org/downloads/wv/"
41 version "/wv-" version ".tar.gz"))
42 (sha256
43 (base32 "17f16lkdv1c3amaz2hagiicih59ynpp4786k1m2qa1sw68xhswsc"))))
44 (build-system gnu-build-system)
45 (inputs
46 `(("glib" ,glib)
47 ("libgsf" ,libgsf)
48 ("libjpeg" ,libjpeg-turbo)
49 ("libpng" ,libpng)
50 ("zlib" ,zlib)))
51 (native-inputs
52 `(("glib" ,glib "bin")
53 ("pkg-config" ,pkg-config)))
54 (synopsis "Microsoft Word conversion library and utilities")
55 (description
56 "wv converts files written by Word 2000, 97, 95, and 6 (known internally as
57 Word 9, 8, 7, and 6) to HTML or LaTeX. Word 2 documents can still be converted
58 to plain text but will lack formatting.
59
60 Other programs can use wv as a library to convert Word documents to other
61 formats. AbiWord uses it as its Word importer, and KWord uses concepts and
62 code from wv in theirs.")
63 (home-page "http://wvware.sourceforge.net/")
64 (license license:gpl2+)))