gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / wordnet.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2016, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages wordnet)
21 #:use-module (guix packages)
22 #:use-module (guix build-system gnu)
23 #:use-module (guix licenses)
24 #:use-module (guix download)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages gcc)
27 #:use-module (gnu packages tcl))
28
29 (define-public wordnet
30 (package
31 (name "wordnet")
32 (version "3.0")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "http://wordnetcode.princeton.edu/"
36 version "/WordNet-" version ".tar.bz2"))
37 (sha256
38 (base32
39 "08pgjvd2vvmqk3h641x63nxp7wqimb9r30889mkyfh2agc62sjbc"))
40 (patches (search-patches
41 "wordnet-CVE-2008-2149.patch"
42 "wordnet-CVE-2008-3908-pt1.patch"
43 "wordnet-CVE-2008-3908-pt2.patch"))))
44 (build-system gnu-build-system)
45 (arguments
46 `(#:configure-flags (list (string-append "--with-tcl="
47 (assoc-ref %build-inputs "tcl")
48 "/lib")
49 (string-append "--with-tk="
50 (assoc-ref %build-inputs "tk")
51 "/lib")
52
53 ;; Provide the `result' field in `Tcl_Interp'.
54 ;; See <https://bugs.gentoo.org/show_bug.cgi?id=452034>.
55 "CFLAGS=-DUSE_INTERP_RESULT -O2")
56 #:phases
57 (modify-phases %standard-phases
58 (add-before 'build 'build-libwn-PIC
59 (lambda _
60 ;; GNU Dico links libWN.a in its wordnet.so plugin, so it needs
61 ;; PIC.
62 (invoke "make" "-C" "lib" "CFLAGS=-O2 -g -fPIC"
63 "LDFLAGS=-fPIC")))
64 (add-after 'install 'post-install
65 (lambda* (#:key inputs outputs #:allow-other-keys)
66 (let ((out (assoc-ref outputs "out"))
67 (bin (assoc-ref outputs "tk"))
68 (tk (assoc-ref inputs "tk"))
69 (tkv ,(let ((v (package-version tk)))
70 (string-take v (string-index-right v #\.)))))
71 ;; Move `wishwn' and `wnb' to BIN.
72 (for-each (lambda (prog)
73 (let ((orig (string-append out "/bin/" prog))
74 (dst (string-append bin "/bin/" prog))
75 (dir (string-append tk "/lib/tk" tkv)))
76 (mkdir-p (dirname dst))
77 (copy-file orig dst)
78 (delete-file orig)
79 (wrap-program dst
80 `("TK_LIBRARY" "" = (,dir))
81 `("PATH" ":" prefix
82 (,(string-append out
83 "/bin"))))))
84 '("wishwn" "wnb"))
85 #t))))))
86 (outputs '("out"
87 "tk")) ; for the Tcl/Tk GUI
88
89 (inputs `(("tk" ,tk)
90 ("tcl" ,tcl)))
91 (home-page "https://wordnet.princeton.edu/")
92 (synopsis "Lexical database for the English language")
93 (description
94 "WordNet is a large lexical database of English. Nouns, verbs,
95 adjectives and adverbs are grouped into sets of cognitive synonyms (synsets),
96 each expressing a distinct concept. Synsets are interlinked by means of
97 conceptual-semantic and lexical relations. The resulting network of
98 meaningfully related words and concepts can be navigated with the browser.
99 WordNet is also freely and publicly available for download. WordNet's
100 structure makes it a useful tool for computational linguistics and natural
101 language processing.")
102 (license x11)))