gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / tv.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016, 2017, 2018 Alex Kost <alezost@gmail.com>
3 ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages tv)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module ((guix licenses) #:prefix license:)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages fontutils)
28 #:use-module (gnu packages image)
29 #:use-module (gnu packages linux)
30 #:use-module (gnu packages pkg-config)
31 #:use-module (gnu packages xml)
32 #:use-module (gnu packages xorg))
33
34 (define-public tvtime
35 (package
36 (name "tvtime")
37 (version "1.0.11")
38 (source (origin
39 (method url-fetch)
40 (uri (string-append
41 "https://linuxtv.org/downloads/tvtime/tvtime-"
42 version ".tar.gz"))
43 (sha256
44 (base32
45 "1367rl3n6qxwf30lqyz234zpb43s9xjhig3hrvbg7cbqcl8g4fs0"))))
46 (build-system gnu-build-system)
47 (arguments
48 '(#:phases
49 (modify-phases %standard-phases
50 (add-after 'unpack 'fix-glibc-compatability
51 (lambda _
52 (substitute* "src/get_media_devices.c"
53 (("<sys/stat.h>")
54 "<sys/stat.h>\n#include <sys/sysmacros.h>"))
55 #t)))))
56 (inputs
57 `(("alsa-lib" ,alsa-lib)
58 ("libx11" ,libx11)
59 ("libxext" ,libxext)
60 ("libxt" ,libxt)
61 ("libxtst" ,libxtst)
62 ("libxinerama" ,libxinerama)
63 ("libxv" ,libxv)
64 ("libxxf86vm" ,libxxf86vm)
65 ("libpng" ,libpng)
66 ("libxml2" ,libxml2)
67 ("freetype" ,freetype)
68 ("zlib" ,zlib)))
69 (native-inputs
70 `(("pkg-config" ,pkg-config)))
71 (home-page "http://tvtime.sourceforge.net")
72 (synopsis "Television viewer")
73 (description
74 "Tvtime processes the input from your video capture card and
75 displays it on a monitor. It focuses on a high visual quality.")
76 (license license:gpl2+)))