gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / sml.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 Andy Patterson <ajpatter@uwaterloo.ca>
3 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
5 ;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages sml)
23 #:use-module (gnu packages lesstif)
24 #:use-module (gnu packages libffi)
25 #:use-module (gnu packages multiprecision)
26 #:use-module (gnu packages xorg)
27 #:use-module (guix build-system gnu)
28 #:use-module (guix download)
29 #:use-module (guix git-download)
30 #:use-module ((guix licenses) #:prefix license:)
31 #:use-module (guix packages))
32
33 (define-public polyml
34 (package
35 (name "polyml")
36 (version "5.8.1")
37 (source (origin
38 (method git-fetch)
39 (uri (git-reference
40 (url "https://github.com/polyml/polyml")
41 (commit (string-append "v" version))))
42 (file-name (git-file-name name version))
43 (sha256
44 (base32
45 "1ag7n55ym1zxksi89dvs17j6iaa58v4mg47s92zpa1b49k4fql1k"))))
46 (build-system gnu-build-system)
47 (inputs
48 `(("gmp" ,gmp)
49 ("lesstif" ,lesstif)
50 ("libffi" ,libffi)
51 ("libx11" ,libx11)
52 ("libxt" ,libxt)))
53 (arguments
54 '(#:configure-flags
55 (list "--with-system-libffi=yes"
56 "--with-x=yes"
57 "--with-threads=yes"
58 "--with-gmp=yes")
59 #:phases
60 (modify-phases %standard-phases
61 (add-after 'build 'build-compiler
62 (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
63 (define flags
64 (if parallel-build?
65 (cons (format #f "-j~d" (parallel-job-count))
66 make-flags)
67 make-flags))
68 (apply system* "make" (append flags (list "compiler"))))))))
69 (home-page "https://www.polyml.org/")
70 (synopsis "Standard ML implementation")
71 (description "Poly/ML is a Standard ML implementation. It is fully
72 compatible with the ML97 standard. It includes a thread library, a foreign
73 function interface, and a symbolic debugger.")
74 ;; Some source files specify 'or any later version'; some don't
75 (license
76 (list license:lgpl2.1
77 license:lgpl2.1+))))