gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / simh.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.com>
3 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages simh)
21 #:use-module ((guix licenses) #:prefix license:)
22 #:use-module (guix packages)
23 #:use-module (guix download)
24 #:use-module (guix git-download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages admin))
27
28 (define-public simh
29 (package
30 (name "simh")
31 (version "3.9-0")
32 (source
33 (origin
34 (method git-fetch)
35 (uri (git-reference
36 (url "https://github.com/simh/simh")
37 (commit (string-append "v" version))))
38 (sha256
39 (base32 "1jiq6shj6a9xvzacvmyhxxd6xdyica8q4006qqjh5mh96rxrp15c"))
40 (file-name (git-file-name name version))))
41 (build-system gnu-build-system)
42 (inputs
43 `(("libpcap" ,libpcap)))
44 (arguments
45 '(#:tests? #f
46 #:make-flags (list
47 "LDFLAGS=-lm"
48 (string-append "INCPATH="
49 (assoc-ref %build-inputs "libpcap")
50 "/include")
51 (string-append "LIBPATH="
52 (assoc-ref %build-inputs "libpcap")
53 "/lib"))
54 #:phases
55 (modify-phases %standard-phases
56 (delete 'configure)
57 (add-before 'build 'prepare-build
58 (lambda _
59 (mkdir "BIN")))
60 (replace 'install
61 (lambda* (#:key outputs #:allow-other-keys)
62 (let* ((out (assoc-ref outputs "out"))
63 (bin (string-append out "/bin/"))
64 (lib (string-append out "/lib/simh/")))
65 (mkdir-p bin)
66 (mkdir-p lib)
67 (for-each
68 (lambda (file)
69 (copy-file file (string-append bin
70 "simh-"
71 (basename file))))
72 (find-files "BIN"))
73 (for-each
74 (lambda (file)
75 (copy-file file (string-append lib
76 (basename file))))
77 (find-files "VAX" "bin$"))))))))
78 (home-page "http://simh.trailing-edge.com")
79 (synopsis "Collection of simulators from The Computer History Simulation
80 Project")
81 (description
82 "SIMH is a highly portable, multi-system simulator. SIMH implements
83 simulators for:
84
85 @itemize
86 @item Data General Nova, Eclipse.
87 @item Digital Equipment Corporation PDP-1, PDP-4, PDP-7, PDP-8, PDP-9, PDP-10,
88 PDP-11, PDP-15, VAX.
89 @item GRI Corporation GRI-909, GRI-99.
90 @item IBM 1401, 1620, 1130, 7090/7094, System 3.
91 @item Interdata (Perkin-Elmer) 16b and 32b systems.
92 @item Hewlett-Packard 2114, 2115, 2116, 2100, 21MX, 1000.
93 @item Honeywell H316/H516.
94 @item MITS Altair 8800, with both 8080 and Z80.
95 @item Royal-Mcbee LGP-30, LGP-21.
96 @item Scientific Data Systems SDS 940.
97 @item SWTP 6800.
98 @end itemize")
99 (license license:expat)))