gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / pth.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2015 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages pth)
22 #:use-module (guix licenses)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu))
26
27 (define-public pth
28 (package
29 (name "pth")
30 (version "2.0.7")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append "mirror://gnu/pth/pth-" version
35 ".tar.gz"))
36 (sha256
37 (base32
38 "0ckjqw5kz5m30srqi87idj7xhpw6bpki43mj07bazjm2qmh3cdbj"))))
39 (build-system gnu-build-system)
40 (arguments
41 `(#:parallel-build? #f
42 #:configure-flags (list
43 ,@(if (string=? "aarch64-linux"
44 (%current-system))
45 '("--host=aarch64-unknown-linux-gnu")
46 '()))))
47 (home-page "https://www.gnu.org/software/pth/")
48 (synopsis "Portable thread library")
49 (description
50 "GNU Pth is a portable library providing non-preemptive, priority-based
51 scheduling for multiple execution threads. Each thread has its own
52 program-counter, run-time stack, signal mask and errno variable. Threads are
53 scheduled in a cooperative way, rather than in the standard preemptive way,
54 such that they are managed according to priority and events. However, Pth
55 also features emulation of POSIX.1c threads (\"pthreads\") for backwards
56 compatibility.")
57 (license lgpl2.1+)))