gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / presentation.scm
1 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
2 ;;;
3 ;;; This file is part of GNU Guix.
4 ;;;
5 ;;; GNU Guix is free software; you can redistribute it and/or modify it
6 ;;; under the terms of the GNU General Public License as published by
7 ;;; the Free Software Foundation; either version 3 of the License, or (at
8 ;;; your option) any later version.
9 ;;;
10 ;;; GNU Guix is distributed in the hope that it will be useful, but
11 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
12 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
13 ;;; GNU General Public License for more details.
14 ;;;
15 ;;; You should have received a copy of the GNU General Public License
16 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
17
18 (define-module (gnu packages presentation)
19 #:use-module ((guix licenses) #:prefix license:)
20 #:use-module (guix download)
21 #:use-module (guix packages)
22 #:use-module (guix utils)
23 #:use-module (guix build-system python)
24 #:use-module (gnu packages figlet)
25 #:use-module (gnu packages games)
26 #:use-module (gnu packages image)
27 #:use-module (gnu packages python)
28 #:use-module (gnu packages python-xyz))
29
30 (define-public presentty
31 (package
32 (name "presentty")
33 (version "0.2.1")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (pypi-uri "presentty" version))
38 (sha256
39 (base32
40 "1qpy992hyg1amjl0acic3agj20spcpv5m0ncg1283mmxs8cs3xy9"))
41 (patches
42 (list
43 (origin
44 (method url-fetch)
45 (uri "https://sources.debian.org/data/main/p/presentty/0.2.1-1/debian/patches/presentty-python3.patch")
46 (sha256
47 (base32
48 "03d3ylh1z99g4dqj7aka60spagnwss9mbacd7jbpk1gazflnssz1")))))))
49 (build-system python-build-system)
50 (arguments
51 `(#:tests? #f ; Test suite hasn't withstood the test of time.
52 #:phases
53 (modify-phases %standard-phases
54 (replace 'wrap
55 (lambda* (#:key python inputs outputs #:allow-other-keys)
56 (let* ((out (assoc-ref outputs "out"))
57 (bin (string-append out "/bin/"))
58 (python (assoc-ref inputs "python")))
59 (for-each
60 (lambda (program)
61 (wrap-program (string-append bin program)
62 `("PATH" ":" prefix (,(dirname (which "cowsay"))
63 ,(dirname (which "figlet"))
64 ,(dirname (which "jp2a"))))
65 `("PYTHONPATH" prefix
66 ,(cons (string-append out "/lib/python"
67 (python-version python)
68 "/site-packages")
69 (search-path-as-string->list
70 (or (getenv "PYTHONPATH") ""))))))
71 '("presentty" "presentty-console")))
72 #t)))))
73 (inputs
74 `(("cowsay" ,cowsay)
75 ("figlet" ,figlet)
76 ("jp2a" ,jp2a)
77 ("python-docutils" ,python-docutils)
78 ("python-pillow" ,python-pillow-2.9)
79 ("python-six" ,python-six)
80 ("python-urwid" ,python-urwid)))
81 (native-inputs
82 `(("python-pbr" ,python-pbr)
83 ("python-pygments" ,python-pygments)))
84 (home-page "http://git.inaugust.com/cgit/presentty/")
85 (synopsis "Console-based presentation system")
86 (description "Presentty is a console-based presentation program where slides
87 are authored in reStructuredText. Its features include, but are not limited to:
88 Cross-fade animations, progressive list display, panning transitions, syntax
89 highlighting, Cowsay and figlet integration, ANSI art, JPEG display.")
90 (license license:gpl3+)))