gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / pem.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Eric Bavier <bavier@member.fsf.org>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages pem)
20 #:use-module (guix packages)
21 #:use-module (guix licenses)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages perl))
25
26 (define-public pem
27 (package
28 (name "pem")
29 (version "0.7.9")
30 (source
31 (origin
32 (method url-fetch)
33 (uri (string-append "mirror://gnu/pem/pem-"
34 version ".tar.gz"))
35 (sha256
36 (base32
37 "03iqcki1lakkck1akdyvljjapgqda3l0rh38id7jhrac9kcxqgg2"))))
38 (build-system gnu-build-system)
39 (inputs `(("perl" ,perl)))
40 (home-page "https://www.gnu.org/software/pem/")
41 (synopsis "Personal expenses manager")
42 (description
43 "GNU Pem is a simple tool for tracking personal income and
44 expenses. It operates from the command line and it stores its data
45 in a basic text format in your home directory. It can easily print
46 reports of your spending on different expenses via a basic search
47 feature.")
48 (license gpl3+)))