gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / u-boot-riscv64-fix-extlinux.patch
1 From 3fc056f0b9f7c26e58a1e947c8c0184e55919614 Mon Sep 17 00:00:00 2001
2 From: David Abdurachmanov <david.abdurachmanov@gmail.com>
3 Date: Wed, 21 Aug 2019 12:07:20 -0700
4 Subject: [PATCH] qemu-riscv64_smode, sifive-fu540: fix extlinux (define
5 preboot)
6 Forwarded: https://patchwork.ozlabs.org/patch/1151125/
7
8 Commit 37304aaf60bf92a5dc3ef222ba520698bd862a44 removed preboot
9 commands in RISC-V targets and broke extlinux support as reported
10 by Fu Wei <wefu@redhat.com>.
11
12 The patch finishes migration of CONFIG_USE_PREBOOT and CONFIG_REBOOT
13 to Kconfig.
14
15 Signed-off-by: David Abdurachmanov <david.abdurachmanov@sifive.com>
16 ---
17 configs/qemu-riscv64_smode_defconfig | 2 ++
18 configs/sifive_fu540_defconfig | 2 ++
19 3 files changed, 4 insertions(+), 4 deletions(-)
20
21 Index: u-boot/configs/qemu-riscv64_smode_defconfig
22 ===================================================================
23 --- u-boot.orig/configs/qemu-riscv64_smode_defconfig
24 +++ u-boot/configs/qemu-riscv64_smode_defconfig
25 @@ -14,3 +14,5 @@ CONFIG_CMD_NVEDIT_EFI=y
26 CONFIG_OF_PRIOR_STAGE=y
27 CONFIG_SYS_RELOC_GD_ENV_ADDR=y
28 CONFIG_DM_MTD=y
29 +CONFIG_USE_PREBOOT=y
30 +CONFIG_PREBOOT="setenv fdt_addr ${fdtcontroladdr}; fdt addr ${fdtcontroladdr};"
31 Index: u-boot/configs/sifive_fu540_defconfig
32 ===================================================================
33 --- u-boot.orig/configs/sifive_fu540_defconfig
34 +++ u-boot/configs/sifive_fu540_defconfig
35 @@ -27,3 +27,5 @@ CONFIG_SPL_DM_SEQ_ALIAS=y
36 CONFIG_SPL_CLK=y
37 CONFIG_DM_MTD=y
38 CONFIG_DM_RESET=y
39 +CONFIG_USE_PREBOOT=y
40 +CONFIG_PREBOOT="setenv fdt_addr ${fdtcontroladdr}; fdt addr ${fdtcontroladdr};"