gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / sharutils-CVE-2018-1000097.patch
1 Fix CVE-2018-1000097:
2
3 https://security-tracker.debian.org/tracker/CVE-2018-1000097
4 https://nvd.nist.gov/vuln/detail/CVE-2018-1000097
5
6 Patch taken from upstream bug report:
7 https://lists.gnu.org/archive/html/bug-gnu-utils/2018-02/msg00005.html
8
9 diff --git a/src/unshar.c b/src/unshar.c
10 index 80bc3a9..0fc3773 100644
11 --- a/src/unshar.c
12 +++ b/src/unshar.c
13 @@ -240,7 +240,7 @@ find_archive (char const * name, FILE * file, off_t start)
14 off_t position = ftello (file);
15
16 /* Read next line, fail if no more and no previous process. */
17 - if (!fgets (rw_buffer, BUFSIZ, file))
18 + if (!fgets (rw_buffer, rw_base_size, file))
19 {
20 if (!start)
21 error (0, 0, _("Found no shell commands in %s"), name);