gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / scheme48-tests.patch
1 The test case below relies on /etc/groups and similar info that is
2 not available in chroot builds, so skip it.
3
4 --- scheme48-1.9/scheme/posix/check.scm 2013-05-11 21:55:36.000000000 +0200
5 +++ scheme48-1.9/scheme/posix/check.scm 2013-05-11 21:55:40.000000000 +0200
6 @@ -229,29 +229,7 @@
7
8 ; This assumes that we are not running as root and that / is owned by root.
9
10 -(define-test-case users&groups posix-core-tests
11 - (let ((my-info (get-file-info directory-name))
12 - (root-info (get-file-info "/")))
13 - (let ((my-user (user-id->user-info (file-info-owner my-info)))
14 - (root-user (user-id->user-info (file-info-owner root-info)))
15 - (my-group (group-id->group-info (file-info-group my-info)))
16 - (root-group (group-id->group-info (file-info-group root-info))))
17 - (let ((my-other-user (name->user-info (user-info-name my-user)))
18 - (my-other-group (name->group-info (group-info-name my-group))))
19 - (check-that (file-info-owner my-info)
20 - (is user-id=? (user-info-id my-user)))
21 - (check-that (file-info-owner root-info)
22 - (opposite (is user-id=? (user-info-id my-user))))
23 - (check-that (file-info-group my-info)
24 - (is group-id=? (group-info-id my-group)))
25 - ;; doesn't work reliably
26 - ;; (specifically, if the user is member of wheel)
27 - ;; (check (not (group-id=? (file-info-group root-info)
28 - ;; (group-info-id my-group))))
29 - (check-that (os-string->string (user-info-name root-user))
30 - (member-of '("root"
31 - "bin" ; AIX
32 - )))))))
33 +
34
35 (define-test-case environment posix-core-tests
36 (let ((env (reverse (environment-alist))))