gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / rust-1.48-linker-locale.patch
1 https://github.com/rust-lang/rust/pull/74416
2 diff --git a/compiler/rustc_codegen_ssa/src/back/linker.rs b/compiler/rustc_codegen_ssa/src/back/linker.rs
3 index 3df956c465e..f45fee45be4 100644
4 --- a/compiler/rustc_codegen_ssa/src/back/linker.rs
5 +++ b/compiler/rustc_codegen_ssa/src/back/linker.rs
6 @@ -28,7 +28,7 @@
7 pub fn disable_localization(linker: &mut Command) {
8 // No harm in setting both env vars simultaneously.
9 // Unix-style linkers.
10 - linker.env("LC_ALL", "C");
11 + linker.env("LC_ALL", "en_US.UTF-8");
12 // MSVC's `link.exe`.
13 linker.env("VSLANG", "1033");
14 }