gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / rcs-5.10.0-no-stdin.patch
1 http://git.savannah.gnu.org/cgit/rcs.git/patch/?id=8883c4f5a29be18e9ea09bd27a7b660830de45bb
2
3
4 From 8883c4f5a29be18e9ea09bd27a7b660830de45bb Mon Sep 17 00:00:00 2001
5 From: Thien-Thi Nguyen <ttn@gnu.org>
6 Date: Fri, 23 Oct 2020 09:23:49 -0400
7 Subject: [v] Don't test signal handling if stdin not ok.
8
9 <https://mail.gnu.org/archive/html/bug-rcs/2020-10/msg00014.html>
10
11 * tests/t632: If stdin is not open and connected to
12 a tty, skip the signal handling portion of the test.
13 ---
14 tests/ChangeLog | 9 +++++++++
15 tests/t632 | 9 +++++++++
16 2 files changed, 18 insertions(+)
17
18 diff --git a/tests/ChangeLog b/tests/ChangeLog
19 index c3715c0..0565058 100644
20 --- a/tests/ChangeLog
21 +++ b/tests/ChangeLog
22 @@ -1,3 +1,12 @@
23 +2020-10-23 Thien-Thi Nguyen <ttn@gnu.org>
24 +
25 + [v] Don't test signal handling if stdin not ok.
26 +
27 + <https://mail.gnu.org/archive/html/bug-rcs/2020-10/msg00014.html>
28 +
29 + * t632: If stdin is not open and connected to
30 + a tty, skip the signal handling portion of the test.
31 +
32 2020-10-20 Thien-Thi Nguyen <ttn@gnu.org>
33
34 Release: 5.10.0
35 diff --git a/tests/t632 b/tests/t632
36 index df6acc9..677ec8c 100644
37 --- a/tests/t632
38 +++ b/tests/t632
39 @@ -40,6 +40,15 @@ echo | co -l -I $w \
40 # (This is skipped if GNU coreutils timeout(1) is not available.)
41 ##
42
43 +# <https://mail.gnu.org/archive/html/bug-rcs/2020-10/msg00014.html>
44 +# The timeout test needs co(1) to block on input.
45 +# If stdin is not open and connected to a tty, skip out.
46 +if test -t 0 ; then
47 + echo STDIN OK
48 +else
49 + exit 0
50 +fi
51 +
52 # TODO: Don't be lame! Pick one:
53 # (a) Mimic timeout(1) w/ sh commands.
54 # (b) Incorporate heart of timeout(1) into ./btdt and use that.
55 --
56 cgit v1.2.1
57