gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / qtbase-absolute-runpath.patch
1 Do not use $ORIGIN in RUNPATH so that executables can be copied elsewhere and
2 still be expected to work (needed for python-pyside-2-tools).
3
4 diff --git a/mkspecs/common/linux.conf b/mkspecs/common/linux.conf
5 --- a/mkspecs/common/linux.conf
6 +++ b/mkspecs/common/linux.conf
7 @@ -10,8 +10,8 @@ QMAKE_CFLAGS_THREAD += -D_REENTRANT
8 QMAKE_CXXFLAGS_THREAD += $$QMAKE_CFLAGS_THREAD
9 QMAKE_LFLAGS_GCSECTIONS = -Wl,--gc-sections
10
11 -QMAKE_LFLAGS_REL_RPATH = -Wl,-z,origin
12 -QMAKE_REL_RPATH_BASE = $ORIGIN
13 +QMAKE_LFLAGS_REL_RPATH =
14 +QMAKE_REL_RPATH_BASE =
15
16 QMAKE_INCDIR =
17 QMAKE_LIBDIR =