gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / pybugz-encode-error.patch
1 In case of 'AttributeError', 'value' is None, so do not try to
2 access it.
3 Submitted upstream.
4
5 --- pybugz-0.6.11/bugz.py 2006-09-02 14:35:37.000000000 +0200
6 +++ pybugz-0.6.11/bugz.py 2014-05-05 16:02:20.000000000 +0200
7 @@ -1249,9 +1254,9 @@ class PrettyBugz(Bugz):
8 for field, name in FIELDS + MORE_FIELDS:
9 try:
10 value = result.find('//%s' % field).text
11 + print '%-12s: %s' % (name, value.encode(self.enc))
12 except AttributeError:
13 continue
14 - print '%-12s: %s' % (name, value.encode(self.enc))
15
16 # Print out the cc'ed people
17 cced = result.findall('.//cc')