gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / openmpi-mtl-priorities.patch
1 PSM2 is the only valid implementation for OmniPath (OPA). UCX also
2 supports OmniPath, but it does so via Verbs, thus getting much lower
3 performance (typically 3 GiB/s instead of 10 GiB/s).
4
5 To work around that, give the mtl_psm2 component a higher priority
6 than the pml_ucx component.
7
8 See <https://www.mail-archive.com/users@lists.open-mpi.org/msg33581.html>.
9
10 --- openmpi-4.0.2/ompi/mca/mtl/psm2/mtl_psm2_component.c 2019-11-15 17:06:15.142076840 +0100
11 +++ openmpi-4.0.2/ompi/mca/mtl/psm2/mtl_psm2_component.c 2019-11-15 17:06:22.242009379 +0100
12 @@ -126,7 +126,7 @@ ompi_mtl_psm2_component_register(void)
13 setenv("PSM2_DEVICES", "self,shm", 0);
14 }
15
16 - param_priority = 40;
17 + param_priority = 55;
18 (void) mca_base_component_var_register (&mca_mtl_psm2_component.super.mtl_version,
19 "priority", "Priority of the PSM2 MTL component",
20 MCA_BASE_VAR_TYPE_INT, NULL, 0, 0,
21
22 Likewise for PSM: we want InfiniPath to be taken care of by PSM, not by UCX,
23 since UCX achieves worse performance.
24
25 --- openmpi-4.0.2/ompi/mca/mtl/psm/mtl_psm_component.c
26 +++ openmpi-4.0.2/ompi/mca/mtl/psm/mtl_psm_component.c
27 @@ -92,7 +92,7 @@ ompi_mtl_psm_component_register(void)
28
29
30 /* set priority high enough to beat ob1's default */
31 - param_priority = 30;
32 + param_priority = 54;
33 (void) mca_base_component_var_register (&mca_mtl_psm_component.super.mtl_version,
34 "priority", "Priority of the PSM MTL component",
35 MCA_BASE_VAR_TYPE_INT, NULL, 0, 0,