gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / mpc123-initialize-ao.patch
1 Description: Zero ao_sample_format structure to cope with libao 1.0.0
2 Author: Colin Watson <cjwatson@debian.org>
3 Bug-Debian: http://bugs.debian.org/591396
4 Bug-Ubuntu: https://bugs.launchpad.net/bugs/710268
5 Forwarded: no
6 Last-Update: 2013-05-07
7
8 Index: b/ao.c
9 ===================================================================
10 --- a/ao.c
11 +++ b/ao.c
12 @@ -123,6 +123,7 @@
13
14 /* initialize ao_format struct */
15 /* XXX VERY WRONG */
16 + memset(&ao_fmt, 0, sizeof(ao_fmt));
17 ao_fmt.bits=16; /*tmp_stream_info.average_bitrate;*/
18 ao_fmt.rate=streaminfo->sample_freq;
19 ao_fmt.channels=streaminfo->channels;