gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / lsof-fatal-test-failures.patch
1 From: Tobias Geerinckx-Rice <me@tobias.gr>
2 Date: Mon, 23 Nov 2020 05:36:53 +0100
3 Subject: [PATCH] gnu: lsof: Make test failures fatal.
4
5 Submitted upstream[0].
6
7 [0]: https://github.com/lsof-org/lsof/pull/144
8
9 diff --git a/tests/Makefile b/tests/Makefile
10 index 08574a0..2923bb8 100644
11 --- a/tests/Makefile
12 +++ b/tests/Makefile
13 @@ -27,7 +27,7 @@ all: ${CKTSTDB} ${BASTST} ${STDTST} FRC
14 exit 1 ;\
15 fi
16 @rm -f config.LT*
17 - -@err=0; \
18 + @err=0; \
19 echo ""; \
20 echo "Basic test:"; \
21 ./${BASTST}; \
22 @@ -54,8 +54,11 @@ all: ${CKTSTDB} ${BASTST} ${STDTST} FRC
23 echo "Suggestion: try the optional tests: \"make opt\""; \
24 echo ""; \
25 fi; \
26 - fi;
27 - @rm -f config.LT*
28 + fi; \
29 + rm -f config.LT*; \
30 + if [ $$err -ne 0 ]; then \
31 + exit 1; \
32 + fi
33
34 auto: ckDB silent FRC
35
36 @@ -112,7 +115,7 @@ LTunix: LTunix.c ${CONFIG} ${LIBOBJ} ${HDR} config.ldflags
37
38 opt: ${CKTSTDB} ${OPTTST} FRC
39 @rm -f config.LT*
40 - -@err=0; \
41 + @err=0; \
42 echo ""; \
43 echo "Optional tests:"; \
44 for i in ${OPTTST}; do \
45 @@ -126,8 +129,11 @@ opt: ${CKTSTDB} ${OPTTST} FRC
46 else \
47 echo "All optional tests succeeded."; \
48 fi; \
49 - echo "";
50 - @rm -f config.LT*
51 + echo ""; \
52 + rm -f config.LT*; \
53 + if [ $$err -ne 0 ]; then \
54 + exit 1; \
55 + fi
56
57 optional: opt
58