gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / libmp4v2-c++11.patch
1 Avoid a type mismatch that shows up in C++11.
2 Taken from <https://bugs.debian.org/853560>.
3
4 --- a/src/rtphint.cpp 2012-05-20 16:11:53.000000000 -0600
5 +++ b/src/rtphint.cpp 2017-05-16 10:25:26.930705191 -0600
6 @@ -339,7 +339,7 @@
7 pSlash = strchr(pSlash, '/');
8 if (pSlash != NULL) {
9 pSlash++;
10 - if (pSlash != '\0') {
11 + if (*pSlash != '\0') {
12 length = (uint32_t)strlen(pRtpMap) - (pSlash - pRtpMap);
13 *ppEncodingParams = (char *)MP4Calloc(length + 1);
14 strncpy(*ppEncodingParams, pSlash, length);