gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / kobodeluxe-midicon-segmentation-fault.patch
1 From: Emile CARRY <emile.carry@sequanux.org>
2 Date: Wed, 6 Apr 2016 00:27:17 +0200
3 Subject: midicon segmentation fault
4
5 Debian-Bug: https://bugs.debian.org/819897
6 Forwarded: no
7 ---
8 sound/a_midicon.c | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11 diff --git a/sound/a_midicon.c b/sound/a_midicon.c
12 index 57de3cf..ded2988 100644
13 --- a/sound/a_midicon.c
14 +++ b/sound/a_midicon.c
15 @@ -120,8 +120,8 @@ static inline void __press(unsigned ch, unsigned key)
16 {
17 m[ch].next[key] = -1;
18 m[ch].prev[key] = m[ch].last;
19 - m[ch].next[m[ch].last] = (char)key;
20 m[ch].last = (char)key;
21 + m[ch].next[m[ch].last] = (char)key;
22 }
23
24