gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / kobodeluxe-graphics-window-signed-char.patch
1 # This was created in responce to Debian bug #163979
2 # Thing is, if you want to compant "-1" with a char value,
3 # you better make that char signed
4 --- kobodeluxe-0.5.1.orig/graphics/window.cpp
5 +++ kobodeluxe-0.5.1/graphics/window.cpp
6 @@ -331,7 +331,7 @@
7 }
8
9
10 -void window_t::center_token(int _x, int _y, const char *txt, char token)
11 +void window_t::center_token(int _x, int _y, const char *txt, signed char token)
12 {
13 center_token_fxp(PIXEL2CS(_x), PIXEL2CS(_y), txt, token);
14 }
15 @@ -374,7 +374,7 @@
16 }
17
18
19 -void window_t::center_token_fxp(int _x, int _y, const char *txt, char token)
20 +void window_t::center_token_fxp(int _x, int _y, const char *txt, signed char token)
21 {
22 _x = CS2PIXEL((_x * xs + 128) >> 8);
23 _y = CS2PIXEL((_y * ys + 128) >> 8);
24 --- kobodeluxe-0.5.1.orig/graphics/window.h
25 +++ kobodeluxe-0.5.1/graphics/window.h
26 @@ -265,10 +265,10 @@
27 void font(int fnt);
28 void string(int _x, int _y, const char *txt);
29 void center(int _y, const char *txt);
30 - void center_token(int _x, int _y, const char *txt, char token = 0);
31 + void center_token(int _x, int _y, const char *txt, signed char token = 0);
32 void string_fxp(int _x, int _y, const char *txt);
33 void center_fxp(int _y, const char *txt);
34 - void center_token_fxp(int _x, int _y, const char *txt, char token = 0);
35 + void center_token_fxp(int _x, int _y, const char *txt, signed char token = 0);
36 int textwidth(const char *txt, int min = 0, int max = 255);
37 int textwidth_fxp(const char *txt, int min = 0, int max = 255);
38 int fontheight();