gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / icecat-avoid-bundled-libraries.patch
1 Fixes needed when avoiding bundled libraries.
2
3 --- icecat-60.5.0/xpcom/build/moz.build.orig 2018-09-13 17:46:49.000000000 -0400
4 +++ icecat-60.5.0/xpcom/build/moz.build 2018-09-22 04:26:50.659564554 -0400
5 @@ -99,10 +99,5 @@
6 '/docshell/base',
7 ]
8
9 -if CONFIG['MOZ_VPX']:
10 - LOCAL_INCLUDES += [
11 - '/media/libvpx',
12 - ]
13 -
14 if CONFIG['MOZ_WIDGET_TOOLKIT'] == 'cocoa':
15 CXXFLAGS += CONFIG['TK_CFLAGS']
16 --- icecat-60.5.0/storage/moz.build.orig 2018-09-13 17:51:11.000000000 -0400
17 +++ icecat-60.5.0/storage/moz.build 2018-09-22 04:26:50.659564554 -0400
18 @@ -117,7 +117,6 @@
19 DEFINES['MOZ_MEMORY_TEMP_STORE_PRAGMA'] = True
20
21 LOCAL_INCLUDES += [
22 - '/db/sqlite3/src',
23 '/dom/base',
24 ]
25
26 --- icecat-60.5.0/dom/indexedDB/moz.build.orig 2018-09-13 17:49:42.000000000 -0400
27 +++ icecat-60.5.0/dom/indexedDB/moz.build 2018-09-22 04:26:50.663564574 -0400
28 @@ -102,7 +102,6 @@
29 CXXFLAGS += ['-Wno-error=shadow']
30
31 LOCAL_INCLUDES += [
32 - '/db/sqlite3/src',
33 '/dom/base',
34 '/dom/storage',
35 '/ipc/glue',
36 --- icecat-60.5.0/media/webrtc/trunk/webrtc/base/rtc_task_queue_gn/moz.build.orig 2018-09-13 17:40:54.000000000 -0400
37 +++ icecat-60.5.0/media/webrtc/trunk/webrtc/base/rtc_task_queue_gn/moz.build 2018-09-23 21:33:12.319975105 -0400
38 @@ -130,11 +130,6 @@
39 DEFINES["WEBRTC_POSIX"] = True
40 DEFINES["_FILE_OFFSET_BITS"] = "64"
41
42 - LOCAL_INCLUDES += [
43 - "/ipc/chromium/src/third_party/libevent/include/",
44 - "/ipc/chromium/src/third_party/libevent/linux/"
45 - ]
46 -
47 UNIFIED_SOURCES += [
48 "/media/webrtc/trunk/webrtc/base/task_queue_libevent.cc",
49 "/media/webrtc/trunk/webrtc/base/task_queue_posix.cc"