gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / hdf-eos5-remove-gctp.patch
1 Don't build/install/use bundled gctp code/headers.
2
3 * cproj.h, proj.h: part of GCTP, therefore already present.
4 * HE5_config.h, tutils.h: used for library building and testing.
5
6 diff --git a/Makefile.in b/Makefile.in
7 index f160d0d..367b537 100644
8 --- a/Makefile.in
9 +++ b/Makefile.in
10 @@ -206,7 +206,7 @@ LIBGCTP = $(top_builddir)/gctp/src/libGctp.la
11 @TESTDRIVERS_CONDITIONAL_TRUE@TESTDRIVERS = testdrivers
12 @INSTALL_INCLUDE_CONDITIONAL_FALSE@INCLUDE =
13 @INSTALL_INCLUDE_CONDITIONAL_TRUE@INCLUDE = include
14 -SUBDIRS = gctp src $(INCLUDE) samples $(TESTDRIVERS)
15 +SUBDIRS = src $(INCLUDE) samples $(TESTDRIVERS)
16 all: all-recursive
17
18 .SUFFIXES:
19 diff --git a/samples/Makefile.in b/samples/Makefile.in
20 index 59331dd..64fda89 100644
21 --- a/samples/Makefile.in
22 +++ b/samples/Makefile.in
23 @@ -206,7 +206,6 @@ he5_gd_datainfo_SOURCES = he5_gd_datainfo.c
24 he5_gd_datainfo_OBJECTS = he5_gd_datainfo.$(OBJEXT)
25 he5_gd_datainfo_LDADD = $(LDADD)
26 am__DEPENDENCIES_1 = $(top_builddir)/src/libhe5_hdfeos.la
27 -am__DEPENDENCIES_2 = $(top_builddir)/gctp/src/libGctp.la
28 he5_gd_datainfo_DEPENDENCIES = $(am__DEPENDENCIES_1) \
29 $(am__DEPENDENCIES_2)
30 he5_gd_defexternalfld_SOURCES = he5_gd_defexternalfld.c
31 @@ -1093,7 +1092,7 @@ sharedstatedir = @sharedstatedir@
32 sysconfdir = @sysconfdir@
33 target_alias = @target_alias@
34 LIBHDFEOS5 = $(top_builddir)/src/libhe5_hdfeos.la
35 -LIBGCTP = $(top_builddir)/gctp/src/libGctp.la
36 +LIBGCTP =
37
38 # Boilerplate definitions file
39
40 diff --git a/include/Makefile.in b/include/Makefile.in
41 index a572128..64dabb5 100644
42 --- a/include/Makefile.in
43 +++ b/include/Makefile.in
44 @@ -190,8 +190,7 @@ LIBGCTP = $(top_builddir)/gctp/src/libGctp.la
45 # Boilerplate include
46
47 # Headers to install
48 -include_HEADERS = HE5_GctpFunc.h HE5_HdfEosDef.h HE5_config.h cproj.h ease.h \
49 - isin.h proj.h tutils.h cfortHdf.h
50 +include_HEADERS = HE5_GctpFunc.h HE5_HdfEosDef.h ease.h isin.h cfortHdf.h
51
52 all: HE5_config.h
53 $(MAKE) $(AM_MAKEFLAGS) all-am
54 --
55 2.10.0