gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / gtksourceview-2-add-default-directory.patch
1 From fc401acb15f15d487c942437b6fb429289dd3c67 Mon Sep 17 00:00:00 2001
2 From: Julien Lepiller <julien@lepiller.eu>
3 Date: Fri, 31 May 2019 13:22:25 +0200
4 Subject: [PATCH] Add installation directory as a default directory.
5
6 In Guix, this library is installed in a separate directory in the store,
7 and it's typically not installed system-wide in a fixed directory. Add
8 the store path to the set of default directories so dependents can find
9 default langs and source highlighting scheme.
10 ---
11 gtksourceview/gtksourceview-utils.c | 6 ++++++
12 1 file changed, 6 insertions(+)
13
14 diff --git a/gtksourceview/gtksourceview-utils.c b/gtksourceview/gtksourceview-utils.c
15 index 6f06bab..c3467d5 100644
16 --- a/gtksourceview/gtksourceview-utils.c
17 +++ b/gtksourceview/gtksourceview-utils.c
18 @@ -66,6 +66,12 @@ _gtk_source_view_get_default_dirs (const char *basename,
19 basename,
20 NULL));
21
22 + /* installed dir */
23 + g_ptr_array_add (dirs, g_build_filename (DATADIR,
24 + SOURCEVIEW_DIR,
25 + basename,
26 + NULL));
27 +
28 g_ptr_array_add (dirs, NULL);
29
30 return (gchar**) g_ptr_array_free (dirs, FALSE);
31 --
32 2.21.0
33