gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / gdb-hurd.patch
1 Taken from upstream, removed ChangeLog.
2
3 From 6930bffe3373690b3431d6291f9f7c116d6a1ec4 Mon Sep 17 00:00:00 2001
4 From: Samuel Thibault <samuel.thibault@ens-lyon.org>
5 Date: Sat, 30 May 2020 18:35:59 +0000
6 Subject: [PATCH] hurd: fix gnu_debug_flag type
7 MIME-Version: 1.0
8 Content-Type: text/plain; charset=UTF-8
9 Content-Transfer-Encoding: 8bit
10
11 Fixes
12
13 ../../gdb/gnu-nat.c:96:6: error: conflicting declaration ‘bool gnu_debug_flag’
14 96 | bool gnu_debug_flag = false;
15 ../../gdb/gnu-nat.c: In function ‘void _initialize_gnu_nat()’:
16 ../../gdb/gnu-nat.c:3511:7: error: cannot
17
18 gdb/ChangeLog:
19
20 * gnu-nat.h (gnu_debug_flag): Set type to bool.
21 ---
22 gdb/ChangeLog | 4 ++++
23 gdb/gnu-nat.h | 2 +-
24 2 files changed, 5 insertions(+), 1 deletion(-)
25
26 diff --git a/gdb/gnu-nat.h b/gdb/gnu-nat.h
27 index 77c57817b2..766f716587 100644
28 --- a/gdb/gnu-nat.h
29 +++ b/gdb/gnu-nat.h
30 @@ -111,7 +111,7 @@ extern char *proc_string (struct proc *proc);
31 __proc_pid (__proc), __proc->tid, \
32 host_address_to_string (__proc) , ##args); } while (0)
33
34 -extern int gnu_debug_flag;
35 +extern bool gnu_debug_flag;
36
37 #define debug(msg, args...) \
38 do { if (gnu_debug_flag) \
39 --
40 Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
41 Freelance IT http://JoyofSource.com | Avatar® http://AvatarAcademy.com
42
43 commit 366f550a593c7e6bae3699a4b6d65fe937af5603
44 Author: Samuel Thibault <samuel.thibault@ens-lyon.org>
45 Date: Sat May 30 18:41:30 2020 +0000
46
47 hurd: add missing include
48
49 Fixes
50
51 ../../gdb/gnu-nat.c:2522:14: error: ‘target_gdbarch’ was not declared in this scope; did you mean ‘target_detach’?
52 2522 | paddress (target_gdbarch (), memaddr), pulongest (len),
53
54 gdb/Changelog:
55
56 * gnu-nat.c: Include "gdbarch.h".
57
58 diff --git a/gdb/gnu-nat.c b/gdb/gnu-nat.c
59 index 3b438a9a43..9b93488b41 100644
60 --- a/gdb/gnu-nat.c
61 +++ b/gdb/gnu-nat.c
62 @@ -64,6 +64,7 @@ extern "C"
63 #include "language.h"
64 #include "target.h"
65 #include "gdbsupport/gdb_wait.h"
66 +#include "gdbarch.h"
67 #include "gdbcmd.h"
68 #include "gdbcore.h"
69 #include "gdbthread.h"