gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / gcc-fix-texi2pod.patch
1 This patch was taken from the official GCC git repository.
2 X-Git-Url: https://gcc.gnu.org/git/?p=gcc.git;a=blobdiff_plain;f=contrib%2Ftexi2pod.pl;h=91bdbb5cea933d0381f2924ab94490fca31d5800;hp=eba1bcaa3cffa78b46030b219d04fe7d68367658;hb=67b56c905078d49d3e4028085e5cb1e1fb87a8aa;hpb=2f508a78310caab123e9794d3dcfe41f2769449b
3
4 It fixes a defect in the contrib/texi2pod.pl script that prevented generating
5 manual pages. It was corrected in the GCC 6.X series.
6
7 diff --git a/contrib/texi2pod.pl b/contrib/texi2pod.pl
8 index eba1bca..91bdbb5 100755
9 --- a/contrib/texi2pod.pl
10 +++ b/contrib/texi2pod.pl
11 @@ -316,7 +316,7 @@ while(<$inf>) {
12 @columns = ();
13 for $column (split (/\s*\@tab\s*/, $1)) {
14 # @strong{...} is used a @headitem work-alike
15 - $column =~ s/^\@strong{(.*)}$/$1/;
16 + $column =~ s/^\@strong\{(.*)\}$/$1/;
17 push @columns, $column;
18 }
19 $_ = "\n=item ".join (" : ", @columns)."\n";