gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / fifo-map-fix-flags-for-gcc.patch
1 From 0871db30bd73d112a434f54572d34cca28de61c5 Mon Sep 17 00:00:00 2001
2 From: fis <ybbs.daans@hotmail.com>
3 Date: Sat, 26 May 2018 22:58:37 +0800
4 Subject: [PATCH 2/2] * CMakeLists.txt: Fix flags for gcc.
5
6 ---
7 CMakeLists.txt | 18 ++----------------
8 1 file changed, 2 insertions(+), 16 deletions(-)
9
10 diff --git a/CMakeLists.txt b/CMakeLists.txt
11 index eba147b..d60dcef 100644
12 --- a/CMakeLists.txt
13 +++ b/CMakeLists.txt
14 @@ -6,20 +6,6 @@ add_executable(unit src/fifo_map.hpp test/unit.cpp)
15
16 target_include_directories(unit PRIVATE "test" "src")
17
18 -if(MSVC)
19 - set(CMAKE_CXX_FLAGS
20 - "/EHsc"
21 - )
22 +set(CMAKE_CXX_FLAGS "-std=c++11 -fpermissive")
23
24 - STRING(REPLACE "/O2" "/Od" CMAKE_CXX_FLAGS_RELEASE ${CMAKE_CXX_FLAGS_RELEASE})
25 -
26 - add_definitions(-D_SCL_SECURE_NO_WARNINGS)
27 -else(MSVC)
28 - set(CMAKE_CXX_FLAGS
29 - "-std=c++11 -stdlib=libc++"
30 - )
31 -endif(MSVC)
32 -
33 -include_directories(
34 - src test
35 -)
36 +include_directories(src test)
37 --
38 2.14.3
39