gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / emacs-json-reformat-fix-tests.patch
1 Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
2
3 This patch fixes tests for Emacs 25.
4
5 Upstream bug URL:
6
7 https://github.com/gongo/json-reformat/issues/33
8
9 diff --git a/test/json-reformat-test.el b/test/json-reformat-test.el
10 index 7de3be1..b4a4dde 100644
11 --- a/test/json-reformat-test.el
12 +++ b/test/json-reformat-test.el
13 @@ -58,7 +58,7 @@
14 (ert-deftest json-reformat-test:string-to-string ()
15 (should (string= "\"foobar\"" (json-reformat:string-to-string "foobar")))
16 (should (string= "\"fo\\\"o\\nbar\"" (json-reformat:string-to-string "fo\"o\nbar")))
17 - (should (string= "\"\\u2661\"" (json-reformat:string-to-string "\u2661")))
18 + (should (string= "\"♡\"" (json-reformat:string-to-string "\u2661")))
19
20 (should (string= "\"^(amq\\\\.gen.*|amq\\\\.default)$\"" (json-reformat:string-to-string "^(amq\\.gen.*|amq\\.default)$")))
21 )
22 @@ -148,6 +148,6 @@ bar\"" (json-reformat:string-to-string "fo\"o\nbar")))
23 [{ foo : \"bar\" }, { \"foo\" : \"baz\" }]") ;; At 3 (line)
24 (json-reformat-region (point-min) (point-max)))
25 (should (string=
26 - "JSON parse error [Reason] Bad string format: \"doesn't start with '\\\"'!\" [Position] In buffer, line 3 (char 6)"
27 + "JSON parse error [Reason] Bad string format: \"doesn't start with \`\\\"'!\" [Position] In buffer, line 3 (char 6)"
28 message-string))
29 )))
30 --
31 2.15.1
32