gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / desmume-gcc7-fixes.patch
1 From e1f7039f1b06add4fb75b2f8774000b8f05574af Mon Sep 17 00:00:00 2001
2 From: rogerman <rogerman@users.sf.net>
3 Date: Mon, 17 Aug 2015 21:15:04 +0000
4 Subject: Fix bug with libfat string handling.
5
6 diff --git a/src/utils/libfat/directory.cpp b/src/utils/libfat/directory.cpp
7 index 765d7ae5..b6d7f01f 100644
8 --- a/src/utils/libfat/directory.cpp
9 +++ b/src/utils/libfat/directory.cpp
10 @@ -139,7 +139,7 @@ static size_t _FAT_directory_mbstoucs2 (ucs2_t* dst, const char* src, size_t len
11 int bytes;
12 size_t count = 0;
13
14 - while (count < len-1 && src != '\0') {
15 + while (count < len-1 && *src != '\0') {
16 bytes = mbrtowc (&tempChar, src, MB_CUR_MAX, &ps);
17 if (bytes > 0) {
18 *dst = (ucs2_t)tempChar;