gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / dbus-helper-search-path.patch
1 The setuid helper of D-Bus is responsible for "service activation".
2 It looks for '.service' files in fixed locations, but the default locations
3 make no sense (see below), so replace them with /etc/dbus-1/system-services.
4
5 --- dbus-1.10.0/dbus/dbus-sysdeps-util-unix.c 2015-10-22 00:07:03.829251854 +0200
6 +++ dbus-1.10.0/dbus/dbus-sysdeps-util-unix.c 2015-10-22 00:07:14.893445175 +0200
7 @@ -1410,10 +1410,7 @@ _dbus_get_standard_system_servicedirs (D
8 * be available.
9 */
10 static const char standard_search_path[] =
11 - "/usr/local/share:"
12 - "/usr/share:"
13 - DBUS_DATADIR ":"
14 - "/lib";
15 + "/etc";
16 DBusString servicedir_path;
17
18 _dbus_string_init_const (&servicedir_path, standard_search_path);