gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / binutils-loongson-workaround.patch
1 Enable the workaround for the Loongson 2F bug by default.
2
3 Patch by Mark H Weaver <mhw@netris.org>.
4
5 --- binutils/gas/config/tc-mips.c.orig 2012-09-04 10:21:03.000000000 -0400
6 +++ binutils/gas/config/tc-mips.c 2013-10-06 02:23:21.651983768 -0400
7 @@ -910,10 +910,10 @@
8 };
9
10 /* ...likewise -mfix-loongson2f-jump. */
11 -static bfd_boolean mips_fix_loongson2f_jump;
12 +static bfd_boolean mips_fix_loongson2f_jump = FALSE;
13
14 /* ...likewise -mfix-loongson2f-nop. */
15 -static bfd_boolean mips_fix_loongson2f_nop;
16 +static bfd_boolean mips_fix_loongson2f_nop = TRUE;
17
18 /* True if -mfix-loongson2f-nop or -mfix-loongson2f-jump passed. */
19 static bfd_boolean mips_fix_loongson2f;
20 --- binutils/gas/testsuite/gas/mips/mips.exp.orig 2012-09-04 10:17:13.000000000 -0400
21 +++ binutils/gas/testsuite/gas/mips/mips.exp 2013-10-06 02:23:21.663983768 -0400
22 @@ -91,6 +91,12 @@
23
24 # Catch because the variable won't be set the first time through.
25 catch {unset mips_arches}
26 +
27 + # Disable the loongson2f nop fix by default, because most of the
28 + # existing test cases for mips will fail otherwise.
29 + global ASFLAGS
30 + set old_ASFLAGS "$ASFLAGS"
31 + set ASFLAGS "$ASFLAGS -mno-fix-loongson2f-nop"
32 }
33
34 # mips_arch_create ARCH GPRSIZE EXTENDS PROPS AS_FLAGS OBJDUMP_FLAGS \