gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / aegis-test-fixup-1.patch
1 This test fails because it expects a MIME type "Content-Type: image/gif"
2 whereas that provided by libmagic is "Content-Type: image/gif; charset=binary"
3 Presumably the test was written against a different version.
4 --- aegis-4.24/test/02/t0228a-matt.sh 2008-03-14 07:19:27.000000000 +0100
5 +++ aegis-4.24/test/02/t0228a-matt.sh 2014-01-27 09:43:44.000000000 +0100
6 @@ -147,7 +147,8 @@
7 SCRIPT_NAME=/cgi-bin/aeget \
8 PATH_INFO=icon/rss.gif \
9 QUERY_STRING= \
10 -$bin/aeget > rss.served.gif 2>&1
11 +$bin/aeget \
12 +| sed -e 's%^Content-Type: image/gif; charset=binary%Content-Type: image/gif%' > rss.served.gif 2>&1
13 if test $? -ne 0 ; then fail; fi
14
15 # Compare the expected and the actual received file.