gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / patches / aegis-constness-error.patch
1 Fixes a fatal constness error with g++ 4.8.2.
2 --- aegis-4.24/common/ac/string/memmem.cc 2008-03-14 07:19:27.000000000 +0100
3 +++ aegis-4.24/common/ac/string/memmem.cc 2014-01-26 11:17:58.000000000 +0100
4 @@ -182,7 +182,7 @@
5
6 // Use optimizations in memchr when possible.
7 if (needle_len == 1)
8 - return memchr(haystack, *needle, haystack_len);
9 + return (void *) memchr(haystack, *needle, haystack_len);
10
11 // Minimizing the worst-case complexity:
12 // Let n = haystack_len, m = needle_len.