gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / mtools.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 John Darrington <jmd@gnu.org>
3 ;;; Copyright © 2015, 2019 Ludovic Courtès <ludo@gnu.org>
4 ;;; Copyright © 2018, 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages mtools)
23 #:use-module (guix licenses)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages))
28
29 (define-public mtools
30 (package
31 (name "mtools")
32 (version "4.0.27")
33 (source (origin
34 (method url-fetch)
35 (uri (string-append "mirror://gnu/mtools/mtools-"
36 version ".tar.bz2"))
37 (sha256
38 (base32
39 "1crqi10adwfahj8xyw60lx70hkpcc5g00b5r8277cm2f4kcwi24w"))
40 (patches
41 (search-patches "mtools-mformat-uninitialized.patch"))))
42 (build-system gnu-build-system)
43 (home-page "https://www.gnu.org/software/mtools/")
44 (synopsis "Access MS-DOS disks without mounting")
45 (description
46 "GNU Mtools is a set of utilities for accessing MS-DOS disks from a GNU
47 or Unix system. It supports long file names and multiple disk formats. It
48 also supports some FAT-specific features such as volume labels and
49 FAT-specific file attributes.")
50 (license gpl3+)))
51
52 (define-public exfat-utils
53 (package
54 (name "exfat-utils")
55 (version "1.3.0")
56 (source (origin
57 (method url-fetch)
58 (uri (string-append
59 "https://github.com/relan/exfat/releases/download/v"
60 version "/" name "-" version ".tar.gz"))
61 (sha256
62 (base32
63 "0da8f8mm1sbwqp7prh78qk33xm0b8kk2d5is7mh2szlhgdxd1syz"))))
64 (build-system gnu-build-system)
65 (home-page "https://github.com/relan/exfat")
66 (synopsis "Utilities to manipulate exFAT file systems")
67 (description
68 "This package provides an implementation of the exFAT file system,
69 including command-line tools to validate exFAT file systems and to create new
70 ones.")
71 (license gpl2+)))