gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / mcrypt.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2014, 2020 Eric Bavier <bavier@posteo.net>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages mcrypt)
21 #:use-module (guix packages)
22 #:use-module ((guix licenses) #:select (gpl2+))
23 #:use-module (guix download)
24 #:use-module (guix build-system gnu)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages compression)
27 #:use-module (gnu packages perl))
28
29 (define-public mcrypt
30 (package
31 (name "mcrypt")
32 (version "2.6.8")
33 (source
34 (origin
35 (method url-fetch)
36 (uri (string-append "mirror://sourceforge/mcrypt/MCrypt/"
37 version "/" name "-" version ".tar.gz"))
38 (sha256
39 (base32
40 "161031n1w9pb4yzz9i47szc12a4mwpcpvyxnvafsik2l9s2aliai"))
41 (patches (search-patches
42 "mcrypt-CVE-2012-4409.patch"
43 "mcrypt-CVE-2012-4426.patch"
44 "mcrypt-CVE-2012-4527.patch"))))
45 (build-system gnu-build-system)
46 (inputs
47 `(("zlib" ,zlib)
48 ("libmcrypt" ,libmcrypt)
49 ("libmhash" ,libmhash)))
50 (home-page "http://mcrypt.sourceforge.net/")
51 (synopsis "Replacement for the popular Unix crypt command")
52 (description
53 "MCrypt is a replacement for the old crypt() package and crypt(1)
54 command, with extensions. It allows developers to use a wide range of
55 encryption functions, without making drastic changes to their code. It allows
56 users to encrypt files or data streams without having to be cryptographers.
57 The companion to MCrypt is Libmcrypt, which contains the actual encryption
58 functions themselves, and provides a standardized mechanism for accessing
59 them.")
60 (license gpl2+)))
61
62 (define-public libmcrypt
63 (package
64 (name "libmcrypt")
65 (version "2.5.8")
66 (source
67 (origin
68 (method url-fetch)
69 (uri (string-append "mirror://sourceforge/mcrypt/Libmcrypt/" version
70 "/libmcrypt-" version ".tar.gz"))
71 (sha256
72 (base32
73 "0gipgb939vy9m66d3k8il98rvvwczyaw2ixr8yn6icds9c3nrsz4"))))
74 (build-system gnu-build-system)
75 (home-page "http://mcrypt.sourceforge.net/")
76 (synopsis "Encryption algorithm library")
77 (description
78 "Libmcrypt is a data encryption library. The library is thread safe and
79 provides encryption and decryption functions. This version of the library
80 supports many encryption algorithms and encryption modes. Some algorithms
81 which are supported: SERPENT, RIJNDAEL, 3DES, GOST, SAFER+, CAST-256, RC2,
82 XTEA, 3WAY, TWOFISH, BLOWFISH, ARCFOUR, WAKE and more.")
83 (license gpl2+)))
84
85 (define-public libmhash
86 (package
87 (name "libmhash")
88 (version "0.9.9.9")
89 (source
90 (origin
91 (method url-fetch)
92 (uri (string-append "mirror://sourceforge/mhash/mhash/" version
93 "/mhash-" version ".tar.bz2"))
94 (sha256
95 (base32
96 "1w7yiljan8gf1ibiypi6hm3r363imm3sxl1j8hapjdq3m591qljn"))
97 (patches (search-patches "mhash-keygen-test-segfault.patch"
98 "libmhash-hmac-fix-uaf.patch"))))
99 (build-system gnu-build-system)
100 (native-inputs
101 `(("perl" ,perl))) ;for tests
102 (home-page "http://mhash.sourceforge.net/")
103 (synopsis "Thread-safe hash library")
104 (description
105 "Mhash is a thread-safe hash library, implemented in C, and provides a
106 uniform interface to a large number of hash algorithms. These algorithms can
107 be used to compute checksums, message digests, and other signatures. The HMAC
108 support implements the basics for message authentication, following RFC 2104.
109
110 Algorithms currently supplied are:
111
112 CRC-32, CRC-32B, ALDER-32, MD-2, MD-4, MD-5, RIPEMD-128, RIPEMD-160,
113 RIPEMD-256, RIPEMD-320, SHA-1, SHA-224, SHA-256, SHA-384, SHA-512, HAVAL-128,
114 HAVAL-160, HAVAL-192, HAVAL-256, TIGER, TIGER-128, TIGER-160, GOST, WHIRLPOOL,
115 SNEFRU-128, SNEFRU-256.")
116 (license gpl2+)))