gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / lighting.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016 John J. Foerch <jjfoerch@earthlink.net>
3 ;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages lighting)
21 #:use-module (guix build-system gnu)
22 #:use-module (guix git-download)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (gnu packages)
26 #:use-module (gnu packages autotools)
27 #:use-module (gnu packages bison)
28 #:use-module (gnu packages check)
29 #:use-module (gnu packages compression)
30 #:use-module (gnu packages gnunet)
31 #:use-module (gnu packages flex)
32 #:use-module (gnu packages libftdi)
33 #:use-module (gnu packages libusb)
34 #:use-module (gnu packages linux)
35 #:use-module (gnu packages pkg-config)
36 #:use-module (gnu packages protobuf))
37
38 (define-public ola
39 ;; Use a commit that allows building with libmicrohttpd 0.9.71.
40 ;; https://github.com/OpenLightingProject/ola/pull/1651
41 (let ((commit "5d882936436240b312b3836afd199587beaca840")
42 (revision "0"))
43 (package
44 (name "ola")
45 (version (git-version "0.10.7" revision commit))
46 (source
47 (origin
48 (method git-fetch)
49 (uri (git-reference
50 (url "https://github.com/OpenLightingProject/ola")
51 (commit commit)))
52 (sha256
53 (base32 "1bhl3gvmvmnyrygfj13cibf2xirm285m8abjkaxq22hrqbsvab2m"))
54 (file-name (git-file-name name version))))
55 (build-system gnu-build-system)
56 (native-inputs
57 `(("bison" ,bison)
58 ("cppunit" ,cppunit)
59 ("flex" ,flex)
60 ("pkg-config" ,pkg-config)
61
62 ;; For git repository bootstrapping.
63 ("autoconf" ,autoconf)
64 ("automake" ,automake)
65 ("libtool" ,libtool)))
66 (inputs
67 `(("libftdi" ,libftdi)
68 ("libmicrohttpd" ,libmicrohttpd)
69 ("libusb" ,libusb)
70 ("libuuid" ,util-linux "lib")
71 ("zlib" ,zlib)))
72 (propagated-inputs
73 `(("protobuf" ,protobuf))) ; for pkg-config --libs libola
74 (arguments
75 `( ;; G++ >= 4.8 macro expansion tracking requires lots of memory, causing
76 ;; build to fail on low memory systems. We disable that with the
77 ;; following configure flags.
78 #:configure-flags (list "CXXFLAGS=-ftrack-macro-expansion=0")))
79 (synopsis "Framework for controlling entertainment lighting equipment")
80 (description "The Open Lighting Architecture is a framework for lighting
81 control information. It supports a range of protocols and over a dozen USB
82 devices. It can run as a standalone service, which is useful for converting
83 signals between protocols, or alternatively using the OLA API, it can be used
84 as the backend for lighting control software. OLA runs on many different
85 platforms including ARM, which makes it a perfect fit for low cost Ethernet to
86 DMX gateways.")
87 (home-page "https://www.openlighting.org/ola")
88 (license license:lgpl2.1+))))