gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / libunwind.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages libunwind)
22 #:use-module (guix packages)
23 #:use-module (gnu packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (guix licenses))
27
28 (define-public libunwind
29 (package
30 (name "libunwind")
31 (version "1.5.0")
32 (source (origin
33 (method url-fetch)
34 (uri (string-append "mirror://savannah/libunwind/libunwind-"
35 version ".tar.gz"))
36 (sha256
37 (base32
38 "05qhzcg1xag3l5m3c805np6k342gc0f3g087b7g16jidv59pccwh"))))
39 (build-system gnu-build-system)
40 (arguments
41 ;; FIXME: As of glibc 2.25, we get 1 out of 34 test failures (2 are
42 ;; expected to fail).
43 ;; Report them upstream.
44 '(#:tests? #f))
45 (home-page "https://www.nongnu.org/libunwind")
46 (synopsis "Determining the call chain of a program")
47 (description
48 "The primary goal of this project is to define a portable and efficient C
49 programming interface (API) to determine the call-chain of a program. The API
50 additionally provides the means to manipulate the preserved (callee-saved)
51 state of each call-frame and to resume execution at any point in the
52 call-chain (non-local goto). The API supports both local (same-process) and
53 remote (across-process) operation. As such, the API is useful in a number of
54 applications.")
55 (license x11)))