gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / libedit.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
3 ;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
4 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;; Copyright © 2019 Gábor Boskovits <boskovits@gmail.com>
6 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages libedit)
24 #:use-module (guix licenses)
25 #:use-module (guix packages)
26 #:use-module (guix download)
27 #:use-module (guix build-system gnu)
28 #:use-module (gnu packages ncurses))
29
30 (define-public libedit
31 (package
32 (name "libedit")
33 (version "20191231-3.1")
34 (source
35 (origin
36 (method url-fetch)
37 (uri (string-append "https://thrysoee.dk/editline"
38 "/libedit-" version ".tar.gz"))
39 (sha256
40 (base32 "0wch48nml28jj6ild889745dsg2agm7mpvrmbl1gi98nw6vjrf6v"))))
41 (build-system gnu-build-system)
42 (inputs
43 `(("ncurses" ,ncurses)))
44 (home-page "https://thrysoee.dk/editline/")
45 (synopsis "NetBSD Editline library")
46 (description
47 "This is an autotool- and libtoolized port of the NetBSD Editline
48 library (libedit). This Berkeley-style licensed command line editor library
49 provides generic line editing, history, and tokenization functions, similar to
50 those found in GNU Readline.")
51 (license bsd-3)))
52
53 (define-public editline
54 (package
55 (name "editline")
56 (version "1.17.1")
57 (source
58 (origin
59 (method url-fetch)
60 (uri (string-append
61 "https://ftp.troglobit.com/editline/editline-" version ".tar.xz"))
62 (sha256
63 (base32 "03pw3z6pz590v8xfnjx0yynnzij2sb9xwjbvqvdzsid56crkn8nz"))))
64 (build-system gnu-build-system)
65 (home-page "https://troglobit.com/projects/editline/")
66 (synopsis "Line editing library")
67 (description
68 "@code{editline} is a small line editing library. It can be linked into almost
69 any program to provide command line editing and history functions. It is call
70 compatible with the GNU Readline library, but at a fraction of the size,
71 and as a result fewer features.")
72 (license bsd-4)))