gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / lesstif.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;;
4 ;;; This file is part of GNU Guix.
5 ;;;
6 ;;; GNU Guix is free software; you can redistribute it and/or modify it
7 ;;; under the terms of the GNU General Public License as published by
8 ;;; the Free Software Foundation; either version 3 of the License, or (at
9 ;;; your option) any later version.
10 ;;;
11 ;;; GNU Guix is distributed in the hope that it will be useful, but
12 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
13 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
14 ;;; GNU General Public License for more details.
15 ;;;
16 ;;; You should have received a copy of the GNU General Public License
17 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
18
19 (define-module (gnu packages lesstif)
20 #:use-module ((guix licenses) #:prefix license:)
21 #:use-module (guix packages)
22 #:use-module (guix download)
23 #:use-module (guix build-system gnu)
24 #:use-module (gnu packages xorg))
25
26
27 (define-public lesstif
28 (package
29 (name "lesstif")
30 (version "0.95.2")
31 (source
32 (origin
33 (method url-fetch)
34 (uri (string-append
35 "mirror://sourceforge/lesstif/lesstif/" version
36 "/lesstif-" version ".tar.bz2"))
37 (sha256
38 (base32
39 "1qzpxjjf7ri1jzv71mvq5m9g8hfaj5yzwp30rwxlm6n2b24a6jpb"))))
40 (build-system gnu-build-system)
41 (propagated-inputs
42 `(("printproto" ,printproto)))
43 (inputs
44 `(("libxext" ,libxext)
45 ("libxt" ,libxt)))
46 (home-page "http://lesstif.sourceforge.net/")
47 (synopsis "Clone of the Motif toolkit for the X window system")
48 (description "Clone of the Motif toolkit for the X window system.")
49 (license license:gpl2+))) ; some files are lgpl2.1+ or x11