gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / kde-systemtools.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
3 ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages kde-systemtools)
21 #:use-module (guix build-system qt)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (guix utils)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages compression)
28 #:use-module (gnu packages kde)
29 #:use-module (gnu packages kde-frameworks)
30 #:use-module (gnu packages linux)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages qt)
33 #:use-module (gnu packages ruby)
34 #:use-module (gnu packages search)
35 #:use-module (gnu packages vnc)
36 #:use-module (gnu packages xml)
37 #:use-module (gnu packages xorg))
38
39 (define-public dolphin
40 (package
41 (name "dolphin")
42 (version "20.04.1")
43 (source
44 (origin
45 (method url-fetch)
46 (uri (string-append "mirror://kde/stable/release-service/" version
47 "/src/dolphin-" version ".tar.xz"))
48 (sha256
49 (base32 "0xr5s0s40i2bsfjfapvpa7dxh9s4604cxirg97xcaacd6fdvhpds"))))
50 (build-system qt-build-system)
51 (native-inputs
52 `(("extra-cmake-modules" ,extra-cmake-modules)
53 ("kdoctools" ,kdoctools)
54 ("ruby" ,ruby)
55 ("ruby-test-unit" ,ruby-test-unit)))
56 (inputs
57 `(("baloo" ,baloo)
58 ("baloo-widgets" ,baloo-widgets)
59 ("kactivities" ,kactivities)
60 ("kbookmarks" ,kbookmarks)
61 ("kcmutils" ,kcmutils)
62 ("kcompletion" ,kcompletion)
63 ("kconfig" ,kconfig)
64 ("kcoreaddons" ,kcoreaddons)
65 ("kcrash" ,kcrash)
66 ("kdbusaddons" ,kdbusaddons)
67 ("ki18n" ,ki18n)
68 ("kiconthemes" ,kiconthemes)
69 ("kinit" ,kinit)
70 ("kio" ,kio)
71 ("knewstuff" ,knewstuff)
72 ("knotifications" ,knotifications)
73 ("kparts" ,kparts)
74 ("ktextwidgets" ,ktextwidgets)
75 ("kwindowsystem" ,kwindowsystem)
76 ("oxygen-icons" ,oxygen-icons) ;; default icon set
77 ("phonon" ,phonon)
78 ("qtbase" ,qtbase)
79 ("solid" ,solid)))
80 (arguments
81 `(#:tests? #f)) ;; TODO: 4/15 tests fail even with offscreen
82 (home-page "https://kde.org/applications/system/org.kde.dolphin")
83 (synopsis "File manager for KDE")
84 (description "Dolphin is a file manager for KDE focusing on usability.
85 The main features of Dolphin are:
86 @itemize
87 @item Navigation bar for URLs, which navigates quickly
88 through the file hierarchy.
89 @item View properties are remembered for each folder.
90 @item Split of views is supported.
91 @item Network transparency.
92 @item Undo/redo functionality.
93 @item Renaming of a variable number of selected items in one step.
94 @end itemize")
95 (license ;; GPL for programs, FDL for documentation
96 (list license:gpl2+ license:fdl1.2+))))
97
98 (define-public dolphin-plugins
99 (package
100 (name "dolphin-plugins")
101 (version "20.04.1")
102 (source
103 (origin
104 (method url-fetch)
105 (uri (string-append "mirror://kde/stable/release-service/" version
106 "/src/dolphin-plugins-" version ".tar.xz"))
107 (sha256
108 (base32 "12g44s6g7ma6avp15l45l42qyzbglswvahm2wji79zdls5vjnz7r"))))
109 (build-system qt-build-system)
110 (native-inputs
111 `(("extra-cmake-modules" ,extra-cmake-modules)))
112 (inputs
113 `(("dolphin" ,dolphin)
114 ("ki18n" ,ki18n)
115 ("kio" ,kio)
116 ("ktexteditor" ,ktexteditor)
117 ("kxmlgui" ,kxmlgui)
118 ("oxygen-icons" ,oxygen-icons) ;; default icon set
119 ("qtbase" ,qtbase)))
120 (home-page "http://www.kde.org/")
121 (synopsis "VCS-Plugins for Dolphin")
122 (description "This package contains plugins that offer integration in
123 Dolphin with the version control systems: Bzr, Git, Mercurial, Subversion.")
124 (license license:gpl2+)))
125
126 (define-public khelpcenter
127 (package
128 (name "khelpcenter")
129 (version "20.04.1")
130 (source
131 (origin
132 (method url-fetch)
133 (uri (string-append "mirror://kde/stable/release-service/" version
134 "/src/khelpcenter-" version ".tar.xz"))
135 (sha256
136 (base32 "0wxzjragvjcfc7c4qja8wzpshhaywficj7f7wkmppzybcsxwn9qb"))))
137 (build-system qt-build-system)
138 (native-inputs
139 `(("extra-cmake-modules" ,extra-cmake-modules)
140 ("kdoctools" ,kdoctools)))
141 (inputs
142 `(("grantlee" ,grantlee)
143 ("karchive" ,karchive)
144 ("kbookmarks" ,kbookmarks)
145 ("kcodecs" ,kcodecs)
146 ("kconfig" ,kconfig)
147 ("kcoreaddons" ,kcoreaddons)
148 ("kdbusaddons" ,kdbusaddons)
149 ("khtml" ,khtml)
150 ("ki18n" ,ki18n)
151 ("kinit" ,kinit)
152 ("kio" ,kio)
153 ("kjs" ,kjs)
154 ("kparts" ,kparts)
155 ("kservice" ,kservice)
156 ("kwindowsystem" ,kwindowsystem)
157 ("libxml2" ,libxml2)
158 ("oxygen-icons" ,oxygen-icons) ;; default icon set
159 ("qtbase" ,qtbase)
160 ("xapian" ,xapian)))
161 (arguments
162 `(#:tests? #f)) ;; 1/1 test fails
163 (home-page "https://kde.org/applications/system/org.kde.Help")
164 (synopsis "KDE documentation viewer")
165 (description "KHelpCenter uses meta data files which describe the
166 documentation available in the system. Each document is represented by a meta
167 data file and shown as an entry in the KHelpCenter navigation tree view. The
168 meta data contains information about title and short description of the
169 document, the location of the document and some more information like how to
170 search the document and translations of title and description. Document
171 hierarchy is represented as hierarchy of the meta data files. Directories are
172 also described by a meta data file which contains the same information as a
173 document meta data file.")
174 (license license:gpl2+)))
175
176 (define-public konsole
177 (package
178 (name "konsole")
179 (version "20.04.1")
180 (source
181 (origin
182 (method url-fetch)
183 (uri (string-append "mirror://kde/stable/release-service/" version
184 "/src/konsole-" version ".tar.xz"))
185 (sha256
186 (base32 "0ckr7bjkyaw0gr5kx569jfnhkhwmlk4lqk41ng61qwxlb4bsdbdm"))))
187 (build-system qt-build-system)
188 (native-inputs
189 `(("extra-cmake-modules" ,extra-cmake-modules)
190 ("kdoctools" ,kdoctools)))
191 (inputs
192 `(("kbookmarks" ,kbookmarks)
193 ("kcompletion" ,kcompletion)
194 ("kconfig" ,kconfig)
195 ("kconfigwidgets" ,kconfigwidgets)
196 ("kcoreaddons" ,kcoreaddons)
197 ("kcrash" ,kcrash)
198 ("kdbusaddons" ,kdbusaddons)
199 ("kguiaddons" ,kguiaddons)
200 ("ki18n" ,ki18n)
201 ("kiconthemes" ,kiconthemes)
202 ("kinit" ,kinit)
203 ("kio" ,kio)
204 ("knewstuff" ,knewstuff)
205 ("kglobalaccel" ,kglobalaccel)
206 ("knotifications" ,knotifications)
207 ("knotifyconfig" ,knotifyconfig)
208 ("kparts" ,kparts)
209 ("kpty" ,kpty)
210 ("kservice" ,kservice)
211 ("ktextwidgets" ,ktextwidgets)
212 ("kwidgetsaddons" ,kwidgetsaddons)
213 ("kwindowsystem" ,kwindowsystem)
214 ("kxmlgui" ,kxmlgui)
215 ("oxygen-icons" ,oxygen-icons) ;; default icon set
216 ("qtbase" ,qtbase)
217 ("qtscript" ,qtscript)))
218 (arguments
219 `(#:tests? #f)) ;; TODO: 2/15 tests fail even with HOME, offscreen, SHELL, debus
220 (home-page "http://www.kde.org/")
221 (synopsis "Terminal emulator similar for KDE")
222 (description "Konsole is a terminal emulator, similar to xterm, built on
223 the KDE Platform. It can contain multiple terminal sessions inside one window
224 using detachable tabs. Konsole supports customizable schemes, saved sessions,
225 output monitoring and more.
226
227 This package is part of the KDE base applications module.")
228 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
229 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
230
231 (define-public krfb
232 (package
233 (name "krfb")
234 (version "20.04.1")
235 (source
236 (origin
237 (method url-fetch)
238 (uri (string-append "mirror://kde/stable/release-service/" version
239 "/src/krfb-" version ".tar.xz"))
240 (sha256
241 (base32 "092ijn88jpmgk2zwz37vzf35jisl234mc3krc9jl7bd955akx51k"))))
242 (build-system qt-build-system)
243 (native-inputs
244 `(("extra-cmake-modules" ,extra-cmake-modules)
245 ("pkg-config" ,pkg-config)
246 ("kdoctools" ,kdoctools)))
247 (inputs
248 `(("kcompletion" ,kcompletion)
249 ("kconfig" ,kconfig)
250 ("kcoreaddons" ,kcoreaddons)
251 ("kcrash" ,kcrash)
252 ("kdbusaddons" ,kdbusaddons)
253 ("kdnssd" ,kdnssd)
254 ("ki18n" ,ki18n)
255 ("knotifications" ,knotifications)
256 ("kwallet" ,kwallet)
257 ("kwidgetsaddons" ,kwidgetsaddons)
258 ("kwindowsystem" ,kwindowsystem)
259 ("kxmlgui" ,kxmlgui)
260 ("libvnc" ,libvnc)
261 ("libxcb" ,libxcb)
262 ("libxtst" ,libxtst)
263 ("oxygen-icons" ,oxygen-icons) ;; default icon set
264 ("pipewire" ,pipewire)
265 ("qtbase" ,qtbase)
266 ("qtx11extras" ,qtx11extras)
267 ("xcb-util-image" ,xcb-util-image)
268 ("zlib" ,zlib)))
269 (home-page "https://kde.org/applications/internet/org.kde.krfb")
270 (synopsis "Desktop Sharing utility")
271 (description "KDE Desktop Sharing is a server application that allows you
272 to share your current session with a user on another machine. The desktop
273 session can be viewed or even controlled remotely by any VNC or RFB client,
274 such as the KDE Remote Desktop Connection client.
275
276 KDE Desktop Sharing can restrict access to only users who are explicitly
277 invited, and will ask for confirmation when a user attempts to connect.
278
279 This package is part of the KDE networking module.")
280 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
281 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
282
283 (define-public ksystemlog
284 (package
285 (name "ksystemlog")
286 (version "20.04.1")
287 (source
288 (origin
289 (method url-fetch)
290 (uri (string-append "mirror://kde/stable/release-service/" version
291 "/src/ksystemlog-" version ".tar.xz"))
292 (sha256
293 (base32 "1826h89ynvlxdwzyqil2d79cvynglww6fax7qp41wxasgarxhsni"))))
294 (build-system qt-build-system)
295 (native-inputs
296 `(("extra-cmake-modules" ,extra-cmake-modules)
297 ("kdoctools" ,kdoctools)))
298 (inputs
299 ;; Not including Journald since this is not used in guix
300 `(("karchive" ,karchive)
301 ("kcompletion" ,kcompletion)
302 ("kconfig" ,kconfig)
303 ("kcoreaddons" ,kcoreaddons)
304 ("ki18n" ,ki18n)
305 ("kiconthemes" ,kiconthemes)
306 ("kio" ,kio)
307 ("kitemviews" ,kitemviews)
308 ("ktextwidgets" ,ktextwidgets)
309 ("kwidgetsaddons" ,kwidgetsaddons)
310 ("kxmlgui" ,kxmlgui)
311 ("oxygen-icons" ,oxygen-icons) ;; default icon set
312 ("qtbase" ,qtbase)))
313 (home-page "https://kde.org/applications/system/org.kde.ksystemlog")
314 (synopsis "System log viewer")
315 (description "This program is developed for being used by beginner users,
316 which don't know how to find information about their Linux system, and how the
317 log files are in their computer. But it is also designed for advanced users,
318 who want to quickly see problems occurring on their server.
319
320 This package is part of the KDE administration module.")
321 (license license:gpl2+)))
322
323 (define-public yakuake
324 (package
325 (name "yakuake")
326 (version "20.12.1")
327 (source (origin
328 (method url-fetch)
329 (uri (string-append "mirror://kde/stable/release-service/" version
330 "/src/yakuake-" version ".tar.xz"))
331 (sha256
332 (base32
333 "02pal9xx1wbpw7dimvs2aw1xnyjqlvbjlybkkfhf8x7c6m1r63aa"))))
334 (build-system qt-build-system)
335 (native-inputs
336 `(("extra-cmake-modules" ,extra-cmake-modules)))
337 (inputs
338 `(("breeze-icons" ,breeze-icons)
339 ("karchive" ,karchive)
340 ("kconfig" ,kconfig)
341 ("kcoreaddons" ,kcoreaddons)
342 ("kcrash" ,kcrash)
343 ("kdbusaddons" ,kdbusaddons)
344 ("kglobalaccel" ,kglobalaccel)
345 ("ki18n" ,ki18n)
346 ("kiconthemes" ,kiconthemes)
347 ("kio" ,kio)
348 ("knewstuff" ,knewstuff)
349 ("knotifications" ,knotifications)
350 ("knotifyconfig" ,knotifyconfig)
351 ("konsole" ,konsole)
352 ("kparts" ,kparts)
353 ("kwayland" ,kwayland)
354 ("kwidgetsaddons" ,kwidgetsaddons)
355 ("kwindowsystem" ,kwindowsystem)
356 ("qtbase" ,qtbase)
357 ("qtsvg" ,qtsvg)
358 ("qtx11extras" ,qtx11extras)))
359 (home-page "https://www.kde.org/applications/system/yakuake/")
360 (synopsis "Quad-style terminal emulator for KDE")
361 (description "Yakuake is a drop-down terminal emulator based on KDE Konsole
362 technology. Features include:
363 @itemize
364 @item Smoothly rolls down from the top of your screen
365 @item Tabbed interface
366 @item Configurable dimensions and animation speed
367 @item Skinnable
368 @item Sophisticated D-Bus interface
369 @end itemize")
370 (license license:gpl2+)))