gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / kde-internet.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
3 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages kde-internet)
21 #:use-module (guix build-system qt)
22 #:use-module (guix download)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (guix utils)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages boost)
28 #:use-module (gnu packages compression)
29 #:use-module (gnu packages glib)
30 #:use-module (gnu packages gnupg)
31 #:use-module (gnu packages image)
32 #:use-module (gnu packages kde)
33 #:use-module (gnu packages kde-frameworks)
34 #:use-module (gnu packages kde-pim)
35 #:use-module (gnu packages libidn)
36 #:use-module (gnu packages linux)
37 #:use-module (gnu packages messaging)
38 #:use-module (gnu packages mp3)
39 #:use-module (gnu packages multiprecision)
40 #:use-module (gnu packages pkg-config)
41 #:use-module (gnu packages qt)
42 #:use-module (gnu packages rdesktop)
43 #:use-module (gnu packages serialization)
44 #:use-module (gnu packages ssh)
45 #:use-module (gnu packages telephony)
46 #:use-module (gnu packages linphone)
47 #:use-module (gnu packages tls)
48 #:use-module (gnu packages video)
49 #:use-module (gnu packages web)
50 #:use-module (gnu packages xiph)
51 #:use-module (gnu packages xml))
52
53 (define-public choqok
54 (package
55 (name "choqok")
56 (version "1.7.0")
57 (source
58 (origin
59 (method url-fetch)
60 (uri (string-append "mirror://kde/stable/choqok/"
61 (version-major+minor version)
62 "/src/choqok-" version ".tar.xz"))
63 (sha256
64 (base32 "0zm4nkpmvd181xlkis7ydzx54p3vn0zgpdzgh54f1hsjy6ahsq16"))))
65 (build-system qt-build-system)
66 (native-inputs
67 `(("extra-cmake-modules" ,extra-cmake-modules)
68 ("kdoctools" ,kdoctools)
69 ("pkg-config" ,pkg-config)))
70 (inputs
71 `(("attica" ,attica)
72 ("kcmutils" ,kcmutils)
73 ("kconfigwidgets" ,kconfigwidgets)
74 ("kcoreaddons" ,kcoreaddons)
75 ("kdewebkit" ,kdewebkit)
76 ("kemoticons" ,kemoticons)
77 ("kglobalaccel" ,kglobalaccel)
78 ("kguiaddons" ,kguiaddons)
79 ("ki18n" ,ki18n)
80 ("kio" ,kio)
81 ("knotifications" ,knotifications)
82 ("knotifyconfig" ,knotifyconfig)
83 ("kparts" ,kparts)
84 ("ktextwidgets" ,ktextwidgets)
85 ("kwallet" ,kwallet)
86 ("kwidgetsaddons" ,kwidgetsaddons)
87 ("kxmlgui" ,kxmlgui)
88 ;; TODO: telepathy
89 ("oxygen-icons" ,oxygen-icons) ; default icon set
90 ("purpose" ,purpose)
91 ("qca" ,qca)
92 ("qoauth" ,qoauth)
93 ("qtbase" ,qtbase)
94 ("qtnetworkauth" ,qtnetworkauth)
95 ("qtwebkit" ,qtwebkit)
96 ("sonnet" ,sonnet)))
97 (home-page "https://kde.org/applications/internet/org.kde.choqok")
98 (synopsis "Micro-Blogging Client")
99 (description "Choqok is a fast, efficient and simple to use micro-blogging
100 client for KDE. It currently supports the twitter.com and identi.ca
101 microblogging services.
102
103 Other notable features include:
104 @itemize
105 @item Support for user + friends time-lines.
106 @item Support for @@Reply time-lines.
107 @item Support for sending and receiving direct messages.
108 @item Twitpic.com integration.
109 @item The ability to use multiple accounts simultaneously.
110 @item Support for search APIs for all services.
111 @item KWallet integration.
112 @item Support for automatic shortening urls with more than 30 characters.
113 @item Support for configuring status lists appearance.
114 @end itemize")
115 (license license:gpl3+)))
116
117 (define-public kget
118 (package
119 (name "kget")
120 (version "20.04.1")
121 (source
122 (origin
123 (method url-fetch)
124 (uri (string-append "mirror://kde/stable/release-service/" version
125 "/src/kget-" version ".tar.xz"))
126 (sha256
127 (base32 "1swx58wcig8zq8ibhczhcw7l8mqjm7pq8zca9gmny9kda5q04f5m"))))
128 (build-system qt-build-system)
129 (native-inputs
130 `(("extra-cmake-modules" ,extra-cmake-modules)
131 ("pkg-config" ,pkg-config)))
132 (inputs
133 `(("boost" ,boost)
134 ("gmp" ,gmp)
135 ("gpgme" ,gpgme)
136 ("kcmutils" ,kcmutils)
137 ("kcompletion" ,kcompletion)
138 ("kconfig" ,kconfig)
139 ("kconfigwidgets" ,kconfigwidgets)
140 ("kcoreaddons" ,kcoreaddons)
141 ("kcrash" ,kcrash)
142 ("kdbusaddons" ,kdbusaddons)
143 ("kdelibs4support" ,kdelibs4support) ;; KLocale
144 ("kdoctools" ,kdoctools)
145 ("ki18n" ,ki18n)
146 ("kiconthemes" ,kiconthemes)
147 ("kio" ,kio)
148 ("kitemviews" ,kitemviews)
149 ("knotifications" ,knotifications)
150 ("knotifyconfig" ,knotifyconfig)
151 ("kparts" ,kparts)
152 ("kservice" ,kservice)
153 ("ktextwidgets" ,ktextwidgets)
154 ("kwallet" ,kwallet)
155 ("kwidgetsaddons" ,kwidgetsaddons)
156 ("kwindowsystem" ,kwindowsystem)
157 ("kxmlgui" ,kxmlgui)
158 ("libgcrypt" ,libgcrypt)
159 ("libktorrent" ,libktorrent)
160 ;; TODO: libmms
161 ;; TODO: LibKWorkspace - plasma-workspace?
162 ("oxygen-icons" ,oxygen-icons) ; default icon set
163 ("qca" ,qca)
164 ("qgpgme" ,qgpgme)
165 ("qtbase" ,qtbase)
166 ))
167 (home-page "http://www.kde.org/")
168 (synopsis "Versatile and user-friendly download manager")
169 (description "KGet is an advanced download manager with support for
170 Metalink and Bittorrent. Downloads are added to the list, where they can be
171 paused, queued, or scheduled for later. KGet supports download via FTP anf
172 HTTP(S) as well as pausing downloads.
173
174 This package is part of the KDE networking module.")
175 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
176 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
177
178 (define-public konversation
179 (package
180 (name "konversation")
181 (version "1.7.7")
182 (source
183 (origin
184 (method url-fetch)
185 (uri (string-append "mirror://kde/stable/konversation/" version
186 "/src/konversation-" version ".tar.xz"))
187 (sha256
188 (base32 "19qqq9s8k0cl71ib33xn07f26j5ji2g4336jk65im6452cf1dv27"))))
189 (build-system qt-build-system)
190 (native-inputs
191 `(("extra-cmake-modules" ,extra-cmake-modules)
192 ("kdoctools" ,kdoctools)))
193 (inputs
194 `(("karchive" ,karchive)
195 ("kbookmarks" ,kbookmarks)
196 ("kconfig" ,kconfig)
197 ("kconfigwidgets" ,kconfigwidgets)
198 ("kcoreaddons" ,kcoreaddons)
199 ("kcrash" ,kcrash)
200 ("kdbusaddons" ,kdbusaddons)
201 ("kemoticons" ,kemoticons)
202 ("kglobalaccel" ,kglobalaccel)
203 ("ki18n" ,ki18n)
204 ("kiconthemes" ,kiconthemes)
205 ("kidletime" ,kidletime)
206 ("kio" ,kio)
207 ("kitemviews" ,kitemviews)
208 ("knotifications" ,knotifications)
209 ("knotifyconfig" ,knotifyconfig)
210 ("kparts" ,kparts)
211 ("kwallet" ,kwallet)
212 ("kwidgetsaddons" ,kwidgetsaddons)
213 ("kwindowsystem" ,kwindowsystem)
214 ("oxygen-icons" ,oxygen-icons) ; default icon set
215 ("phonon" ,phonon)
216 ("qtbase" ,qtbase)
217 ("qca" ,qca)
218 ("solid" ,solid)
219 ("sonnet" ,sonnet)))
220 (home-page "https://kde.org/applications/internet/org.kde.konversations")
221 (synopsis "Graphical Internet Relay Chat (IRC) client for KDE")
222 (description "Konversation is a graphical Internet Relay Chat client (IRC)
223 with KDE support.
224
225 Features are:
226 @itemize
227 @item Standard IRC features
228 @item SSL server support
229 @item Bookmarking support
230 @item Easy to use graphical user interface
231 @item Multiple servers and channels in one single window
232 @item DCC file transfer with resume support
233 @item Multiple identities for different servers
234 @item Text decorations and colors
235 @item Pattern-based message highlighting and OnScreen Display notifications
236 @item Automatic UTF-8 detection
237 @item Per channel encoding support
238 @item Theme support for nick icons
239 @item Highly configurable
240 @item Multi-language scripting support (with DCOP)
241 @item Customizable command aliases
242 @item NickServ-aware log-on (for registered nicknames)
243 @item Smart logging
244 @item Traditional or enhanced-shell-style nick completion
245 @end itemize")
246 (license ;; GPL for programs, FDL for documentation
247 (list license:gpl2+ license:fdl1.2+))))
248
249 (define-public kopete
250 (package
251 (name "kopete")
252 (version "20.04.1")
253 (source
254 (origin
255 (method url-fetch)
256 (uri (string-append "mirror://kde/stable/release-service/" version
257 "/src/kopete-" version ".tar.xz"))
258 (sha256
259 (base32 "149gi9hkyl825kf046iqkam3gkzfwdc2sihbf8gs6njachzvb81y"))))
260 (build-system qt-build-system)
261 (native-inputs
262 `(("extra-cmake-modules" ,extra-cmake-modules)
263 ("kdoctools" ,kdoctools)
264 ("pkg-config" ,pkg-config)))
265 (inputs
266 `(("alsa-lib" ,alsa-lib)
267 ("boost" ,boost)
268 ("expat" ,expat)
269 ("glib" ,glib)
270 ("gpgme" ,gpgme)
271 ("jsoncpp" ,jsoncpp)
272 ("kcmutils" ,kcmutils)
273 ("kconfig" ,kconfig)
274 ("kcontacts" ,kcontacts)
275 ("kcoreaddons" ,kcoreaddons)
276 ("kcrash" ,kcrash)
277 ("kdbusaddons" ,kdbusaddons)
278 ("kdelibs4support" ,kdelibs4support)
279 ("kdnssd" ,kdnssd)
280 ("kemoticons" ,kemoticons)
281 ("khtml" ,khtml)
282 ("ki18n" ,ki18n)
283 ("kidentitymanagement" ,kidentitymanagement)
284 ("kjs" ,kjs)
285 ;; TODO? kleopatra (additionally to libkleo)
286 ("knotifyconfig" ,knotifyconfig)
287 ("kparts" ,kparts)
288 ("kpimtextedit" ,kpimtextedit)
289 ("ktexteditor" ,ktexteditor)
290 ("kwallet" ,kwallet)
291 ;; TODO: Libgadu
292 ("libidn" ,libidn)
293 ("libkleo" ,libkleo)
294 ;; TODO: LibMeanwhile
295 ("libotr" ,libotr)
296 ("libsrtp" ,libsrtp)
297 ("libxml2" ,libxml2)
298 ("libxstl" ,libxslt)
299 ;; TODO: Mediastreamer
300 ("openssl" ,openssl)
301 ("ortp" ,ortp)
302 ("phonon" ,phonon)
303 ("qca" ,qca)
304 ("qgpgme" ,qgpgme)
305 ("qtbase" ,qtbase)
306 ("speex" ,speex)
307 ("v4l-utils" ,v4l-utils)
308 ;; TODO: Xmms
309 ("zlib" ,zlib)))
310 ;; TODO: enable video support
311 (home-page "https://kde.org/applications/internet/org.kde.kopete")
312 (synopsis "Instant messaging and chat application")
313 (description "Kopete is an instant messenger supporting Jabber/XMPP ,AIM,
314 ICQ, Gadu-Gadu, Novell GroupWise Messenger, and more. It is designed to be a
315 flexible and extensible multi-protocol system suitable for personal and
316 enterprise use.
317
318 The goal of Kopete is to provide users with a single easy-to-use way to access
319 all of their instant messaging systems. The interface puts people first, and
320 is integrated with the system address book to let you access your contacts
321 from other KDE applications.
322
323 This package is part of the KDE networking module.")
324 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
325 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
326
327 (define-public krdc
328 (package
329 (name "krdc")
330 (version "20.04.1")
331 (source
332 (origin
333 (method url-fetch)
334 (uri (string-append "mirror://kde/stable/release-service/" version
335 "/src/krdc-" version ".tar.xz"))
336 (sha256
337 (base32 "1hp23k3nsrcxpv2qiynjgm71zn3l6ds00cpd4frc68szgiblrw9r"))))
338 (build-system qt-build-system)
339 (native-inputs
340 `(("extra-cmake-modules" ,extra-cmake-modules)
341 ("kdoctools" ,kdoctools)))
342 (inputs
343 `(("kbookmarks" ,kbookmarks)
344 ("freerdp" ,freerdp)
345 ("kcmutils" ,kcmutils)
346 ("kcompletion" ,kcompletion)
347 ("kconfig" ,kconfig)
348 ("kdnssd" ,kdnssd)
349 ("ki18n" ,ki18n)
350 ("kiconthemes" ,kiconthemes)
351 ("knotifications" ,knotifications)
352 ("knotifyconfig" ,knotifyconfig)
353 ("knotifyconfig" ,knotifyconfig)
354 ("kwallet" ,kwallet)
355 ("kwidgetsaddons" ,kwidgetsaddons)
356 ("kwindowsystem" ,kwindowsystem)
357 ("kxmlgui" ,kxmlgui)
358 ("libssh2" ,libssh)
359 ;; TODO: libvnc{server,client} - is not tigervnc-{server,client}
360 ("oxygen-icons" ,oxygen-icons) ; default icon set
361 ("qtbase" ,qtbase)))
362 (home-page "https://kde.org/applications/internet/org.kde.krdc")
363 (synopsis "Remote desktop client")
364 (description "KRDC is a client application that allows you to view or even
365 control the desktop session on another machine that is running a compatible
366 server. VNC and RDP are supported.
367
368 This package is part of the KDE networking module.")
369 (license ;; GPL for programs, LGPL for libraries, FDL for documentation
370 (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
371
372 (define-public ktorrent
373 (package
374 (name "ktorrent")
375 (version "5.1.2")
376 (source
377 (origin
378 (method url-fetch)
379 (uri (string-append "mirror://kde/stable/ktorrent/" version
380 "/ktorrent-" version ".tar.xz"))
381 (sha256
382 (base32 "0kwd0npxfg4mdh7f3xadd2zjlqalpb1jxk61505qpcgcssijf534"))))
383 (build-system qt-build-system)
384 (native-inputs
385 `(("extra-cmake-modules" ,extra-cmake-modules)
386 ("kdoctools" ,kdoctools)))
387 (inputs
388 `(("boost" ,boost)
389 ("gmp" ,gmp)
390 ("karchive" ,karchive)
391 ("kcmutils" ,kcmutils)
392 ("kconfig" ,kconfig)
393 ("kconfigwidgets" ,kconfigwidgets)
394 ("kcoreaddons" ,kcoreaddons)
395 ("kcrash" ,kcrash)
396 ("kdbusaddons" ,kdbusaddons)
397 ("kdewebkit" ,kdewebkit)
398 ("kdnssd" ,kdnssd)
399 ("ki18n" ,ki18n)
400 ("kiconthemes" ,kiconthemes)
401 ("kio" ,kio)
402 ("knotifications" ,knotifications)
403 ("knotifyconfig" ,knotifyconfig)
404 ("kparts" ,kparts)
405 ("kplotting" ,kplotting)
406 ("kross" ,kross)
407 ("kwidgetsaddons" ,kwidgetsaddons)
408 ("kwindowsystem" ,kwindowsystem)
409 ("kxmlgui" ,kxmlgui)
410 ("libgcrypt" ,libgcrypt)
411 ("libktorrent" ,libktorrent)
412 ;; TODO: LibKWorkspace -> plasma-workspace?
413 ("oxygen-icons" ,oxygen-icons) ; default icon set
414 ("phonon" ,phonon)
415 ("qtbase" ,qtbase)
416 ("qtscript" ,qtscript)
417 ("qtwebkit" ,qtwebkit)
418 ("solid" ,solid)
419 ("syndication" ,syndication)
420 ("taglib" ,taglib)))
421 (home-page "https://kde.org/applications/internet/org.kde.ktorrent")
422 (synopsis "BitTorrent client")
423 (description "KTorrent is a BitTorrent application by KDE which allows you
424 to download files using the BitTorrent protocol. It enables you to run
425 multiple torrents at the same time and comes with extended features to make it
426 a full-featured client for BitTorrent.")
427 (license license:gpl2+)))
428
429 (define-public libgravatar
430 (package
431 (name "libgravatar")
432 (version "20.04.1")
433 (source
434 (origin
435 (method url-fetch)
436 (uri (string-append "mirror://kde/stable/release-service/" version
437 "/src/libgravatar-" version ".tar.xz"))
438 (sha256
439 (base32 "0981ci2kr20v4fk11h57rqya0brgslfazpgq1yk5yqiwyqqm49r2"))))
440 (build-system qt-build-system)
441 (native-inputs
442 `(("extra-cmake-modules" ,extra-cmake-modules)))
443 (inputs
444 `(("kconfig" ,kconfig)
445 ("ki18n" ,ki18n)
446 ("kio" ,kio)
447 ("kpimcommon" ,kpimcommon)
448 ("ktextwidgets" ,ktextwidgets)
449 ("kwidgetsaddons" ,kwidgetsaddons)
450 ("qtbase" ,qtbase)))
451 (arguments
452 `(#:tests? #f)) ;; 2/7 tests fail (due to network issues?)
453 (home-page "https://invent.kde.org/pim/libgravatar")
454 (synopsis "Online avatar lookup library")
455 (description "This library retrieves avatar images based on a
456 hash from a person's email address, as well as local caching to avoid
457 unnecessary network operations.")
458 (license ;; GPL for programs, LGPL for libraries
459 (list license:gpl2+ license:lgpl2.0+))))
460
461 (define-public libktorrent
462 (package
463 (name "libktorrent")
464 (version "2.1.1")
465 (source
466 (origin
467 (method url-fetch)
468 (uri (string-append "mirror://kde//stable/ktorrent/"
469 (package-version ktorrent)
470 "/libktorrent-" version ".tar.xz"))
471 (sha256
472 (base32 "0051zh8bb4p9wmcfn5ql987brhsaiw9880xdck7b5dm1a05mri2w"))))
473 (build-system qt-build-system)
474 (native-inputs
475 `(("extra-cmake-modules" ,extra-cmake-modules)))
476 (inputs
477 `(("boost" ,boost)
478 ("gmp" ,gmp)
479 ("karchive" ,karchive)
480 ("kcrash" ,kcrash)
481 ("ki18n" ,ki18n)
482 ("kio" ,kio)
483 ("libgcrypt" ,libgcrypt)
484 ("qca" ,qca)
485 ("qtbase" ,qtbase)
486 ("solid" ,solid)))
487 (home-page "https://invent.kde.org/network/libktorrent")
488 (synopsis "BitTorrent protocol library for C++ / Qt 5 / KDE Frameworks")
489 (description "The KTorrent library supports connectivity to HTTP and UDP
490 trackers, mainline DHT and the new generation Micro Transport
491 Protocol (uTP). In addition, it provides many powerful BitTorrent network
492 features including but not limited to torrent downloading and seeding, torrent
493 creation and downloaded data verification, magnet links, advanced peer
494 management, IP blocking lists.")
495 (license license:gpl2+)))