gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / gkrellm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
5 ;;;
6 ;;; This file is part of GNU Guix.
7 ;;;
8 ;;; GNU Guix is free software; you can redistribute it and/or modify it
9 ;;; under the terms of the GNU General Public License as published by
10 ;;; the Free Software Foundation; either version 3 of the License, or (at
11 ;;; your option) any later version.
12 ;;;
13 ;;; GNU Guix is distributed in the hope that it will be useful, but
14 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
15 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
16 ;;; GNU General Public License for more details.
17 ;;;
18 ;;; You should have received a copy of the GNU General Public License
19 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
20
21 (define-module (gnu packages gkrellm)
22 #:use-module ((guix licenses) #:prefix license:)
23 #:use-module (guix packages)
24 #:use-module (guix download)
25 #:use-module (guix build-system gnu)
26 #:use-module (gnu packages gettext)
27 #:use-module (gnu packages gtk)
28 #:use-module (gnu packages pkg-config)
29 #:use-module (gnu packages xorg))
30
31 (define-public gkrellm
32 (package
33 (name "gkrellm")
34 (version "2.3.11")
35 (source
36 (origin
37 (method url-fetch)
38 (uri (string-append "http://gkrellm.srcbox.net/releases/gkrellm-"
39 version ".tar.bz2"))
40 (sha256
41 (base32 "01lccz4fga40isv09j8rjgr0qy10rff9vj042n6gi6gdv4z69q0y"))))
42 (build-system gnu-build-system)
43 (inputs
44 `(("gettext" ,gettext-minimal)
45 ("gtk+" ,gtk+-2)
46 ("libice" ,libice)
47 ("libsm" ,libsm)))
48 (native-inputs
49 `(("pkg-config" ,pkg-config)))
50 (arguments
51 `(#:tests? #f ; there is no check target
52 #:phases
53 (modify-phases %standard-phases
54 (delete 'configure)) ; no configure script
55 #:make-flags
56 (let ((out (assoc-ref %outputs "out")))
57 (list (string-append "INSTALLROOT=" out)
58 "CC=gcc"))))
59 (home-page "http://gkrellm.srcbox.net/")
60 (synopsis "System monitors")
61 (description
62 "GKrellM is a single process stack of system monitors which supports
63 applying themes to match its appearance to your window manager, Gtk, or any
64 other theme.")
65 (license license:gpl3+)))