gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / fvwm.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
3 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Nikita <nikita@n0.is>
5 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages fvwm)
23 #:use-module ((guix licenses) #:select (gpl2+))
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix build-system gnu)
27 #:use-module (gnu packages fribidi)
28 #:use-module (gnu packages gnome)
29 #:use-module (gnu packages image)
30 #:use-module (gnu packages perl)
31 #:use-module (gnu packages pkg-config)
32 #:use-module (gnu packages readline)
33 #:use-module (gnu packages xml)
34 #:use-module (gnu packages xorg))
35
36 (define-public fvwm
37 (package
38 (name "fvwm")
39 (version "2.6.9")
40 (source (origin
41 (method url-fetch)
42 (uri (string-append
43 "https://github.com/fvwmorg/fvwm/releases/download/"
44 version "/fvwm-" version ".tar.gz"))
45 (sha256
46 (base32
47 "1bliqcnap7vb3m2rn8wvxyfhbf35h9x34s41fl4301yhrkrlrihv"))))
48 (build-system gnu-build-system)
49 (arguments
50 `(#:phases
51 (modify-phases %standard-phases
52 (add-after 'install 'install-xsession
53 (lambda* (#:key outputs #:allow-other-keys)
54 (let* ((out (assoc-ref outputs "out"))
55 (xsessions (string-append out "/share/xsessions")))
56 (mkdir-p xsessions)
57 (make-desktop-entry-file
58 (string-append xsessions "/fvwm2.desktop")
59 #:name "FVWM"
60 #:exec (string-append out "/bin/" ,name)
61 #:comment '("FVWM")))
62 #t)))))
63 (native-inputs
64 `(("perl" ,perl)
65 ("pkg-config" ,pkg-config)
66 ("xsltproc" ,libxslt)))
67 (inputs
68 `(("fribidi" ,fribidi)
69 ("libpng" ,libpng)
70 ("librsvg" ,librsvg)
71 ("libxcursor" ,libxcursor)
72 ("libxext" ,libxext)
73 ("libxft" ,libxft)
74 ("libxinerama" ,libxinerama)
75 ("libxpm" ,libxpm)
76 ("libxt" ,libxt)
77 ("readline" ,readline)))
78 (synopsis "Virtual window manager for X11")
79 (description
80 "FVWM is an extremely powerful ICCCM-compliant multiple virtual desktop
81 window manager for the X Window system.")
82 (home-page "https://www.fvwm.org/")
83 (license gpl2+)))