gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / file.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
3 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
4 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
5 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
7 ;;;
8 ;;; This file is part of GNU Guix.
9 ;;;
10 ;;; GNU Guix is free software; you can redistribute it and/or modify it
11 ;;; under the terms of the GNU General Public License as published by
12 ;;; the Free Software Foundation; either version 3 of the License, or (at
13 ;;; your option) any later version.
14 ;;;
15 ;;; GNU Guix is distributed in the hope that it will be useful, but
16 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
17 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
18 ;;; GNU General Public License for more details.
19 ;;;
20 ;;; You should have received a copy of the GNU General Public License
21 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
22
23 (define-module (gnu packages file)
24 #:use-module (gnu packages)
25 #:use-module (guix licenses)
26 #:use-module (guix packages)
27 #:use-module (guix download)
28 #:use-module (guix build-system gnu))
29
30 (define-public file
31 (package
32 (name "file")
33 (version "5.38")
34 (source (origin
35 (method url-fetch)
36 (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
37 version ".tar.gz"))
38 (sha256
39 (base32
40 "0d7s376b4xqymnrsjxi3nsv3f5v89pzfspzml2pcajdk5by2yg2r"))))
41 (build-system gnu-build-system)
42
43 ;; When cross-compiling, this package depends upon a native install of
44 ;; itself.
45 (native-inputs (if (%current-target-system)
46 `(("self" ,this-package))
47 '()))
48
49 (properties
50 `((release-monitoring-url . "http://ftp.astron.com/pub/file/")))
51 (synopsis "File type guesser")
52 (description
53 "The file command is a file type guesser, a command-line tool that tells
54 you in words what kind of data a file contains. It does not rely on filename
55 extensions to tell you the type of a file, but looks at the actual contents
56 of the file. This package provides the libmagic library.")
57 (license bsd-2)
58 (home-page "https://www.darwinsys.com/file/")))