gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / conky.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Siniša Biđin <sinisa@bidin.eu>
3 ;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
4 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
5 ;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages conky)
23 #:use-module (guix packages)
24 #:use-module (guix utils)
25 #:use-module (guix download)
26 #:use-module (guix git-download)
27 #:use-module (guix build-system cmake)
28 #:use-module ((guix licenses) #:prefix license:)
29 #:use-module (gnu packages curl)
30 #:use-module (gnu packages fontutils)
31 #:use-module (gnu packages image)
32 #:use-module (gnu packages lua)
33 #:use-module (gnu packages ncurses)
34 #:use-module (gnu packages pkg-config)
35 #:use-module (gnu packages pulseaudio)
36 #:use-module (gnu packages xorg))
37
38 (define-public conky
39 (package
40 (name "conky")
41 (home-page "https://github.com/brndnmtthws/conky")
42 (version "1.11.6")
43 (source
44 (origin
45 (method git-fetch)
46 (uri (git-reference
47 (url home-page)
48 (commit (string-append "v" version))))
49 (file-name (git-file-name name version))
50 (sha256
51 (base32 "0y2g66fjqp2hdk0y1h4ijxhnv34j16gizvxpmbigwh4n6zijcm6v"))))
52 (build-system cmake-build-system)
53 (arguments
54 `(#:tests? #f ; there are no tests
55 #:configure-flags
56 (list "-DRELEASE=true"
57 "-DBUILD_PULSEAUDIO=ON")
58 #:phases
59 (modify-phases %standard-phases
60 (add-after 'unpack 'add-freetype-to-search-path
61 (lambda* (#:key inputs #:allow-other-keys)
62 (substitute* "cmake/ConkyPlatformChecks.cmake"
63 (("set\\(INCLUDE_SEARCH_PATH")
64 (string-append
65 "set(INCLUDE_SEARCH_PATH "
66 (assoc-ref inputs "freetype") "/include/freetype2 ")))
67 #t))
68 (replace 'install
69 (lambda* (#:key outputs #:allow-other-keys)
70 (let* ((out (assoc-ref outputs "out"))
71 (bin (string-append out "/bin")))
72 (install-file "src/conky" bin))
73 #t)))))
74 (inputs
75 `(("freetype" ,freetype)
76 ("imlib2" ,imlib2)
77 ("libx11" ,libx11)
78 ("libxdamage" ,libxdamage)
79 ("libxext" ,libxext)
80 ("libxft" ,libxft)
81 ("libxinerama" ,libxinerama)
82 ("pulseaudio" ,pulseaudio)
83 ("lua" ,lua)
84 ("ncurses" ,ncurses)
85 ("curl" ,curl)))
86 (native-inputs
87 `(("pkg-config" ,pkg-config)))
88 (synopsis "Lightweight system monitor for X")
89 (description
90 "Conky is a lightweight system monitor for X that displays operating
91 system statistics (CPU, disk, and memory usage, etc.) and more on the
92 desktop.")
93 (license license:gpl3+)))