gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / augeas.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
3 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
5 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;;
7 ;;; This file is part of GNU Guix.
8 ;;;
9 ;;; GNU Guix is free software; you can redistribute it and/or modify it
10 ;;; under the terms of the GNU General Public License as published by
11 ;;; the Free Software Foundation; either version 3 of the License, or (at
12 ;;; your option) any later version.
13 ;;;
14 ;;; GNU Guix is distributed in the hope that it will be useful, but
15 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
16 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
17 ;;; GNU General Public License for more details.
18 ;;;
19 ;;; You should have received a copy of the GNU General Public License
20 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
21
22 (define-module (gnu packages augeas)
23 #:use-module ((guix licenses) #:prefix license:)
24 #:use-module (guix packages)
25 #:use-module (guix download)
26 #:use-module (guix utils)
27 #:use-module (guix build-system gnu)
28 #:use-module (gnu packages)
29 #:use-module (gnu packages readline)
30 #:use-module (gnu packages pkg-config)
31 #:use-module (gnu packages xml))
32
33 (define-public augeas
34 (package
35 (name "augeas")
36 (version "1.12.0")
37 (source (origin
38 (method url-fetch)
39 (uri (string-append "http://download.augeas.net/augeas-"
40 version ".tar.gz"))
41 (sha256
42 (base32
43 "11ybhb13wkkilsn7b416a1dn61m1xrq0lbdpkhp5w61jrk4l469j"))))
44 (build-system gnu-build-system)
45 ;; Marked as "required" in augeas.pc.
46 (propagated-inputs
47 `(("libxml2" ,libxml2)))
48 (inputs
49 `(("readline" ,readline)))
50 (native-inputs
51 `(("pkg-config" ,pkg-config)))
52 (home-page "https://augeas.net")
53 (synopsis "Edit configuration files programmatically")
54 (description
55 "Augeas is a library and command line tool for programmatically editing
56 configuration files in a controlled manner. Augeas exposes a tree of all
57 configuration settings and a simple local API for manipulating the tree.
58 Augeas then modifies underlying configuration files according to the changes
59 that have been made to the tree; it does as little modeling of configurations
60 as possible, and focuses exclusivley on transforming the tree-oriented syntax
61 of its public API to the myriad syntaxes of individual configuration files.")
62 (license license:lgpl2.1+)))