gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / abduco.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015, 2016 Leo Famulari <leo@famulari.name>
3 ;;; Copyright © 2020 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
4 ;;;
5 ;;; This file is part of GNU Guix.
6 ;;;
7 ;;; GNU Guix is free software; you can redistribute it and/or modify it
8 ;;; under the terms of the GNU General Public License as published by
9 ;;; the Free Software Foundation; either version 3 of the License, or (at
10 ;;; your option) any later version.
11 ;;;
12 ;;; GNU Guix is distributed in the hope that it will be useful, but
13 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
14 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
15 ;;; GNU General Public License for more details.
16 ;;;
17 ;;; You should have received a copy of the GNU General Public License
18 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
19
20 (define-module (gnu packages abduco)
21 #:use-module (guix build-system gnu)
22 #:use-module (guix utils)
23 #:use-module (guix download)
24 #:use-module (guix licenses)
25 #:use-module (guix packages))
26
27 (define-public abduco
28 (package
29 (name "abduco")
30 (version "0.6")
31 (source (origin
32 (method url-fetch)
33 (uri (string-append
34 "https://www.brain-dump.org/projects/abduco/abduco-"
35 version ".tar.gz"))
36 (sha256
37 (base32
38 "1x1m58ckwsprljgmdy93mvgjyg9x3cqrzdf3mysp0mx97zhhj2f9"))))
39 (build-system gnu-build-system)
40 (arguments
41 `(#:make-flags (list (string-append "CC=" ,(cc-for-target))
42 (string-append "PREFIX=" (assoc-ref %outputs "out")))
43 #:phases (modify-phases %standard-phases
44 (delete 'configure)
45 (delete 'check)))) ; no test suite
46 (synopsis "Session management in a clean and simple way")
47 (description "abduco provides session management i.e. it allows programs to
48 be run independently from their controlling terminal. That is, programs can
49 be detached---run in the background---and then later reattached.")
50 (home-page "https://www.brain-dump.org/projects/abduco/")
51 (license isc)))