Merge branch 'master' into ungrafting
[jackhill/guix/guix.git] / gnu / packages / openstack.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2015 Cyril Roelandt <tipecaml@gmail.com>
3 ;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
4 ;;; Copyright © 2016, 2017, 2019 Clément Lassieur <clement@lassieur.org>
5 ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
6 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
7 ;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
8 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
9 ;;;
10 ;;; This file is part of GNU Guix.
11 ;;;
12 ;;; GNU Guix is free software; you can redistribute it and/or modify it
13 ;;; under the terms of the GNU General Public License as published by
14 ;;; the Free Software Foundation; either version 3 of the License, or (at
15 ;;; your option) any later version.
16 ;;;
17 ;;; GNU Guix is distributed in the hope that it will be useful, but
18 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
19 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
20 ;;; GNU General Public License for more details.
21 ;;;
22 ;;; You should have received a copy of the GNU General Public License
23 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
24
25 (define-module (gnu packages openstack)
26 #:use-module (gnu packages)
27 #:use-module (gnu packages check)
28 #:use-module (gnu packages gnupg)
29 #:use-module (gnu packages python)
30 #:use-module (gnu packages python-check)
31 #:use-module (gnu packages python-crypto)
32 #:use-module (gnu packages python-web)
33 #:use-module (gnu packages python-xyz)
34 #:use-module (gnu packages sphinx)
35 #:use-module (gnu packages ssh)
36 #:use-module (gnu packages time)
37 #:use-module (gnu packages tls)
38 #:use-module (gnu packages version-control)
39 #:use-module (gnu packages xml)
40 #:use-module (guix build-system python)
41 #:use-module (guix download)
42 #:use-module ((guix licenses)
43 #:select (asl2.0))
44 #:use-module (guix packages)
45 #:use-module (srfi srfi-1))
46
47 (define-public python-bandit
48 (package
49 (name "python-bandit")
50 (version "1.6.2")
51 (source
52 (origin
53 (method url-fetch)
54 (uri (pypi-uri "bandit" version))
55 (sha256
56 (base32
57 "0rb034c99pyhb4a60z7f2kz40cjydhm8m9v2blaal1rmhlam7rs1"))))
58 (build-system python-build-system)
59 (arguments
60 ;; The tests are disabled to avoid a circular dependency with
61 ;; python-stestr.
62 `(#:tests? #f))
63 (propagated-inputs
64 `(("python-gitpython" ,python-gitpython)
65 ("python-pyyaml" ,python-pyyaml)
66 ("python-six" ,python-six)
67 ("python-stevedore" ,python-stevedore)))
68 (native-inputs
69 `(("python-pbr" ,python-pbr)))
70 (home-page "https://github.com/PyCQA/bandit")
71 (synopsis "Security oriented static analyser for python code")
72 (description "Bandit is a tool designed to find common security issues in
73 Python code. To do this Bandit processes each file, builds an AST from it,
74 and runs appropriate plugins against the AST nodes. Once Bandit has finished
75 scanning all the files it generates a report.")
76 (license asl2.0)))
77
78 (define-public python-cliff
79 (package
80 (name "python-cliff")
81 (version "3.5.0")
82 (source
83 (origin
84 (method url-fetch)
85 (uri (pypi-uri "cliff" version))
86 (sha256
87 (base32
88 "0n8pzr0mnn9lq2mykds69ij2xrn0fsirh4ndmkx0mzydbx5niysv"))))
89 (build-system python-build-system)
90 (arguments
91 `(#:tests? #f))
92 (native-inputs
93 `(("python-pbr" ,python-pbr)))
94 (propagated-inputs
95 `(("python-cmd2" ,python-cmd2)
96 ("python-prettytable" ,python-prettytable)
97 ("python-pyparsing" ,python-pyparsing)
98 ("python-pyyaml" ,python-pyyaml)
99 ("python-bandit" ,python-bandit)
100 ("python-stevedore" ,python-stevedore)))
101 (home-page "https://opendev.org/openstack/cliff")
102 (synopsis "Framework for building command line programs")
103 (description "The @code{cliff} framework allows creating multi-level
104 commands such as those of @command{subversion} and @command{git}, where the
105 main program handles some basic argument parsing and then invokes a
106 sub-command to do the work. It uses plugins to define sub-commands, output
107 formatters, and other extensions.")
108 (license asl2.0)))
109
110 (define-public python-debtcollector
111 (package
112 (name "python-debtcollector")
113 (version "1.19.0")
114 (source
115 (origin
116 (method url-fetch)
117 (uri (pypi-uri "debtcollector" version))
118 (sha256
119 (base32
120 "06c7vyn184y9f0lsrwaz13aq63hdz5fjrd191b8nifx6acsni42f"))))
121 (build-system python-build-system)
122 (propagated-inputs
123 `(("python-pbr" ,python-pbr)
124 ("python-six" ,python-six)
125 ("python-wrapt" ,python-wrapt)))
126 (native-inputs
127 `(;; Tests.
128 ("python-subunit" ,python-subunit)
129 ("python-testrepository" ,python-testrepository)
130 ("python-testtools" ,python-testtools)))
131 (home-page "https://www.openstack.org/")
132 (synopsis
133 "Find deprecated patterns and strategies in Python code")
134 (description
135 "This package provides a collection of Python deprecation patterns and
136 strategies that help you collect your technical debt in a non-destructive
137 manner.")
138 (properties `((python2-variant . ,(delay python2-debtcollector))))
139 (license asl2.0)))
140
141 (define-public python2-debtcollector
142 (let ((base (package-with-python2 (strip-python2-variant
143 python-debtcollector))))
144 (package
145 (inherit base)
146 (propagated-inputs
147 `(("python2-funcsigs" ,python2-funcsigs)
148 ,@(package-propagated-inputs base))))))
149
150 (define-public python-hacking
151 (package
152 (name "python-hacking")
153 (version "4.0.0")
154 (source
155 (origin
156 (method url-fetch)
157 (uri (pypi-uri "hacking" version))
158 (sha256
159 (base32
160 "062rvbkvbavqqz55f7q00ikwipkn5j0rdls1rrajdbfwgckjcrsm"))))
161 (build-system python-build-system)
162 (propagated-inputs
163 `(("python-flake8" ,python-flake8)))
164 (native-inputs
165 `( ;; Tests
166 ("python-coverage" ,python-coverage)
167 ("python-ddt" ,python-ddt)
168 ("python-dnspython" ,python-dnspython)
169 ("python-fixtures" ,python-fixtures)
170 ("python-eventlet" ,python-eventlet)
171 ("python-mock" ,python-mock)
172 ("python-monotonic" ,python-monotonic)
173 ("python-subunit" ,python-subunit)
174 ("python-stestr" ,python-stestr)
175 ("python-testscenarios" ,python-testscenarios)
176 ("python-testtools" ,python-testtools)))
177 (home-page "https://github.com/openstack-dev/hacking")
178 (synopsis "OpenStack hacking guideline enforcement")
179 (description
180 "Python-hacking is a set of flake8 plugins that test and enforce the
181 @uref{http://docs.openstack.org/developer/hacking/, OpenStack style
182 guidelines}.")
183 (license asl2.0)))
184
185 (define-public python-mox3
186 (package
187 (name "python-mox3")
188 (version "0.24.0")
189 (source
190 (origin
191 (method url-fetch)
192 (uri (pypi-uri "mox3" version))
193 (patches (search-patches "python-mox3-python3.6-compat.patch"))
194 (sha256
195 (base32
196 "0w58adwv7q9wzvmq9mlrk2asfk73myq9fpwy7mjkzsz3baa95zf5"))))
197 (build-system python-build-system)
198 (propagated-inputs
199 `(("python-fixtures" ,python-fixtures)
200 ("python-pbr" ,python-pbr)))
201 (native-inputs
202 `(("python-openstackdocstheme" ,python-openstackdocstheme)
203 ("python-sphinx" ,python-sphinx)
204 ("python-subunit" ,python-subunit)
205 ("python-testrepository" ,python-testrepository)
206 ("python-testtools" ,python-testtools)))
207 (home-page "https://www.openstack.org/")
208 (synopsis "Mock object framework for Python")
209 (description
210 "Mox3 is an unofficial port of the @uref{https://code.google.com/p/pymox/,
211 Google mox framework} to Python 3. It was meant to be as compatible
212 with mox as possible, but small enhancements have been made.")
213 (license asl2.0)))
214
215 (define-public python-openstackdocstheme
216 (package
217 (name "python-openstackdocstheme")
218 (version "1.18.1")
219 (source (origin
220 (method url-fetch)
221 (uri (pypi-uri "openstackdocstheme" version))
222 (sha256
223 (base32
224 "1ki5204rjdqjvr8xr9w2qc1z6b6d2i5jas0i70xzkf9njlzjzv2r"))))
225 (build-system python-build-system)
226 (arguments
227 ;; FIXME: Tests require an old version of python-hacking, which in
228 ;; turn depends on mox3 which depends on this package.
229 `(#:tests? #f))
230 (propagated-inputs
231 `(("python-dulwich" ,python-dulwich)
232 ("python-pbr" ,python-pbr)))
233 (native-inputs
234 `(("python-sphinx" ,python-sphinx)))
235 (home-page "https://docs.openstack.org/openstackdocstheme/latest/")
236 (synopsis "OpenStack Docs Theme")
237 (description
238 "This package provides themes and extensions for Sphinx for publishing
239 to docs.openstack.org and developer.openstack.org.")
240 (license asl2.0)))
241
242 (define-public python-os-client-config
243 (package
244 (name "python-os-client-config")
245 (version "1.12.0")
246 (source
247 (origin
248 (method url-fetch)
249 (uri (pypi-uri "os-client-config" version))
250 (sha256
251 (base32
252 "1vjn7667pswnmpqv6ngwyqm2xn46w90hi5b4pv2grwfz751cn1lf"))))
253 (build-system python-build-system)
254 (arguments
255 `(#:tests? #f)) ;; Circular dependency with python-oslotest
256 (propagated-inputs
257 `(("python-appdirs" ,python-appdirs)
258 ("python-pyyaml" ,python-pyyaml)))
259 (native-inputs
260 `(("python-pbr" ,python-pbr)
261 ("python-fixtures" ,python-fixtures)
262 ("python-mimeparse" ,python-mimeparse)
263 ("python-testrepository" ,python-testrepository)
264 ("python-testscenarios" ,python-testscenarios)
265 ("python-testtools" ,python-testtools)))
266 (home-page "https://www.openstack.org/")
267 (synopsis
268 "OpenStack Client Configuration Library")
269 (description
270 "The OpenStack Client Configuration Library is a library for collecting
271 client configuration for using an OpenStack cloud in a consistent and
272 comprehensive manner.")
273 (license asl2.0)))
274
275 (define-public python2-os-client-config
276 (package-with-python2 python-os-client-config))
277
278 (define-public python-os-testr
279 (package
280 (name "python-os-testr")
281 (version "0.8.0")
282 (source
283 (origin
284 (method url-fetch)
285 (uri (pypi-uri "os-testr" version))
286 (sha256
287 (base32
288 "0mknd9hlmxmihr755gjkxyjp180380jajq5i3zm34q7y7bi62lss"))))
289 (build-system python-build-system)
290 (arguments
291 ;; os-testr uses itself to run the tests. It seems like pbr writes the
292 ;; exectuable in the virtualenv when using tox. Not sure how to do this
293 ;; when building the package. Skip the tests for now.
294 `(#:tests? #f))
295 (propagated-inputs
296 `(("python-subunit" ,python-subunit)))
297 (native-inputs
298 `(("python-pbr" ,python-pbr)
299 ("python-testtools" ,python-testtools)
300 ("python-babel" ,python-babel)))
301 (home-page "https://www.openstack.org/")
302 (synopsis "Testr wrapper to provide functionality for OpenStack projects")
303 (description
304 "Os-testr provides developers with a testr wrapper and an output filter
305 for subunit.")
306 (license asl2.0)))
307
308 (define-public python2-os-testr
309 (package-with-python2 python-os-testr))
310
311 (define-public python-stevedore
312 (package
313 (name "python-stevedore")
314 (version "3.2.2")
315 (source
316 (origin
317 (method url-fetch)
318 (uri (pypi-uri "stevedore" version))
319 (sha256
320 (base32
321 "1w11lm293afzb73iq0ba9wnmr2rjwymnhr92km4a4xrs7a5qcigq"))))
322 (build-system python-build-system)
323 (arguments
324 ;; The tests are disabled to avoid a circular dependency with
325 ;; python-stestr.
326 `(#:tests? #f))
327 (native-inputs
328 `(("python-pbr" ,python-pbr)))
329 (home-page "https://github.com/dreamhost/stevedore")
330 (synopsis "Manage dynamic plugins for Python applications")
331 (description
332 "Python makes loading code dynamically easy, allowing you to configure
333 and extend your application by discovering and loading extensions (\"plugins\")
334 at runtime. Many applications implement their own library for doing this,
335 using __import__ or importlib. Stevedore avoids creating yet another extension
336 mechanism by building on top of setuptools entry points. The code for managing
337 entry points tends to be repetitive, though, so stevedore provides manager
338 classes for implementing common patterns for using dynamically loaded
339 extensions.")
340 (license asl2.0)))
341
342 (define-public python2-stevedore
343 (package-with-python2 python-stevedore))
344
345 (define-public python-tempest-lib
346 (package
347 (name "python-tempest-lib")
348 (version "1.0.0")
349 (source
350 (origin
351 (method url-fetch)
352 (uri (pypi-uri "tempest-lib" version))
353 (sha256
354 (base32
355 "1cpp2vwmawpd29hjsklsps181lq2ah91cl412qvpnz228nf9sqn5"))))
356 (build-system python-build-system)
357 (arguments
358 `(#:tests? #f ; FIXME: Requires oslo.log >= 1.14.0.
359 #:phases
360 (modify-phases %standard-phases
361 (add-before
362 'check 'pre-check
363 (lambda _
364 (substitute* "tempest_lib/tests/cli/test_execute.py"
365 (("/bin/ls") (which "ls"))))))))
366 (propagated-inputs
367 `(("python-fixtures" ,python-fixtures)
368 ("python-httplib2" ,python-httplib2)
369 ("python-iso8601" ,python-iso8601)
370 ("python-jsonschema" ,python-jsonschema)
371 ("python-oslo.log" ,python-oslo.log)
372 ("python-paramiko" ,python-paramiko)
373 ("python-pbr" ,python-pbr)
374 ("python-six" ,python-six)))
375 (native-inputs
376 `(("python-babel" ,python-babel)
377 ("python-mock" ,python-mock)
378 ("python-os-testr" ,python-os-testr)
379 ("python-oslotest" ,python-oslotest)))
380 (home-page "https://www.openstack.org/")
381 (synopsis "OpenStack functional testing library")
382 (description
383 "Tempest-lib is a functional testing library for OpenStack. It provides
384 common features used in Tempest.")
385 (license asl2.0)))
386
387 \f
388 ;;;
389 ;;; Packages from the Oslo library
390 ;;;
391
392 (define-public python-oslo.config
393 (package
394 (name "python-oslo.config")
395 (version "5.2.0")
396 (source
397 (origin
398 (method url-fetch)
399 (uri (pypi-uri "oslo.config" version))
400 (sha256
401 (base32
402 "0ymf7jxbq29fifyvkwhfiys1qvljqfxdw8ajwzwaf3yiqidgpxqd"))))
403 (build-system python-build-system)
404 (propagated-inputs
405 `(("python-debtcollector" ,python-debtcollector)
406 ("python-netaddr" ,python-netaddr)
407 ("python-oslo.i18n" ,python-oslo.i18n)
408 ("python-pbr" ,python-pbr)
409 ("python-rfc3986" ,python-rfc3986)
410 ("python-six" ,python-six)
411 ("python-stevedore" ,python-stevedore)
412 ("python-pyyaml" ,python-pyyaml)))
413 (native-inputs
414 `(("python-bandit" ,python-bandit)
415 ("python-coverage" ,python-coverage)
416 ("python-mock" ,python-mock)
417 ("python-openstackdocstheme" ,python-openstackdocstheme)
418 ("python-oslotest" ,python-oslotest)
419 ("python-reno" ,python-reno)
420 ("python-sphinx" ,python-sphinx)
421 ("python-testrepository" ,python-testrepository)
422 ("python-testscenarios" ,python-testscenarios)
423 ("python-testtools" ,python-testtools)))
424 (home-page "https://launchpad.net/oslo")
425 (synopsis "Oslo Configuration API")
426 (description
427 "The Oslo configuration API supports parsing command line arguments and
428 .ini style configuration files.")
429 (license asl2.0)))
430
431 (define-public python-oslo.context
432 (package
433 (name "python-oslo.context")
434 (version "3.1.1")
435 (source
436 (origin
437 (method url-fetch)
438 (uri (pypi-uri "oslo.context" version))
439 (sha256
440 (base32
441 "1l2z186rkd9acrb2ygf53yrdc1lgf7cy1akbhm21kgkzind4p2r6"))))
442 (build-system python-build-system)
443 (arguments
444 `(#:phases (modify-phases %standard-phases
445 (add-after 'unpack 'relax-requirements
446 (lambda _
447 (substitute* "test-requirements.txt"
448 (("hacking>=3.0.1,<3.1.0")
449 "hacking>=3.0.1"))
450 #t)))))
451 (propagated-inputs
452 `(("python-debtcollector" ,python-debtcollector)))
453 (native-inputs
454 `(("python-bandit" ,python-bandit)
455 ("python-coverage" ,python-coverage)
456 ("python-fixtures" ,python-fixtures)
457 ("python-hacking" ,python-hacking)
458 ("python-oslotest" ,python-oslotest)
459 ("python-pbr" ,python-pbr)
460 ("python-stestr" ,python-stestr)))
461 (home-page "https://launchpad.net/oslo")
462 (synopsis "Oslo context library")
463 (description
464 "The Oslo context library has helpers to maintain useful information
465 about a request context. The request context is usually populated in the WSGI
466 pipeline and used by various modules such as logging.")
467 (license asl2.0)))
468
469 (define-public python-oslo.i18n
470 (package
471 (name "python-oslo.i18n")
472 (version "3.20.0")
473 (source
474 (origin
475 (method url-fetch)
476 (uri (pypi-uri "oslo.i18n" version))
477 (sha256
478 (base32
479 "0kjcdw4bk3mi4vqmqwhhq053kxbbbj05si6nwxd1pzx33z067ky3"))))
480 (build-system python-build-system)
481 (propagated-inputs
482 `(("python-babel" ,python-babel)
483 ("python-six" ,python-six)))
484 (native-inputs
485 `(("python-pbr" ,python-pbr)
486 ;; Tests
487 ("python-mock" ,python-mock)
488 ("python-mox3" ,python-mox3)
489 ("python-oslotest" ,python-oslotest)
490 ("python-testscenarios" ,python-testscenarios)))
491 (home-page "https://launchpad.net/oslo")
492 (synopsis "Oslo internationalization (i18n) library")
493 (description
494 "The oslo.i18n library contain utilities for working with
495 internationalization (i18n) features, especially translation for text strings
496 in an application or library.")
497 (license asl2.0)))
498
499 (define-public python-oslo.log
500 (package
501 (name "python-oslo.log")
502 (version "3.36.0")
503 (source
504 (origin
505 (method url-fetch)
506 (uri (pypi-uri "oslo.log" version))
507 (sha256
508 (base32
509 "0h7hplf1h8k24v75m3mq1jlrl74x5ynyr4hwgffsg5campxnza4x"))))
510 (build-system python-build-system)
511 (propagated-inputs
512 `(("python-dateutil" ,python-dateutil)
513 ("python-debtcollector" ,python-debtcollector)
514 ("python-monotonic" ,python-monotonic)
515 ("python-oslo.config" ,python-oslo.config)
516 ("python-oslo.context" ,python-oslo.context)
517 ("python-oslo.i18n" ,python-oslo.i18n)
518 ("python-oslo.utils" ,python-oslo.utils)
519 ("python-oslo.serialization" ,python-oslo.serialization)
520 ("python-pbr" ,python-pbr)
521 ("python-pyinotify" ,python-pyinotify)
522 ("python-six" ,python-six)))
523 (native-inputs
524 `(("python-mock" ,python-mock)
525 ("python-oslotest" ,python-oslotest)
526 ("python-subunit" ,python-subunit)
527 ("python-testrepository" ,python-testrepository)
528 ("python-testtools" ,python-testtools)))
529 (home-page "https://launchpad.net/oslo")
530 (synopsis "Python logging library of the Oslo project")
531 (description
532 "The oslo.log (logging) configuration library provides standardized
533 configuration for all OpenStack projects. It also provides custom formatters,
534 handlers and support for context specific logging (like resource id’s etc).")
535 (license asl2.0)))
536
537 (define-public python-oslo.serialization
538 (package
539 (name "python-oslo.serialization")
540 (version "2.24.0")
541 (source
542 (origin
543 (method url-fetch)
544 (uri (pypi-uri "oslo.serialization" version))
545 (sha256
546 (base32
547 "08bxkp98c617y58x630xq44iiffm7f0f3cwh6zbnlkgq0zgh7jk1"))))
548 (build-system python-build-system)
549 (propagated-inputs
550 `(("python-msgpack" ,python-msgpack)
551 ("python-netaddr" ,python-netaddr)
552 ("python-oslo.utils" ,python-oslo.utils)
553 ("python-six" ,python-six)
554 ("python-pytz" ,python-pytz)))
555 (native-inputs
556 `(("python-pbr" ,python-pbr)
557 ;; Tests.
558 ("python-mock" ,python-mock)
559 ("python-oslo.i18n" ,python-oslo.i18n)
560 ("python-oslotest" ,python-oslotest)))
561 (home-page "https://launchpad.net/oslo")
562 (synopsis "Oslo serialization library")
563 (description
564 "The oslo.serialization library provides support for representing objects
565 in transmittable and storable formats, such as JSON and MessagePack.")
566 (license asl2.0)))
567
568 (define-public python-reno
569 (package
570 (name "python-reno")
571 (version "2.7.0")
572 (source
573 (origin
574 (method url-fetch)
575 (uri (pypi-uri "reno" version))
576 (sha256
577 (base32 "0gwzi5dvacqx43smxl3rd1z33npn7gfhm50bvgmq90fib2q431wc"))))
578 (build-system python-build-system)
579 (arguments
580 `(#:phases
581 (modify-phases %standard-phases
582 (add-before 'check 'init-git
583 (lambda _
584 ;; reno expects a git repo
585 (invoke "git" "init"))))))
586 (propagated-inputs
587 `(("python-dulwich" ,python-dulwich)
588 ("python-pbr" ,python-pbr)
589 ("python-pyyaml" ,python-pyyaml)
590 ("python-six" ,python-six)))
591 (native-inputs
592 `(("python-testtools" ,python-testtools)
593 ("python-testscenarios" ,python-testscenarios)
594 ("python-testrepository" ,python-testrepository)
595 ("python-mock" ,python-mock)
596 ("python-docutils" ,python-docutils)
597 ("python-sphinx" ,python-sphinx)
598 ("gnupg" ,gnupg)
599 ("git" ,git-minimal)))
600 (home-page "https://docs.openstack.org/reno/latest/")
601 (synopsis "Release notes manager")
602 (description "Reno is a tool for storing release notes in a git repository
603 and building documentation from them.")
604 (license asl2.0)))
605
606 (define-public python-oslosphinx
607 (package
608 (name "python-oslosphinx")
609 (version "4.18.0")
610 (source
611 (origin
612 (method url-fetch)
613 (uri (pypi-uri "oslosphinx" version))
614 (sha256
615 (base32
616 "1xm41857vzrzjmnyi6bqirg4i5qa61v7wxcsdc4q1nzgr3ndgz5k"))))
617 (build-system python-build-system)
618 (arguments
619 `(#:phases
620 (modify-phases %standard-phases
621 (add-after 'unpack 'relax-requirements
622 (lambda _
623 (substitute* "test-requirements.txt"
624 (("hacking!=0.13.0,<0.14,>=0.12.0")
625 "hacking!=0.13.0,>=0.12.0"))
626 #t)))))
627 (propagated-inputs
628 `(("python-requests" ,python-requests)))
629 (native-inputs
630 `(("python-hacking" ,python-hacking)
631 ("python-openstackdocstheme" ,python-openstackdocstheme)
632 ("python-pbr" ,python-pbr)
633 ("python-reno" ,python-reno)
634 ("python-sphinx" ,python-sphinx)))
635 (home-page "https://www.openstack.org/")
636 (synopsis "OpenStack sphinx extensions and theme")
637 (description "This package provides themes and extensions for Sphinx
638 documentation from the OpenStack project.")
639 (license asl2.0)))
640
641 (define-public python-oslotest
642 (package
643 (name "python-oslotest")
644 (version "4.4.1")
645 (source
646 (origin
647 (method url-fetch)
648 (uri (pypi-uri "oslotest" version))
649 (sha256
650 (base32
651 "0r50sz55m8ljv2vk1k7sp88iz1iqq4p9w6kb8hn8g8c50r9zdi5i"))))
652 (build-system python-build-system)
653 (arguments
654 ;; The tests are disabled to avoid a circular dependency with oslo.config.
655 `(#:tests? #f))
656 (propagated-inputs
657 `(("python-fixtures" ,python-fixtures)
658 ("python-six" ,python-six)
659 ("python-subunit" ,python-subunit)
660 ("python-testtools" ,python-testtools)))
661 (home-page "https://launchpad.net/oslo")
662 (synopsis "Oslo test framework")
663 (description "The Oslo Test framework provides common fixtures, support
664 for debugging, and better support for mocking results.")
665 (license asl2.0)))
666
667 (define-public python2-oslotest
668 (package-with-python2 python-oslotest))
669
670 (define-public python-oslo.utils
671 (package
672 (name "python-oslo.utils")
673 (version "3.36.2")
674 (source
675 (origin
676 (method url-fetch)
677 (uri (pypi-uri "oslo.utils" version))
678 (sha256
679 (base32
680 "1ipjcgg9z697wmibhcbg5lqpk5gafakdx4qkff3w255zr0mvw04r"))))
681 (build-system python-build-system)
682 (propagated-inputs
683 `(("python-debtcollector" ,python-debtcollector)
684 ("python-oslo.i18n" ,python-oslo.i18n)
685 ("python-iso8601" ,python-iso8601)
686 ("python-monotonic" ,python-monotonic)
687 ("python-netaddr" ,python-netaddr)
688 ("python-netifaces" ,python-netifaces)
689 ("python-pyparsing" ,python-pyparsing)
690 ("python-pytz" ,python-pytz)
691 ("python-six" ,python-six)))
692 (native-inputs
693 `(("python-pbr" ,python-pbr)
694 ;; Tests.
695 ("python-bandit" ,python-bandit)
696 ("python-ddt" ,python-ddt)
697 ("python-fixtures" ,python-fixtures)
698 ("python-oslo.config" ,python-oslo.config)
699 ("python-oslotest" ,python-oslotest)
700 ("python-mock" ,python-mock)
701 ("python-testrepository" ,python-testrepository)
702 ("python-testscenarios" ,python-testscenarios)
703 ("python-testtools" ,python-testtools)))
704 (home-page "https://launchpad.net/oslo")
705 (synopsis "Oslo utility library")
706 (description
707 "The @code{oslo.utils} library provides support for common utility type
708 functions, such as encoding, exception handling, string manipulation, and time
709 handling.")
710 (license asl2.0)))
711
712 (define-public python-keystoneclient
713 (package
714 (name "python-keystoneclient")
715 (version "1.8.1")
716 (source
717 (origin
718 (method url-fetch)
719 (uri (pypi-uri "python-keystoneclient" version))
720 (sha256
721 (base32
722 "1w4csvkah67rfpxylxnvs2s3594i0f9isy8pf4gnsqs5zirvjaa4"))))
723 (build-system python-build-system)
724 (arguments
725 '(#:tests? #f)) ; FIXME: Many tests are failing.
726 (native-inputs
727 `(("python-sphinx" ,python-sphinx)
728 ;; and some packages for the tests
729 ("openssl" ,openssl)
730 ("python-coverage" ,python-coverage)
731 ("python-discover" ,python-discover)
732 ("python-fixtures" ,python-fixtures)
733 ("python-hacking" ,python-hacking)
734 ("python-keyring" ,python-keyring)
735 ("python-lxml" ,python-lxml)
736 ("python-mock" ,python-mock)
737 ("python-mox3" ,python-mox3)
738 ("python-oauthlib" ,python-oauthlib)
739 ("python-oslosphinx" ,python-oslosphinx)
740 ("python-oslotest" ,python-oslotest)
741 ("python-pycrypto" ,python-pycrypto)
742 ("python-requests-mock" ,python-requests-mock)
743 ("python-temptest-lib" ,python-tempest-lib)
744 ("python-testrepository" ,python-testrepository)
745 ("python-testresources" ,python-testresources)
746 ("python-testtools" ,python-testtools)
747 ("python-webob" ,python-webob)))
748 (propagated-inputs
749 `(("python-babel" ,python-babel)
750 ("python-debtcollector" ,python-debtcollector)
751 ("python-iso8601" ,python-iso8601)
752 ("python-netaddr" ,python-netaddr)
753 ("python-oslo.config" ,python-oslo.config)
754 ("python-oslo.i18n" ,python-oslo.i18n)
755 ("python-oslo.serialization" ,python-oslo.serialization)
756 ("python-oslo.utils" ,python-oslo.utils)
757 ("python-pbr" ,python-pbr)
758 ("python-prettytable" ,python-prettytable)
759 ("python-requests" ,python-requests)
760 ("python-six" ,python-six)
761 ("python-stevedore" ,python-stevedore)))
762 (home-page "https://www.openstack.org/")
763 (synopsis "Client Library for OpenStack Identity")
764 (description
765 "Python-keystoneclient is the identity service used by OpenStack for
766 authentication (authN) and high-level authorization (authZ). It currently
767 supports token-based authN with user/service authZ, and is scalable to support
768 OAuth, SAML, and OpenID in future versions. Out of the box, Keystone uses
769 SQLite for its identity store database, with the option to connect to external
770 LDAP.")
771 (license asl2.0)))
772
773 (define-public python-swiftclient
774 (package
775 (name "python-swiftclient")
776 (version "2.6.0")
777 (source
778 (origin
779 (method url-fetch)
780 (uri (pypi-uri "python-swiftclient" version))
781 (sha256
782 (base32
783 "1j33l4z9vqh0scfncl4fxg01zr1hgqxhhai6gvcih1gccqm4nd7p"))))
784 (build-system python-build-system)
785 (native-inputs
786 `(("python-pbr" ,python-pbr)
787 ("python-sphinx" ,python-sphinx)
788 ;; The folloing packages are needed for the tests.
789 ("python-coverage" ,python-coverage)
790 ("python-discover" ,python-discover)
791 ("python-hacking" ,python-hacking)
792 ("python-mock" ,python-mock)
793 ("python-oslosphinx" ,python-oslosphinx)
794 ("python-keystoneclient" ,python-keystoneclient)
795 ("python-testrepository" ,python-testrepository)
796 ("python-testtools" ,python-testtools)))
797 (propagated-inputs
798 `(("python-requests" ,python-requests)
799 ("python-six" ,python-six)))
800 (home-page "https://www.openstack.org/")
801 (synopsis "OpenStack Object Storage API Client Library")
802 (description
803 "OpenStack Object Storage (code-named Swift) creates redundant, scalable
804 object storage using clusters of standardized servers to store petabytes of
805 accessible data. It is not a file system or real-time data storage system, but
806 rather a long-term storage system for a more permanent type of static data that
807 can be retrieved, leveraged, and then updated if necessary. Primary examples of
808 data that best fit this type of storage model are virtual machine images, photo
809 storage, email storage and backup archiving. Having no central \"brain\" or
810 master point of control provides greater scalability, redundancy and
811 permanence.")
812 (license asl2.0)))
813
814 (define-public python-git-review
815 (package
816 (name "python-git-review")
817 (version "1.28.0")
818 (source
819 (origin
820 (method url-fetch)
821 (uri (pypi-uri "git-review" version))
822 (sha256
823 (base32 "0nn17mfqvsa3ryjz53qjslmf60clc0vx2115kkj66h28p6vsnflf"))))
824 (build-system python-build-system)
825 (arguments
826 '(#:tests? #f ; tests require a running Gerrit server
827 #:phases
828 (modify-phases %standard-phases
829 (add-after 'install 'wrap-program
830 (lambda* (#:key inputs outputs #:allow-other-keys)
831 (let* ((out (assoc-ref outputs "out"))
832 (git (assoc-ref inputs "git"))
833 (openssh (assoc-ref inputs "openssh")))
834 (wrap-program (string-append out "/bin/git-review")
835 `("PATH" ":" prefix
836 ,(map (lambda (dir)
837 (string-append dir "/bin"))
838 (list git openssh)))))
839 #t)))))
840 (native-inputs
841 `(("python-pbr" ,python-pbr)))
842 (propagated-inputs
843 `(("python-requests" ,python-requests)))
844 (inputs
845 `(("git" ,git)
846 ("openssh" ,openssh)))
847 (home-page "https://docs.openstack.org/infra/git-review/")
848 (synopsis "Command-line tool for Gerrit")
849 (description
850 "Git-review is a command-line tool that helps submitting Git branches to
851 Gerrit for review, or fetching existing ones.")
852 (license asl2.0)))
853
854 (define-public python2-git-review
855 (package-with-python2 python-git-review))