Merge branch 'master' into staging
[jackhill/guix/guix.git] / gnu / packages / guile.scm
1 ;;; GNU Guix --- Functional package management for GNU
2 ;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
3 ;;; Copyright © 2014 Cyril Roelandt <tipecaml@gmail.com>
4 ;;; Copyright © 2014, 2016, 2018 David Thompson <davet@gnu.org>
5 ;;; Copyright © 2014, 2017, 2018 Mark H Weaver <mhw@netris.org>
6 ;;; Copyright © 2015, 2017 Christopher Allan Webber <cwebber@dustycloud.org>
7 ;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
8 ;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
9 ;;; Copyright © 2016, 2019 Ricardo Wurmus <rekado@elephly.net>
10 ;;; Copyright © 2017 Andy Wingo <wingo@igalia.com>
11 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
12 ;;; Copyright © 2017, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
13 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
14 ;;; Copyright © 2017, 2018 Amirouche <amirouche@hypermove.net>
15 ;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
16 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
17 ;;; Copyright © 2019 Taylan Kammer <taylan.kammer@gmail.com>
18 ;;;
19 ;;; This file is part of GNU Guix.
20 ;;;
21 ;;; GNU Guix is free software; you can redistribute it and/or modify it
22 ;;; under the terms of the GNU General Public License as published by
23 ;;; the Free Software Foundation; either version 3 of the License, or (at
24 ;;; your option) any later version.
25 ;;;
26 ;;; GNU Guix is distributed in the hope that it will be useful, but
27 ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
28 ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
29 ;;; GNU General Public License for more details.
30 ;;;
31 ;;; You should have received a copy of the GNU General Public License
32 ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
33
34 (define-module (gnu packages guile)
35 #:use-module ((guix licenses) #:prefix license:)
36 #:use-module (gnu packages)
37 #:use-module (gnu packages autotools)
38 #:use-module (gnu packages base)
39 #:use-module (gnu packages bash)
40 #:use-module (gnu packages bdw-gc)
41 #:use-module (gnu packages compression)
42 #:use-module (gnu packages dbm)
43 #:use-module (gnu packages flex)
44 #:use-module (gnu packages gawk)
45 #:use-module (gnu packages gettext)
46 #:use-module (gnu packages hurd)
47 #:use-module (gnu packages libffi)
48 #:use-module (gnu packages libunistring)
49 #:use-module (gnu packages linux)
50 #:use-module (gnu packages m4)
51 #:use-module (gnu packages multiprecision)
52 #:use-module (gnu packages pkg-config)
53 #:use-module (gnu packages readline)
54 #:use-module (gnu packages sqlite)
55 #:use-module (gnu packages texinfo)
56 #:use-module (gnu packages version-control)
57 #:use-module (guix packages)
58 #:use-module (guix download)
59 #:use-module (guix git-download)
60 #:use-module (guix build-system gnu)
61 #:use-module (guix build-system guile)
62 #:use-module (guix deprecation)
63 #:use-module (guix utils)
64 #:use-module (ice-9 match)
65 #:use-module ((srfi srfi-1) #:prefix srfi-1:))
66
67 ;;; Commentary:
68 ;;;
69 ;;; GNU Guile, and modules and extensions.
70 ;;;
71 ;;; Code:
72
73 (define-public guile-1.8
74 (package
75 (name "guile")
76 (version "1.8.8")
77 (source (origin
78 (method url-fetch)
79 (uri (string-append "mirror://gnu/guile/guile-" version
80 ".tar.gz"))
81 (sha256
82 (base32
83 "0l200a0v7h8bh0cwz6v7hc13ds39cgqsmfrks55b1rbj5vniyiy3"))
84 (patches (search-patches "guile-1.8-cpp-4.5.patch"))))
85 (build-system gnu-build-system)
86 (arguments '(#:configure-flags '("--disable-error-on-warning")
87
88 ;; Insert a phase before `configure' to patch things up.
89 #:phases
90 (modify-phases %standard-phases
91 (add-before 'configure 'patch-stuff
92 (lambda* (#:key outputs #:allow-other-keys)
93 ;; Add a call to `lt_dladdsearchdir' so that
94 ;; `libguile-readline.so' & co. are in the
95 ;; loader's search path.
96 (substitute* "libguile/dynl.c"
97 (("lt_dlinit.*$" match)
98 (format #f
99 " ~a~% lt_dladdsearchdir(\"~a/lib\");~%"
100 match
101 (assoc-ref outputs "out"))))
102
103 ;; The usual /bin/sh...
104 (substitute* "ice-9/popen.scm"
105 (("/bin/sh") (which "sh")))
106 #t)))))
107
108 ;; When cross-compiling, a native version of Guile itself is needed.
109 (native-inputs (if (%current-target-system)
110 `(("self" ,this-package))
111 '()))
112
113 (inputs `(("gawk" ,gawk)
114 ("readline" ,readline)))
115
116 ;; Since `guile-1.8.pc' has "Libs: ... -lgmp -lltdl", these must be
117 ;; propagated.
118 (propagated-inputs `(("gmp" ,gmp)
119 ("libltdl" ,libltdl)))
120
121 (native-search-paths
122 (list (search-path-specification
123 (variable "GUILE_LOAD_PATH")
124 (files '("share/guile/site")))))
125
126 (synopsis "Scheme implementation intended especially for extensions")
127 (description
128 "Guile is the GNU Ubiquitous Intelligent Language for Extensions, the
129 official extension language of the GNU system. It is an implementation of
130 the Scheme language which can be easily embedded in other applications to
131 provide a convenient means of extending the functionality of the application
132 without requiring the source code to be rewritten.")
133 (home-page "https://www.gnu.org/software/guile/")
134 (license license:lgpl2.0+)))
135
136 (define-public guile-2.0
137 (package
138 (name "guile")
139 (version "2.0.14")
140 (source (origin
141 (method url-fetch)
142 (uri (string-append "mirror://gnu/guile/guile-" version
143 ".tar.xz"))
144 (sha256
145 (base32
146 "10lxc6l5alf3lzbs3ihnbfy6dfcrsyf8667wa57f26vf4mk2ai78"))))
147 (build-system gnu-build-system)
148
149 ;; When cross-compiling, a native version of Guile itself is needed.
150 (native-inputs `(,@(if (%current-target-system)
151 `(("self" ,this-package))
152 '())
153 ("pkgconfig" ,pkg-config)))
154 (inputs `(("libffi" ,libffi)
155 ,@(libiconv-if-needed)
156
157 ;; We need Bash when cross-compiling because some of the scripts
158 ;; in bin/ refer to it. Use 'bash-minimal' because we don't need
159 ;; an interactive Bash with Readline and all.
160 ,@(if (target-mingw?) '() `(("bash" ,bash-minimal)))))
161 (propagated-inputs
162 `( ;; These ones aren't normally needed here, but since `libguile-2.0.la'
163 ;; reads `-lltdl -lunistring', adding them here will add the needed
164 ;; `-L' flags. As for why the `.la' file lacks the `-L' flags, see
165 ;; <http://thread.gmane.org/gmane.comp.lib.gnulib.bugs/18903>.
166 ("libunistring" ,libunistring)
167
168 ;; Depend on LIBLTDL, not LIBTOOL. That way, we avoid some the extra
169 ;; dependencies that LIBTOOL has, which is helpful during bootstrap.
170 ("libltdl" ,libltdl)
171
172 ;; The headers and/or `guile-2.0.pc' refer to these packages, so they
173 ;; must be propagated.
174 ("bdw-gc" ,libgc)
175 ("gmp" ,gmp)))
176
177 (outputs '("out" "debug"))
178
179 (arguments
180 `(#:configure-flags '("--disable-static") ; saves 3 MiB
181 #:phases
182 (modify-phases %standard-phases
183 (add-before 'configure 'pre-configure
184 (lambda* (#:key inputs #:allow-other-keys)
185 ;; Tell (ice-9 popen) the file name of Bash.
186 (let ((bash (assoc-ref inputs "bash")))
187 (substitute* "module/ice-9/popen.scm"
188 ;; If bash is #f allow fallback for user to provide
189 ;; "bash" in PATH. This happens when cross-building to
190 ;; MinGW for which we do not have Bash yet.
191 (("/bin/sh")
192 ,@(if (target-mingw?)
193 '((if bash
194 (string-append bash "/bin/bash")
195 "bash"))
196 '((string-append bash "/bin/bash")))))
197 #t))))))
198
199 (native-search-paths
200 (list (search-path-specification
201 (variable "GUILE_LOAD_PATH")
202 (files '("share/guile/site/2.0")))
203 (search-path-specification
204 (variable "GUILE_LOAD_COMPILED_PATH")
205 (files '("lib/guile/2.0/site-ccache")))))
206
207 (synopsis "Scheme implementation intended especially for extensions")
208 (description
209 "Guile is the GNU Ubiquitous Intelligent Language for Extensions, the
210 official extension language of the GNU system. It is an implementation of
211 the Scheme language which can be easily embedded in other applications to
212 provide a convenient means of extending the functionality of the application
213 without requiring the source code to be rewritten.")
214 (home-page "https://www.gnu.org/software/guile/")
215 (license license:lgpl3+)))
216
217 (define-public guile-2.2
218 (package (inherit guile-2.0)
219 (name "guile")
220 (version "2.2.6")
221 (source (origin
222 (method url-fetch)
223
224 ;; Note: we are limited to one of the compression formats
225 ;; supported by the bootstrap binaries, so no lzip here.
226 (uri (string-append "mirror://gnu/guile/guile-" version
227 ".tar.xz"))
228 (sha256
229 (base32
230 "1269ymxm56j1z1lvq1y42rm961f2n7rinm3k6l00p9k52hrpcddk"))
231 (modules '((guix build utils)))
232 (patches (search-patches
233 "guile-2.2-skip-oom-test.patch"))
234
235 ;; Remove the pre-built object files. Instead, build everything
236 ;; from source, at the expense of significantly longer build
237 ;; times (almost 3 hours on a 4-core Intel i5).
238 (snippet '(begin
239 (for-each delete-file
240 (find-files "prebuilt" "\\.go$"))
241 #t))))
242 (properties '((timeout . 72000) ;20 hours
243 (max-silent-time . 36000))) ;10 hours (needed on ARM
244 ; when heavily loaded)
245 (native-search-paths
246 (list (search-path-specification
247 (variable "GUILE_LOAD_PATH")
248 (files '("share/guile/site/2.2")))
249 (search-path-specification
250 (variable "GUILE_LOAD_COMPILED_PATH")
251 (files '("lib/guile/2.2/site-ccache")))))))
252
253 (define-public guile-2.2.7
254 ;; This version contains a bug fix for a relatively rare crash that could
255 ;; affect shepherd as PID 1: <https://bugs.gnu.org/37757>.
256 (package
257 (inherit guile-2.2)
258 (version "2.2.7")
259 (source (origin
260 (inherit (package-source guile-2.2))
261 (uri (string-append "mirror://gnu/guile/guile-" version
262 ".tar.xz"))
263 (sha256
264 (base32
265 "013mydzhfswqci6xmyc1ajzd59pfbdak15i0b090nhr9bzm7dxyd"))))))
266
267 (define-deprecated guile-2.2/bug-fix guile-2.2.7)
268
269 (define-public guile-2.2/fixed
270 ;; A package of Guile 2.2 that's rarely changed. It is the one used
271 ;; in the `base' module, and thus changing it entails a full rebuild.
272 (package
273 (inherit guile-2.2)
274 (properties '((hidden? . #t) ;people should install 'guile-2.2'
275 (timeout . 72000) ;20 hours
276 (max-silent-time . 36000))))) ;10 hours (needed on ARM
277 ; when heavily loaded)
278 (define-public guile-2.2.4
279 (package/inherit
280 guile-2.2
281 (version "2.2.4")
282 (source (origin
283 (inherit (package-source guile-2.2))
284 (uri (string-append "mirror://gnu/guile/guile-" version
285 ".tar.xz"))
286 (sha256
287 (base32
288 "07p3g0v2ba2vlfbfidqzlgbhnzdx46wh2rgc5gszq1mjyx5bks6r"))))))
289
290 (define-public guile-3.0
291 ;; This is the latest Guile stable version.
292 (package
293 (inherit guile-2.2)
294 (name "guile-next") ;to be renamed to "guile"
295 (version "3.0.1")
296 (source (origin
297 (inherit (package-source guile-2.2))
298 (uri (string-append "mirror://gnu/guile/guile-"
299 version ".tar.xz"))
300 (sha256
301 (base32
302 "1jakps3127h8g69ixgb4zwc8v2g29dmwql1vi3pwg30kzp8fm5nn"))
303 (patches
304 (append (search-patches "guile-3.0-crash.patch")
305 (origin-patches (package-source guile-2.2))))))
306 (native-search-paths
307 (list (search-path-specification
308 (variable "GUILE_LOAD_PATH")
309 (files '("share/guile/site/3.0")))
310 (search-path-specification
311 (variable "GUILE_LOAD_COMPILED_PATH")
312 (files '("lib/guile/3.0/site-ccache"
313 "share/guile/site/3.0")))))))
314
315 (define-public guile-next guile-3.0)
316
317 (define* (make-guile-readline guile #:optional (name "guile-readline"))
318 (package
319 (name name)
320 (version (package-version guile))
321 (source (package-source guile))
322 (build-system gnu-build-system)
323 (arguments
324 '(#:configure-flags '("--disable-silent-rules")
325 #:phases (modify-phases %standard-phases
326 (add-before 'build 'chdir
327 (lambda* (#:key outputs #:allow-other-keys)
328 (invoke "make" "-C" "libguile" "scmconfig.h")
329 (invoke "make" "-C" "lib")
330 (chdir "guile-readline")
331
332 (substitute* "Makefile"
333 (("../libguile/libguile-[[:graph:]]+\\.la")
334 ;; Remove dependency on libguile-X.Y.la.
335 "")
336 (("^READLINE_LIBS = (.*)$" _ libs)
337 ;; Link against the provided libguile.
338 (string-append "READLINE_LIBS = "
339 "-lguile-$(GUILE_EFFECTIVE_VERSION) "
340 libs "\n"))
341 (("\\$\\(top_builddir\\)/meta/build-env")
342 ;; Use the provided Guile, not the one from
343 ;; $(builddir).
344 "")
345
346 ;; Install modules to the 'site' directories.
347 (("^moddir = .*$")
348 "moddir = $(pkgdatadir)/site/$(GUILE_EFFECTIVE_VERSION)\n")
349 (("^ccachedir = .*$")
350 "ccachedir = $(pkglibdir)/$(GUILE_EFFECTIVE_VERSION)/site-ccache\n"))
351
352 ;; Load 'guile-readline.so' from the right place.
353 (substitute* "ice-9/readline.scm"
354 (("load-extension \"guile-readline\"")
355 (format #f "load-extension \
356 (string-append ~s \"/lib/guile/\" (effective-version) \"/extensions/guile-readline\")"
357 (assoc-ref outputs "out"))))
358 #t)))))
359 (home-page (package-home-page guile))
360 (native-inputs (package-native-inputs guile))
361 (inputs
362 `(,@(package-inputs guile) ;to placate 'configure'
363 ,@(package-propagated-inputs guile)
364 ("guile" ,guile)
365 ("readline" ,readline)))
366 (synopsis "Line editing support for GNU Guile")
367 (description
368 "This module provides line editing support via the Readline library for
369 GNU@tie{}Guile. Use the @code{(ice-9 readline)} module and call its
370 @code{activate-readline} procedure to enable it.")
371 (license license:gpl3+)))
372
373 (define-public guile-readline
374 (make-guile-readline guile-2.2))
375
376 (define-public guile3.0-readline
377 (make-guile-readline guile-next "guile3.0-readline"))
378
379 (define (guile-variant-package-name prefix)
380 (lambda (name)
381 "Return NAME with PREFIX instead of \"guile-\", when applicable."
382 (if (string-prefix? "guile-" name)
383 (string-append prefix "-"
384 (string-drop name
385 (string-length "guile-")))
386 name)))
387
388 (define package-for-guile-2.0
389 ;; A procedure that rewrites the dependency tree of the given package to use
390 ;; GUILE-2.0 instead of GUILE-2.2.
391 (package-input-rewriting `((,guile-2.2 . ,guile-2.0))
392 (guile-variant-package-name "guile2.0")))
393
394 (define package-for-guile-3.0
395 (package-input-rewriting `((,guile-2.2 . ,guile-next))
396 (guile-variant-package-name "guile3.0")))
397
398 (define-public guile-for-guile-emacs
399 (package (inherit guile-2.2)
400 (name "guile-for-guile-emacs")
401 (version "20150510.d8d9a8d")
402 (source (origin
403 (method git-fetch)
404 (uri (git-reference
405 (url "git://git.hcoop.net/git/bpt/guile.git")
406 (commit "d8d9a8da05ec876acba81a559798eb5eeceb5a17")))
407 (file-name (string-append name "-" version "-checkout"))
408 (sha256
409 (base32
410 "00sprsshy16y8pxjy126hr2adqcvvzzz96hjyjwgg8swva1qh6b0"))))
411 (arguments
412 `(;; Tests aren't passing for now.
413 ;; Obviously we should re-enable this!
414 #:tests? #f
415 ,@(package-arguments guile-2.2)))
416 (native-inputs
417 `(("autoconf" ,autoconf)
418 ("automake" ,automake)
419 ("libtool" ,libtool)
420 ("flex" ,flex)
421 ("texinfo" ,texinfo)
422 ("gettext" ,gettext-minimal)
423 ,@(package-native-inputs guile-2.2)))
424 ;; Same as in guile-2.0
425 (native-search-paths
426 (list (search-path-specification
427 (variable "GUILE_LOAD_PATH")
428 (files '("share/guile/site/2.0")))
429 (search-path-specification
430 (variable "GUILE_LOAD_COMPILED_PATH")
431 (files '("lib/guile/2.0/site-ccache"
432 "share/guile/site/2.0")))))))
433
434 \f
435 ;;;
436 ;;; Extensions.
437 ;;;
438
439 (define-public guile-json-1
440 (package
441 (name "guile-json")
442 (version "1.2.0")
443 (home-page "https://github.com/aconchillo/guile-json")
444 (source (origin
445 (method url-fetch)
446 (uri (string-append "mirror://savannah/guile-json/guile-json-"
447 version ".tar.gz"))
448 (sha256
449 (base32
450 "15gnb84d7hpazqhskkf3g9z4r6knw54wfj4ch5270kakz1lp70c9"))))
451 (build-system gnu-build-system)
452 (native-inputs `(("pkg-config" ,pkg-config)
453 ("guile" ,guile-2.2)))
454 (inputs `(("guile" ,guile-2.2)))
455 (synopsis "JSON module for Guile")
456 (description
457 "Guile-JSON supports parsing and building JSON documents according to the
458 specification. These are the main features:
459
460 @itemize
461 @item Strictly complies to @uref{http://json.org, specification}.
462 @item Build JSON documents programmatically via macros.
463 @item Unicode support for strings.
464 @item Allows JSON pretty printing.
465 @end itemize\n")
466
467 ;; Version 1.2.0 switched to GPLv3+ (from LGPLv3+).
468 (license license:gpl3+)))
469
470 ;; Deprecate the 'guile-json' alias to force the use 'guile-json-1' or
471 ;; 'guile-json-3'. In the future, we may reuse 'guile-json' as an alias for
472 ;; 'guile-json-3'.
473 (define-deprecated guile-json guile-json-1)
474 (export guile-json)
475
476 (define-public guile2.0-json
477 (package-for-guile-2.0 guile-json-1))
478
479 (define-public guile-json-3
480 ;; This version is incompatible with 1.x; see the 'NEWS' file.
481 (package
482 (inherit guile-json-1)
483 (name "guile-json")
484 (version "3.2.0")
485 (source (origin
486 (method url-fetch)
487 (uri (string-append "mirror://savannah/guile-json/guile-json-"
488 version ".tar.gz"))
489 (sha256
490 (base32
491 "14m6b6g2maw0mkvfm4x63rqb54vgbpn1gcqs715ijw4bikfzlqfz"))))))
492
493 (define-public guile3.0-json
494 (package-for-guile-3.0 guile-json-3))
495
496 ;; There are two guile-gdbm packages, one using the FFI and one with
497 ;; direct C bindings, hence the verbose name.
498
499 (define-public guile-gdbm-ffi
500 (package
501 (name "guile-gdbm-ffi")
502 (version "20120209.fa1d5b6")
503 (source (origin
504 (method git-fetch)
505 (uri (git-reference
506 (url "https://github.com/ijp/guile-gdbm.git")
507 (commit "fa1d5b6231d0e4d096687b378c025f2148c5f246")))
508 (file-name (string-append name "-" version "-checkout"))
509 (patches (search-patches
510 "guile-gdbm-ffi-support-gdbm-1.14.patch"))
511 (sha256
512 (base32
513 "1j8wrsw7v9w6qkl47xz0rdikg50v16nn6kbs3lgzcymjzpa7babj"))))
514 (build-system guile-build-system)
515 (arguments
516 '(#:phases (modify-phases %standard-phases
517 (add-after 'unpack 'move-examples
518 (lambda* (#:key outputs #:allow-other-keys)
519 ;; Move examples where they belong.
520 (let* ((out (assoc-ref outputs "out"))
521 (doc (string-append out "/share/doc/"
522 (strip-store-file-name out)
523 "/examples")))
524 (copy-recursively "examples" doc)
525 (delete-file-recursively "examples")
526 #t)))
527 (add-after 'unpack 'set-libgdbm-file-name
528 (lambda* (#:key inputs #:allow-other-keys)
529 (substitute* "gdbm.scm"
530 (("\\(dynamic-link \"libgdbm\"\\)")
531 (format #f "(dynamic-link \"~a/lib/libgdbm.so\")"
532 (assoc-ref inputs "gdbm"))))
533 #t)))))
534 (native-inputs
535 `(("guile" ,guile-2.2)))
536 (inputs
537 `(("gdbm" ,gdbm)))
538 (home-page "https://github.com/ijp/guile-gdbm")
539 (synopsis "Guile bindings to the GDBM library via Guile's FFI")
540 (description
541 "Guile bindings to the GDBM key-value storage system, using
542 Guile's foreign function interface.")
543 (license license:gpl3+)))
544
545 (define-public guile2.0-gdbm-ffi
546 (package-for-guile-2.0 guile-gdbm-ffi))
547
548 (define-public guile3.0-gdbm-ffi
549 (package-for-guile-3.0 guile-gdbm-ffi))
550
551 (define-public guile-sqlite3
552 (package
553 (name "guile-sqlite3")
554 (version "0.1.0")
555 (home-page "https://notabug.org/guile-sqlite3/guile-sqlite3.git")
556 (source (origin
557 (method git-fetch)
558 (uri (git-reference
559 (url home-page)
560 (commit (string-append "v" version))))
561 (sha256
562 (base32
563 "1nv8j7wk6b5n4p22szyi8lv8fs31rrzxhzz16gyj8r38c1fyp9qp"))
564 (file-name (string-append name "-" version "-checkout"))
565 (modules '((guix build utils)))
566 (snippet
567 '(begin
568 ;; Allow builds with Guile 3.0.
569 (substitute* "configure.ac"
570 (("^GUILE_PKG.*")
571 "GUILE_PKG([3.0 2.2 2.0])\n"))
572 #t))))
573 (build-system gnu-build-system)
574 (native-inputs
575 `(("autoconf" ,autoconf)
576 ("automake" ,automake)
577 ("pkg-config" ,pkg-config)))
578 (inputs
579 `(("guile" ,guile-2.2)
580 ("sqlite" ,sqlite)))
581 (synopsis "Access SQLite databases from Guile")
582 (description
583 "This package provides Guile bindings to the SQLite database system.")
584 (license license:gpl3+)))
585
586 (define-public guile2.0-sqlite3
587 (package-for-guile-2.0 guile-sqlite3))
588
589 (define-public guile3.0-sqlite3
590 (package-for-guile-3.0 guile-sqlite3))
591
592 (define-public guile-bytestructures
593 (package
594 (name "guile-bytestructures")
595 (version "1.0.7")
596 (home-page "https://github.com/TaylanUB/scheme-bytestructures")
597 (source (origin
598 (method git-fetch)
599 (uri (git-reference
600 (url home-page)
601 (commit (string-append "v" version))))
602 (file-name (git-file-name name version))
603 (sha256
604 (base32
605 "0q0habjiy3h9cigb7q1br9kz6z212dn2ab31f6dgd3rrmsfn5rvb"))))
606 (build-system gnu-build-system)
607 (arguments
608 `(#:make-flags '("GUILE_AUTO_COMPILE=0") ;to prevent guild warnings
609
610 #:phases (modify-phases %standard-phases
611 (add-after 'install 'install-doc
612 (lambda* (#:key outputs #:allow-other-keys)
613 (let* ((out (assoc-ref outputs "out"))
614 (package ,(package-full-name this-package "-"))
615 (doc (string-append out "/share/doc/" package)))
616 (install-file "README.md" doc)
617 #t))))))
618 (native-inputs
619 `(("autoconf" ,autoconf)
620 ("automake" ,automake)
621 ("pkg-config" ,pkg-config)
622 ("guile" ,guile-2.2)))
623 (inputs
624 `(("guile" ,guile-2.2)))
625 (synopsis "Structured access to bytevector contents for Guile")
626 (description
627 "Guile bytestructures offers a system imitating the type system
628 of the C programming language, to be used on bytevectors. C's type
629 system works on raw memory, and Guile works on bytevectors which are
630 an abstraction over raw memory. It's also more powerful than the C
631 type system, elevating types to first-class status.")
632 (license license:gpl3+)
633 (properties '((upstream-name . "bytestructures")))))
634
635 (define-public guile2.0-bytestructures
636 (package-for-guile-2.0 guile-bytestructures))
637
638 (define-public guile3.0-bytestructures
639 (package-for-guile-3.0 guile-bytestructures))
640
641 (define-public guile-git
642 (package
643 (name "guile-git")
644 (version "0.3.0")
645 (home-page "https://gitlab.com/guile-git/guile-git.git")
646 (source (origin
647 (method url-fetch)
648 (uri (string-append "https://gitlab.com/guile-git/guile-git/uploads/"
649 "4c563d8e7e1ff84396abe8ca7011bcaf/guile-git-"
650 version ".tar.gz"))
651 (sha256
652 (base32
653 "0c5i3d16hp7gp9rd78vk9zc45js8bphf92m4lbb5gyi4l1yl7kkm"))))
654 (build-system gnu-build-system)
655 (native-inputs
656 `(("pkg-config" ,pkg-config)
657 ("guile" ,guile-2.2)
658 ("guile-bytestructures" ,guile-bytestructures)))
659 (inputs
660 `(("guile" ,guile-2.2)
661 ("libgit2" ,libgit2)))
662 (propagated-inputs
663 `(("guile-bytestructures" ,guile-bytestructures)))
664 (synopsis "Guile bindings for libgit2")
665 (description
666 "This package provides Guile bindings to libgit2, a library to
667 manipulate repositories of the Git version control system.")
668 (license license:gpl3+)))
669
670 (define-public guile3.0-git
671 (package-for-guile-3.0 guile-git))
672
673 (define-public guile2.0-git
674 (let ((base (package-for-guile-2.0 guile-git)))
675 (package
676 (inherit base)
677 ;; Libgit2's Guile test driver requires (ice-9 textual-ports), which is
678 ;; not in Guile 2.0. Thus, keep LIBGIT2 as-is here (i.e., built against
679 ;; Guile 2.2).
680 (inputs `(("libgit2" ,libgit2)
681 ,@(srfi-1:alist-delete "libgit2"
682 (package-inputs base)))))))
683
684 ;;; guile.scm ends here
685